Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Fahrvenugen

Pages: [1] 2 3 4
1
Utilities / Re: Where do I find SciTech Display Doctor?
« on: August 17, 2019, 04:36:09 pm »
Hi,

I'd agree with other posts that you are better with either the version of SNAP that is on Hobbes or the version in ArcaOS.  I have to say that while there are reports of SNAP 3.1.8 not working well with SMP, I have run that version with multiple processor machines and not run into the issues reported.

If you do want the older Scitech Display Doctor, IBM did license a "special edition" of SDD version 7  which is still available at:

ftp://service.boulder.ibm.com/ps/products/os2/os2ddpak_cur/sddse704.exe


2
Hi,

As mentioned, check to make sure that hyperthreading is turned off in the BIOS.

Also, since you've mentioned a graphic lockup, which graphic driver are you using?  If you're using either Panaroma or SNAP, try the other one and see if the problem persists?  I've found on a lot of older hardware (and some newer hardware) I have better luck with SNAP

3
Multimedia / Re: Warp with 2 sound cards?
« on: June 06, 2019, 05:44:45 pm »
Lars,

Unfortunately I don't have much programming experience with MMOS2, but I agree that Timur is probably the most knowledgeable.  Most of what he did when he worked for IBM was centered around MMOS2

He's got an email on his website:

http://timur.tabi.org/timur/


4
Multimedia / Re: Warp with 2 sound cards?
« on: June 05, 2019, 09:53:12 pm »
Lars,

With the current state of MMOS2, the fact that IBM essentially abandoned it around the time of Warp 3, I am not surprised that there are bugs.  I certainly would not put any fault in your driver or applet, in fact I applaud your efforts - I'm really impressed with how well your USB audio driver works.

The sad part - there was a time when MMOS2 was near the top of the game - I can recall when the only system that had better multimedia capabilities was the Amiga.  Unfortunately today it can be a challenge just to get a sound card to work.  But I can't say that I'm all that surprised.

Anyways, thanks for your efforts.  I still have an old Warp 3 machine here, it isn't the one that I had from way back when with 2 audio cards, but I might just see if I can get the Warp 3 box I do have going with 2 cards to see if it works the way I remember.  I do recall that when I did have 2 cards working it was on an old machine with all ISA ports (it took quite a bit of fiddling with the jumpers and IRQ's to get it to work... that's how I recall it was an ISA based machine).  Unfortunately I don't remember specific details of any configurations that might have been needed.  1996 was a long time ago!

Cheers!


5
Multimedia / Re: Warp with 2 sound cards?
« on: June 02, 2019, 07:19:10 pm »
Thanks for the replies, I'll have to try again.

Lars, I did recently install your USB drivers, but had not paid close attention to the applet for changing the default.  I'll have a look at that, it may be partly what I need.

I'll also have to try out PlayRec, it looks like it may do what I want. 

Thanks!

6
Multimedia / Warp with 2 sound cards?
« on: June 02, 2019, 06:49:39 am »
Hi,

I remember back in the Warp 3 days I had at one point managed to find a way to get Warp to recognize and be able to use 2 sound cards at the same time, each able to do different things - either playing different audio out each card, or having one doing a record the other a playback, or both recording different things at the same time.

Does anyone know if this is still possible with current drivers?  I know that MMOS2 is still pretty much the same as it was in the Warp 3 days so I imagine it can still  handle it, but drivers -  particularly UniAud and some of the CMI and SBLive drivers don't seem to be able to handle this, at least I have not had much luck.

Anyone know if this is still possible?

7
Multimedia / Re: SYBA USB Stereo Sound Adapter: Good or bad?
« on: June 02, 2019, 05:27:04 am »
Lars,

I do want to thank you for all your work on OS/2 over the years.  I've got a bunch of cheap USB-Audio adapters that I picked up for around $1 each, based on the CM108 chipset.  I was happy to find that it works well with your USB driver.

My only complaint about it is that its record channel is only mono, but that's a limitation of the hardware and has nothing to do with your driver.  I actually found that - when recording from it in mono I got better results then when I tried similar tests under Windows (which gives the occasional choppiness).  Playback to the USB dongle works well, overall I'm very impressed.

Best!

8
Utilities / Re: best process killer application
« on: January 17, 2019, 10:03:47 pm »
I know it is quite old by the standards of others that have come out since, but I still like WatchCat


9
Applications / Re: The Java drama and the OS/2 Community.
« on: November 10, 2018, 08:45:39 pm »
The dissapointing part of all of this is how far Java has diverged from its original promise.

Originally it was "write once, run anywhere".  Part of this  implied that your apps would run on all future versions of Java on all future platforms.  The idea that all versions of the Java runtime were (in theory) going to be backwards compatible with previously released versions. 

Unfortunately this got abandoned quickly.  Java apps that require a specific version of the Java runtime, and in some cases I've even seen Java stuff that requires both a specific version of Java on a specific OS.

10
Setup & Installation / Re: OS2 Warp Version 3 wont boot from Hard Drive
« on: October 19, 2018, 10:19:30 pm »
This could be two things.  Just re-reading your original post it sounds like it'll boot with a CD drive installed, but once you disconnect the CD drive it won't boot.

First double check the jumpers on your hard disk.  There will either be a jumper setting for "single" *or* if there is no setting for "single" try pulling the jumper out entirely.  Some of those old drives would default to single if no jumper was installed.  Some BIOSes -  especially older ones, if they see a "master" drive on the IDE bus they'll then look for a "Slave" on that bus too.  If they don't find it they'd come to a grinding halt.

The second thing it could be, if it is starting to initially boot but then stopping, the original release of Warp 3 had a very buggy IDE driver (ibm1s506 and others).  Back in the day I had a 386 which would boot Warp 3 when the CD drive was *not* plugged in but as soon as it was plugged in it would crash.  IBM released a fix for the buggy drivers on the install disks at:

ftp://service.boulder.ibm.com/ps/products/os2/fixes/v3.0warp/english-us/warpinst/

If it is a driver issue that might fix it.


11
Hi,

For Warp 3 non-connect, you'll need to install MPTS.  Technically MPTS is only licensed for Warp 3 Connect or Warp 4, Warp Server, Warp Server for eBusiness, MCP, but it'll work on plain old non-connect Warp 3 and IBM still has it posted on one of their public FTP servers.  I doubt IBM is all that worried about people using MPTS on non-connect Warp 3...

There are 2 versions - a 16 bit version and the 32 bit version.  Pick one of them but not both.  Both will work with the TCP apps included in the bonuspack (although I think there were a few minor incompatibilities with the 32 bit stack and the Bonuspack TCP apps, but it didn't cause major problems).  As I recall some newer apps will only work with the 32 bit version, but (and it's been a while since I've set up a Warp 3 box) there was some file in the 32 bit stack that if I recall you had to swap out to make it work.  Anyways, here's where you can grab what you need.

The 16 bit version you can grab from here:
ftp://service.boulder.ibm.com/ps/products/mpts/fixes/english-us/wr08423_conv/

And then there is a fixpack for it at:
ftp://service.boulder.ibm.com/ps/products/mpts/fixes/english-us/wr08425_conv/

Or the 32 bit stack is at:

ftp://service.boulder.ibm.com/ps/products/mpts/fixes/english-us/wr08610_conv/

With a fixpack
ftp://service.boulder.ibm.com/ps/products/mpts/fixes/english-us/wr08621/

Additional fix to fix a random stack crash in the 32 bit stack:
http://hobbes.nmsu.edu/download/pub/os2/system/patches/newstack.zip

If I recall you first install the TCP internet connection kit from the bonuspack (use the selective install - some of the stuff like the newsreader and email client you don't really need).  Then install the base MPTS, then the fixpak for the MPTS you've installed, and then if you've gone with the 32 bit stack the newstack.zip

You'll want to use one of the newer Firefox builds.  Most should work with Warp 4.52, but I can't recall what the last one to work with Warp 3 was.  You'll definitely need to instal Warp Fixpak 40 if you're running 3.

I still have a couple of Warp 3 connect systems that I maintain running.  To be honest it has been so long since I set them up that I can't recall all the steps, but like Warp 3 has always done for me, they just keep on doing what they do best without crashing.


12
Programming / Re: SIO, SIO2K
« on: August 08, 2018, 09:38:19 pm »
As Neil said, I am guessing similar - if someone familiar with 386 assembler can meet with Ray for a period of time to learn what can be learned about the source, then this would be much more useful then just a bunch of code and having to guess at how to build it.

As a registered user of SIO, I still use it to this very day.  There continue to be things it can do which IBM's drivers can't.


13
Storage / Re: Help! I don't want losing my data.
« on: June 15, 2018, 11:13:52 pm »
I agree that the last time I tried the NTFS driver in OS/2 it did not work very well and is read-only.  I would not recommend it.

As suggested the best-case situation is to make your common data partition a FAT32 partition.  Then you can see it from both OS/2 and Windows.  It works but you do have to jump through a few hoops to make it work.

The other option - if the system is going to be used in a home environment (not a mobile environment) is to put your data drive on a network drive, build something like a NAS.  There are a few benefits to this:

1. If Windows, OS/2, or any other OS you might run (Linux, BSD, etc) can see your NAS then you can likely access your files.
2. If you have more then one computer at your location, you can access your files from any computer
3. If a end-user computer happens to crash or die - due to either hardware or software failure - your files should still be safe if your NAS is still safe
4. It is easy to backup a NAS - either build another NAS as a backup for your files, or use any of the "cloud-based" backup options and have the NAS automagically backup/sync your files to a server somewhere on the internet
5. If you want to test another OS, you can safely wipe your computer without having to worry about your files - they're on another system after all.

I know for many people running a network share at their home would be overkill, but depending on the situation sometimes it is a better option then storing files on a local PC.

14
Setup & Installation / Re: OS/2 Warp 3 Installation Issue
« on: March 26, 2018, 03:44:03 am »
Hi,

A few thoughts.

If you have not already, grab warpinst.exe from IBM and copy replace older files on your boot disk(s) with files in the archives. Especially anything dealing with SCSI since you're working with a SCSI system - with perhaps the exception of the drivers that actually work with your SCSI card.  You can grab this file from:

ftp://service.boulder.ibm.com/ps/products/os2/fixes/v3.0warp/english-us/warpinst/

Yes, IBM still has OS/2 files available on its FTP servers!

The system memory should not be a problem.  The main issue with Warp 3 was that if the system had more then 64 MB, then Warp would not see memory above 64 MB. Once installed and up and running you can use patchldr from Hobbes to see the "extra" memory - up to 512 MB as I recall (the Warp 3 kernel has  a 512 MB limit)

http://hobbes.nmsu.edu/h-search.php?key=patchldr&pushbutton=Search

For the hard disk, there is a limit on how big the boot drive partition can be in Warp 3.  The boot partition for OS/2 must be with the first 1024 cylinders of the disk - if the end of your boot partition is beyond the first 1024 cylinders then the install won't complete, the system won't boot.

For starters - try the install using the Advanced install, go into FDISK when it lets you do so, and delete all partitions on the drive.  Select the option to write the changes to the disk and then reboot - power down, boot back up with your floppies selecting the Advanced install.

After the reboot see if it'll let you install Boot Manager and create a parition on your drive.  Your boot partition does not need to be very big.  Remember this is Warp 3 which came out originally in 1994.  200 MB is adequate for the OS install, in fact the original manual recommends 25 to 55 MB for the boot partition (although I do recommend more since - after you get things like TCP/IP, stuff from the bonus pack, and Fixpak 40 installed you'll need more then 55 MB).  Assign your Boot partition as Startable and assign it as Drive C (if FDISK doesn't do this already, I can't recall - it has been a few years since I did a Warp 3 install from original install disks).  Exit FDISK and select the option to write the changes to disk.

On Warp 3 installs I've often gone with 500 MB boot drives with success.  Note that making sure the boot partition is within the first 1024 cylinders of the drive should take care of the issue that Bogdan is talking about suggesting a smaller then 8 GB drive.   If Warp can see the drive itself (which is suggested based on the posted screen shots), then it is more likely a problem that the partition is just too big.

Note - if Warp 3's fdisk won't let you partition the drive properly you may have to use something like DFSee as suggested in an earlier post.

If I recall correctly you'll have to reboot again with your floppies, again select the Advanced install.  See if you can get it to the section where it'll let you format the partition - use HPFS - and if it'll do that then hopefully it'll go through the rest of the install.

** On some systems it'll get through the first part of the installation process, will try and boot to the hard disk to continue the process, and it'll fail to boot.  On these systems if it gets through the text-based install but fails to boot to the graphicall install part, try the following:

1.  Boot with your floppies, when it gets to the "select easy install or advanced" it also has an option to press F3 to go to a command prompt/exit.  Press F3

2.  From the command prompt, type:

sysinstx c:

You might need to search around to figure out which floppy the sysinstx utility is on - if I recall it is on either disk 1 or 2, you can do a dir command at the promot to see the floppy directory / contents.

Assuming it does not come up with an error, pull your floppy out and reboot with CTRL-ALT-DEL

Sysinstx is a utility on one of the boot floppies that'll transfer some of the main boot files over to the hard disk specified.  The installation app is supposed to do this for you, but it doesn't always work.

Also a few hints during install.  If you do get to the point of the graphical desktop and graphical install, do NOT try and install video drivers / sound drivers during install.  Just let it do its thing using VGA and such.  I've seen the installer crash while trying to install these drivers during an initial install. You can always install them once your desktop is up and running.

Hope this helps.


15
This sounds fantastic, I can't wait to try it out.

Are the additional sample rates available to any audio adapter, or just USB?

Just wondering - I've got a couple of Warp boxes running audio logging 24x7, I'd love to be able to up the sample rate (they're using onboard audio cards supported via Uniaudio). 

I could of course switch these 2 systems over to using USB audio cards if needed.


Pages: [1] 2 3 4