Author Topic: FM/2 loading issue  (Read 543 times)

Ben

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 3
  • Posts: 182
  • Know Thyself
    • View Profile
FM/2 loading issue
« on: February 28, 2018, 03:09:34 pm »
I have been using FM/2 for many years back until the 90s when I bought a license from Mark Kimes.

However, recently FM/2 has been failing to load and the attached image pops up. There are no error logs generated anywhere and no indication that anything else is wrong. I have reinstalled, used existing older copies, restored old desktops and perused my Config.sys, (which has the appropriate FM/2 statements still there and intact), but all to no avail.

Has anyone encountered this problem before or have a suggestion or a solution?

Thanks.

David Graser

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 7
  • Posts: 183
    • View Profile
Re: FM/2 loading issue
« Reply #1 on: February 28, 2018, 03:13:26 pm »
Ben

Try deleting your FM3.ini file.  Then open FM/2 again.  You are going to have to go back and redo your properties settings.

David

Ben

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 3
  • Posts: 182
  • Know Thyself
    • View Profile
Re: FM/2 loading issue
« Reply #2 on: February 28, 2018, 03:44:45 pm »
My first thought was of FM/2 INI corruption as referenced in the popup; I used known good ones, (I have generations), I opened FM/2 without any fm3.ini file, (I deleted it, to force FM/2 to recreate one). I also deleted the references to FM/2 in the OS2 INI file as well. No change. Very strange.

I looked for FM/2 dependencies outside of the FM/2 folder and as far as I am aware there are none.

I had made some recent changes in my Config.sys but only as relates to the *:\usr directory(s) and my \Python paths etc. I also used known good Config.sys files as well, going back several generations; still no change. Very strange.

I even restored the desktop using Unimaintenance and OS/2 archives. Nothing.

I suspect that some *.dll or driver has crept in there somewhere and is interfering with the loading process, but I'll be damned if I know what it could be. I have changed nothing in that regard... at least, not by intent.

David Graser

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 7
  • Posts: 183
    • View Profile
Re: FM/2 loading issue
« Reply #3 on: February 28, 2018, 04:12:01 pm »
What version of FM/2 are you using?  The last version was 3.24.

The latest version can be found here

ftp://ftp.netlabs.org/pub/fm2/fm2-3-24-0.wpi

and if you prefer an earlier version at the same location:

ftp://ftp.netlabs.org/pub/fm2

David
« Last Edit: February 28, 2018, 04:41:41 pm by David Graser »

Ben

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 3
  • Posts: 182
  • Know Thyself
    • View Profile
Re: FM/2 loading issue
« Reply #4 on: February 28, 2018, 05:45:31 pm »
Yep. Latest version; October 24 2015 3.24.

Though I tried some older versions as well; no difference.

David Graser

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 7
  • Posts: 183
    • View Profile
Re: FM/2 loading issue
« Reply #5 on: February 28, 2018, 07:52:58 pm »
Yep. Latest version; October 24 2015 3.24.

Though I tried some older versions as well; no difference.


Ben the only other thing I can think of is to uninstall FM/2 and delete the FM2 directory and any files that may be left in it, provided the directory still exist.  Then try reinstalling again.

David

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 27
  • Posts: 780
    • View Profile
Re: FM/2 loading issue
« Reply #6 on: February 28, 2018, 10:00:17 pm »
A long shot but have you run CHECKINI.EXE  from wptools and CLEANINI.EXE to be certain that your OS2 ini files are clean and don't have any odd paths that might be causing the problem?

Ben

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 3
  • Posts: 182
  • Know Thyself
    • View Profile
Re: FM/2 loading issue
« Reply #7 on: March 01, 2018, 01:08:22 am »
Using known good backups of INI files would take care of that Ivan.

I also do regular cleaning of the OS2*.iNI files.

With regards to deleting and reinstalling... I believe that FM/2 is confined to the folder by the same name. However, I'm willing to give it a shot.

Ben

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 3
  • Posts: 182
  • Know Thyself
    • View Profile
Re: FM/2 loading issue
« Reply #8 on: March 11, 2018, 09:11:50 pm »
Just FYI, my os2*.ini file(s) was getting corrupted.

When I fixed that problem and restored from them from backups the problem went away. Strangely enough the problem was also affecting other *.INI files lime those in EPM.