Author Topic: OS/4 (technical details only)  (Read 49815 times)

OS4User

  • Sr. Member
  • ****
  • Thank You
  • -Given: 96
  • -Receive: 16
  • Posts: 306
  • Karma: +9/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #225 on: June 14, 2020, 10:02:05 am »
usb 12.4 and older AN usb drivers are also working with OS4 kernel, 12.5 breaks that. The bad thing is that without usb 12.6 I have no usb 3 and without OS4 kernel I have no working virtualbox for os/2.

Still hope it will be fixed  in 12.07.

BTW: USBD.SYS is before all USB?HCD.SYS statements in my config.sys and the settings are properly choosen.

Coming back to your logs, what I can see  is:

1)
Code: [Select]
Symbols linked (usbuhcd)
Symbols linked (usbuhcd)
Symbols linked (usbuhcd)
Symbols linked (usbehcd)
Symbols linked (ibmkbd)
Symbols linked (usbd)

it means  that  usbd.sys line is  after usb?hcd.sys lines

2)

MaxProcesses = 1025

If you do not really need that many processes at the same time  -  it has a sense to reduce this setting (the same for THREADS=)  otherwise   it just waste of memory in  system arena.

3)

VAL = 1536

Saving mem in system arena (proper THREADS= and PROCESSES= ) allows you to set VAL much higher   even 3072, what increase your  high privet/shared arenas.

Pls check - may be you refer to config.SYS  but not config.OS4



Igor

  • Newbie
  • *
  • Thank You
  • -Given: 6
  • -Receive: 9
  • Posts: 34
  • Karma: +8/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #226 on: June 16, 2020, 09:00:18 pm »
I noticed that new BASEDEV drivers (USB 12.05+) from Arca do not display diagnostic messages when booting with the OS / 4 kernel and not load. Perhaps the problem is only in the driver loader itself. This gives us hope that the problem can be quite easily fixed.

Bernhard Pöttinger

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 27
  • Karma: +1/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #227 on: June 17, 2020, 07:16:42 pm »
I noticed that new BASEDEV drivers (USB 12.05+) from Arca do not display diagnostic messages when booting with the OS / 4 kernel and not load. Perhaps the problem is only in the driver loader itself. This gives us hope that the problem can be quite easily fixed.

I  have placed an bug report on AN bug tracker. Will see what they are saying. I will post the answer.
 
Bernhard
Modify message

Bernhard Pöttinger

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 27
  • Karma: +1/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #228 on: June 18, 2020, 11:10:42 am »
I noticed that new BASEDEV drivers (USB 12.05+) from Arca do not display diagnostic messages when booting with the OS / 4 kernel and not load. Perhaps the problem is only in the driver loader itself. This gives us hope that the problem can be quite easily fixed.

I  have placed an bug report on AN bug tracker. Will see what they are saying. I will post the answer.
 
Bernhard
Modify message

That is the answer from AN:

Quote
Regardless what any other kernel (legal or illegal) may offer, Arca Noae has no intention of providing support for non-Arca Noae kernels.

If the request is that we add support for a feature not currently implemented in the ArcaOS kernel, that is a separate matter, and such requests are accepted for consideration.

As described here, the configuration on your system is completely unsupported by Arca Noae (not just the USB stack).

Our best recommendation is to use a legal, supported kernel, specifically, the one supplied with ArcaOS.

(I, too, use a browser in a box" solution under VBox 1.6 on ArcaOS, which works just fine for running small Linux distros, with Arca Noae kernels 14.200 and 14.201.)

The case is closed by Lewis.

OS4User

  • Sr. Member
  • ****
  • Thank You
  • -Given: 96
  • -Receive: 16
  • Posts: 306
  • Karma: +9/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #229 on: June 18, 2020, 08:07:34 pm »

That is the answer from AN:

Quote
Regardless what any other kernel (legal or illegal) may offer, Arca Noae has no intention of providing support for non-Arca Noae kernels.

The case is closed by Lewis.

Actually,  it sounds not that bad. Lewis just said  that there is no support for OS/4 configured system - and his position is easy to understand.  I and still hope that 12.07  will  work  with OS/4  as 12.04 did. It seems that majority of people will accept the absence of support from AN in this case.


G. M. Anchieri

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 19
  • Karma: +4/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #230 on: January 10, 2021, 03:39:11 pm »
Hi OS4USER,

I have some problem using your Kernel, I install a new version of your SVN.... every two or three month to test it (last version installed is SVN5971).

1) during the loading of CONFIG.SYS file don't accept anymore this statement on line 186 of it:
    DEVICE=H:\IBMLAN\NETPROG\VNETAPI.OS2
    this statement has been installed by IBM DB2 for OS2 version 1.72 (last version for OS2),
    previous version of SVN58.. and part of SVN59.. accepted it, it's a regression?.

2) I use frequently my Lotus Smart Suite  (last version 1.73), but I can't open or use a Spread Sheet
    with your kernel, because the system hang almost immediately, and I have to reboot manually CAD
    don't function.
    I can use WordPro (from the same suite) without hang the system.

Please, do you can investigate, and possibly, resolve this two question?

Thank you very much for your great work done,   G.M. Anchieri

OS4User

  • Sr. Member
  • ****
  • Thank You
  • -Given: 96
  • -Receive: 16
  • Posts: 306
  • Karma: +9/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #231 on: January 10, 2021, 06:27:01 pm »
Hi

OS/4 kernel is maintained by OS/4 Team.


1) during the loading of CONFIG.SYS file don't accept anymore this statement on line 186 of it:
    DEVICE=H:\IBMLAN\NETPROG\VNETAPI.OS2
    this statement has been installed by IBM DB2 for OS2 version 1.72 (last version for OS2),
    previous version of SVN58.. and part of SVN59.. accepted it, it's a regression?.

It is definitely a regression.  I have just tested   VNETAPI.OS2  size of  35 840 bytes on my comp  -  it was loaded ok.  Is your VNETAPI.OS2 same size ?  If no  it would be great  if you could provide it to me for test purposes. Another way   is to find out the first ver with this regression.

2) I use frequently my Lotus Smart Suite  (last version 1.73), but I can't open or use a Spread Sheet
    with your kernel, because the system hang almost immediately, and I have to reboot manually CAD
    don't function.
    I can use WordPro (from the same suite) without hang the system.

Please, do you can investigate, and possibly, resolve this two question?

I do not have Lotus Smart Suite  -  pls find out  what ver this regression came from.

Please, do you can investigate, and possibly, resolve this two question?

Tnx for nice words, the investigation has just started. :)
« Last Edit: January 10, 2021, 06:43:30 pm by OS4User »

G. M. Anchieri

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 19
  • Karma: +4/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #232 on: January 11, 2021, 10:22:16 am »
first question - my VNETAPI.OS2 is dated 10-10-2001 and is of  24167 bytes. 
second question - spread sheet is never functioned with every version of kernel that I have tested before.

I have write on this forum because now this kernel work with all other program that I use to day
inclusive of VBOX vers. 5051 (with running Win 7 pro) and Lotus that is a must to have for me.

my hardware is a:
ASUS PRIME B250-A with four core in Hypertrading and VT-x instruction 8GB of RAM.

Thank you very much for your response to my question if you want other information I can give you my
eMail :

G.M. Anchieri 
« Last Edit: January 12, 2021, 12:34:32 pm by G. M. Anchieri »

Andreas Schnellbacher

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 37
  • Posts: 709
  • Karma: +9/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #233 on: January 11, 2021, 08:57:52 pm »
eMail: ...
Hi Guilio, please don't post email addresses in a publicly accessible forum. Even don't do that, when it's your own one. Please use the edit function to remove it. You may have described it in words to avoid automatic scanning of things like that. Note that even something like (at) is easily recognized.

G. M. Anchieri

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 19
  • Karma: +4/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #234 on: January 15, 2021, 09:49:31 am »

I have some problem using your Kernel, I install a new version of your SVN.... every two or three month to test it (last version installed is SVN5971).

1) during the loading of CONFIG.SYS file don't accept anymore this statement on line 186 of it:
    DEVICE=H:\IBMLAN\NETPROG\VNETAPI.OS2
    this statement has been installed by IBM DB2 for OS2 version 1.72 (last version for OS2),
    previous version of SVN58.. and part of SVN59.. accepted it, it's a regression?.

Great, this bug has been resolved in a few day in SVN5976,
thank very much to the Team of OS4
G.M. Anchieri 

Igor

  • Newbie
  • *
  • Thank You
  • -Given: 6
  • -Receive: 9
  • Posts: 34
  • Karma: +8/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #235 on: January 15, 2021, 11:01:54 am »
2) I use frequently my Lotus Smart Suite  (last version 1.73), but I can't open or use a Spread Sheet
    with your kernel, because the system hang almost immediately, and I have to reboot manually CAD
    don't function.
    I can use WordPro (from the same suite) without hang the system.
I repeated this in a virtual machine(OS/4 guest in OS/4 host). I have correctly worked Lotus 123 with the OS / 4 kernel. But the virtual machine has 1 processor. Try turning off a lot of cpu for the test. It's interesting to check it out. If it works, then you can mark the executable files to run on one processor.

G. M. Anchieri

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 19
  • Karma: +4/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #236 on: January 20, 2021, 11:42:34 am »
2) I use frequently my Lotus Smart Suite  (last version 1.73), but I can't open or use a Spread Sheet
    with your kernel, because the system hang almost immediately, and I have to reboot manually CAD
    don't function.
    I can use WordPro (from the same suite) without hang the system.
I have resolved this  question, after lined up my config.os4 to config.sys, I can use my Lotus 123 without great problem, but in some case using mouse block the system, I have to test it with one CPU as suggested by Igor.
G.M. Anchieri

G. M. Anchieri

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 19
  • Karma: +4/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #237 on: March 27, 2021, 10:13:50 am »
To all user of os4kernel,
BWW is porting the new QT5 TO OS2, but QT5 new Web Engine e/o Chrome, contain AVX instruction that inhibit  program compiled with GCC 9.2 to work with OS4KERNEL, I have tested 3 program: FFMPEG, (last version in RPM/YUM), QT5WEB and also card game HEARTS, all give immediately a trap (in OS2 Kernel all run).
Do Can the BWW resolve this issue? If not the user of OS4KERNEL has to face a dark night.

G.M. Anchieri   

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 590
  • -Receive: 121
  • Posts: 3252
  • Karma: +26/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: OS/4 (technical details only)
« Reply #238 on: March 27, 2021, 04:58:33 pm »
Hi G. M. Anchieri

I recommend you to open a ticket on "https://github.com/bitwiseworks/qtwebengine-os2" (explain things in detail). The Bitwise guys does not visit this forum regularly and does not read all threads.
Possible they would like to focus first on having the browser on ArcaOS (with regular kernel) first, and maybe later they can check on that.

I think that opening a ticket will be a good "heads up" for them, but I can not predict their answer.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Mentore

  • Jr. Member
  • **
  • Thank You
  • -Given: 19
  • -Receive: 3
  • Posts: 77
  • Karma: +1/-0
    • View Profile
Re: OS/4 (technical details only)
« Reply #239 on: March 27, 2021, 05:55:41 pm »
Hi G. M. Anchieri

I recommend you to open a ticket on "https://github.com/bitwiseworks/qtwebengine-os2" (explain things in detail). The Bitwise guys does not visit this forum regularly and does not read all threads.
Possible they would like to focus first on having the browser on ArcaOS (with regular kernel) first, and maybe later they can check on that.

I think that opening a ticket will be a good "heads up" for them, but I can not predict their answer.

Regards

Truth be told, since (as far as I can remember) OS/4 is still kind of an unauthorized work it is definitely possible that this problem will not be solved. Even so, it may be worth a try, since if I'm not mistaken there are other problems with AVX under OS/2.

It's really too much time I don't fiddle anymore with my OS/2 machines. Definitely time to put these two up again. So much work to do, so little time...

Mentore