Author Topic: Installing eCS 2.1 on ibm x41, unicode error  (Read 307 times)

Jaroslav

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
    • View Profile
Installing eCS 2.1 on ibm x41, unicode error
« on: May 15, 2018, 02:49:35 pm »
Hello, dear community!
I have an old Thinkpad x41 with a pentium m processor. I am trying to install eCS 2.1 off an external dvd. I have checked the "external cd" in boot options, hited f10, and the setup is forever frosen on ecs blue logo, with no spining cd activity.
I have selected an ahci and to output log option, and the error is = 14, saying something like  can not get codepage unicode 850, or something like that. But the error code is definitely = 14.
Thanks in advance.
« Last Edit: May 15, 2018, 03:00:59 pm by Jaroslav »

Neil Waldhauer

  • Sr. Member
  • ****
  • Thank You
  • -Given: 6
  • -Receive: 20
  • Posts: 341
    • View Profile
    • Blonde Guy
Re: Installing eCS 2.1 on ibm x41, unicode error
« Reply #1 on: May 15, 2018, 03:22:23 pm »
The X41 has an unusual hard drive. Try DaniS506 instead of AHCI.
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Jaroslav

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
    • View Profile
Re: Installing eCS 2.1 on ibm x41, unicode error
« Reply #2 on: May 15, 2018, 08:11:55 pm »
It is already in Danis506 perfomance mode. When not perfomance mode, but compability mode, then occurs an unspecified error.
Codepage has nothing to do with the drive, it is i think a problem with the fact that laptop is russian?

Jaroslav

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
    • View Profile
Re: Installing eCS 2.1 on ibm x41, unicode error
« Reply #3 on: May 15, 2018, 08:15:23 pm »
The exact name of the error is

Unicode - unable to load codepage 850
Error = 14

And

Unicode - unable to load codepage 437
Error = 14

Jaroslav

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
    • View Profile
Re: Installing eCS 2.1 on ibm x41, unicode error
« Reply #4 on: May 15, 2018, 08:36:07 pm »
After i try to select another codepage, it says that the parameter 855 on line 87 of the config.sys file is not acceptable for the codepage statement, line will be igbored

And the installation is frozen again...

Andreas Schnellbacher

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 299
    • View Profile
Re: Installing eCS 2.1 on ibm x41, unicode error
« Reply #5 on: May 15, 2018, 10:21:17 pm »
Have you already tried another kernel?

Jaroslav

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
    • View Profile
Re: Installing eCS 2.1 on ibm x41, unicode error
« Reply #6 on: May 24, 2018, 06:41:38 pm »
what do you mean saying "another kernel"? OS/2 kernel are not compatible with Ecs, AFAIK, and ECS are not available to download, do i need to buy it? If so, where is guarantee that it will work?

Olafur Gunnlaugsson

  • Full Member
  • ***
  • Thank You
  • -Given: 27
  • -Receive: 8
  • Posts: 110
    • View Profile
Re: Installing eCS 2.1 on ibm x41, unicode error
« Reply #7 on: May 24, 2018, 07:42:09 pm »
The exact name of the error is

Unicode - unable to load codepage 850
Error = 14

And

Unicode - unable to load codepage 437
Error = 14

What language and code page choices did you make at the start of the installer?

Jaroslav

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
    • View Profile
Re: Installing eCS 2.1 on ibm x41, unicode error
« Reply #8 on: May 24, 2018, 07:55:17 pm »
i changed nothing from the default - as you see in a error message it is 850 and 437
When i try to change this values before starting an installation, the debug mode shows me a message, saying that the codepage numbers are set up wrong. My installation is in another room now, i cannot say exact error text,  but if you need it, i would get it

guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 14
  • Posts: 273
    • View Profile
Re: Installing eCS 2.1 on ibm x41, unicode error
« Reply #9 on: May 24, 2018, 10:28:46 pm »
It should not make any difference that the laptop is Russian. All that means is different key caps) The hardware is the same. Does it stop in fase 1 of the installation, i.e. before booting from hard disk?

David Graser

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 7
  • Posts: 165
    • View Profile
Re: Installing eCS 2.1 on ibm x41, unicode error
« Reply #10 on: Today at 04:09:30 am »
I tried to install eCS 2.1 on my thinkpad X220 notebook a while back.  It too would freeze at the eCS logo.  Tried several times, but always the same result.  Then tried ArcaOS 5.02 on same computer and installation was no problem.  At the time, I was wanting to boot to eCS or ArcaOS.

Jaroslav

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
    • View Profile
Re: Installing eCS 2.1 on ibm x41, unicode error
« Reply #11 on: Today at 09:11:34 am »
Does it stop in fase 1 of the installation, i.e. before booting from hard disk?

Dont even know, i would guess not, simply because in normal mode it just freeze on the logo on the first second, in debug mode it writes down the mentioned above message in ~10 seconds, without saying anything about hddboot.
And what do you mean "different keycaps"? How would i fix this?
Thanks in advance.

Jaroslav

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 8
    • View Profile
Re: Installing eCS 2.1 on ibm x41, unicode error
« Reply #12 on: Today at 09:18:26 am »
And sorry, i wont spend another 120 dollars on the os without a guarantee to boot. I mean Arca. You know, freaking 2014 crisis, dollar prices has risen by 2 times, and now 120 dollars are simply 240, which is too costly for the os with a risk of not installing too.
But if someone could provide me a free DEMO of Arca to test of installing abillity, i would be very thankfull. I simply did not find it.