Author Topic: PMSHELL  (Read 955 times)

Dariusz Piatkowski

  • Sr. Member
  • ****
  • Thank You
  • -Given: 13
  • -Receive: 8
  • Posts: 453
    • View Profile
Re: PMSHELL
« Reply #15 on: August 03, 2018, 05:59:44 pm »
Hi Lars,

Whenever you have data in a data segment that is marked to load high you will get in deep shit trouble if that data needs to be passed for access by a 16-bit DLL...It should be obvious that it is almost impossible to know if data will eventually be accessed by 16-bit code and therefore it is a bad idea in general to mark data segments to load high...

Thank you, that is a great explanation and certainly on my part that means the safest route would be to mark code only for highmem load.

Remy

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 7
  • Posts: 132
    • View Profile
Re: PMSHELL
« Reply #16 on: August 03, 2018, 07:11:33 pm »
That much sounds like a memory leak either in some WPS class (which is likely, given its lousy stability) or even in the memory subsystem (which is rather unlikely, compared to option 1).

But this memory leakage problem is not related to the question of low/high memory arena. It is likely a problem of dynamically allocated memory that is not properly freed when no longer in use. Since every WPS class remains loaded for as long as PMSHELL is executing, that memory will be leaked until you shut down the system or do a WPS restart.

As a test: if you observe this leakage, just do a WPS restart (via XWorkplace/eWorkplace) and see if that brings back the lost memory.

- Wen it was possible, I did use it, it release about 50% of unreased storage but at the end, it goes into too low available shared storage below 512M
I saw that openoffice 4.1.3 does load dll in highmem. I flagged then to go in highmem and now it does it but I also saw that each time I close openoffice (only a fex MB of storage are release in below shared memory and none in high memory) and at each load, it load near 100MB into shared memory. After 3 start/stop, I lost about 300MB of shared memory... and so on. I tried to use C.A.D and do a WPS restart at time I saw my high shared storage dropped to about 100MB (virualaddresslimit=1536 and previously, I tried 2048 as well 2560), but this results into a bad screen display (like if out of frequence syncro) + hung = reboot.
- Firefox release well storage at stop time like other some other products or rexx based exe...
Strange...  Strange too having (when a few appls are running and some folders opened, at close of some folders or programs, parts of folder image or program image are persistent and when moving an othe rfolder above it, it does like a gum but seems to generate a lot of unstability...     
 
I think resolving this part of problem could improve a lot system stability and programs developments.     
« Last Edit: August 03, 2018, 07:13:13 pm by Remy »