Author Topic: Lucide 141b9 or 141b10  (Read 418 times)

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 14
  • -Receive: 7
  • Posts: 407
    • View Profile
Lucide 141b9 or 141b10
« on: October 06, 2018, 02:26:19 pm »
After downloading and installing the wpi the pdf plugin is installed but it does not work. When I open the plugin it shows "OS / 2 executable module built for kLIBC v0.6.4 +" but the latest version available in rpm is 0.6.2-1
saludos

David Graser

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 206
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #1 on: October 06, 2018, 04:42:09 pm »
Same thing here.  The PDF plugin does not work, even with 1.41 beta_10.

Dariusz Piatkowski

  • Sr. Member
  • ****
  • Thank You
  • -Given: 13
  • -Receive: 8
  • Posts: 465
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #2 on: October 06, 2018, 05:37:34 pm »
I see 0.6.3 available on netlabs-exp, but no official release, nor the 0.6.4...best to wait until at least that aspect has been ironed out.

Gregg Young

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 4
  • Posts: 26
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #3 on: October 06, 2018, 05:43:43 pm »
After downloading and installing the wpi the pdf plugin is installed but it does not work. When I open the plugin it shows "OS / 2 executable module built for kLIBC v0.6.4 +" but the latest version available in rpm is 0.6.2-1
saludos

Lucide 1.4.1 requires libc 0.6.6-38, libcx 0.6.3-1 and Poppler 0.59.0. They are available from the netlabs-exp RPM repository. Beta 9 requires pmprintf.dll in the lib path beta 10 doesn't. The Poppler update was required to fix traps when loading large files.  If you have additional problems please either post back to the Lucide groups (where the betas came from) or put in a ticket at http://trac.netlabs.org/lucide Thanks

André Heldoorn

  • Sr. Member
  • ****
  • Thank You
  • -Given: 38
  • -Receive: 9
  • Posts: 337
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #4 on: October 06, 2018, 07:18:58 pm »
Lucide 1.4.1 requires libc 0.6.6-38, libcx 0.6.3-1 and Poppler 0.59.0. They are available from the netlabs-exp RPM repository.
Not 0.49.0?

Gregg Young

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 4
  • Posts: 26
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #5 on: October 06, 2018, 07:55:12 pm »
Lucide 1.4.1 requires libc 0.6.6-38, libcx 0.6.3-1 and Poppler 0.59.0. They are available from the netlabs-exp RPM repository.
Not 0.49.0?

You need 0.59.0 it has only been on netlabs-exp for a couple of weeks. It contains popple70.dll

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 14
  • -Receive: 7
  • Posts: 407
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #6 on: October 06, 2018, 09:50:02 pm »
Thanks Gregg
After installing netlabs-exp and update everything necessary is ok.
Very good job, and thanks for the language translation.
saludos

Gregg Young

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 4
  • Posts: 26
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #7 on: October 07, 2018, 12:19:21 am »
Very good job, and thanks for the language translation.
saludos

Thanks

I am guessing you are talking about the translation in the warpin. That is actual the produce of my not having the warpin build stuff from 1.40. It is the pre 1.40 warpin build system. This installs all the language packs by default. In 1.40 you had to install them individually (except English)

If you got it with ArcaOS it probably only installed English and you would need to find the Lucide warpin on the iso to install anything else.  Note you will find some English mixed in with the other languages.

The documentation hasn't been updated either.  If anyone is interested in updating the translations let me know.

This wasn't really intended for release at this stage. Feed back on any issues would be appreciated. 

André Heldoorn

  • Sr. Member
  • ****
  • Thank You
  • -Given: 38
  • -Receive: 9
  • Posts: 337
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #8 on: October 07, 2018, 12:23:23 am »
You need 0.59.0 it has only been on netlabs-exp for a couple of weeks. It contains popple70.dll

Thanks, couldn't find 59 @ the RPM ZIP directory.

Gregg Young

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 4
  • Posts: 26
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #9 on: October 07, 2018, 12:42:59 am »
It is in the experimental directory tree. Libc 0,6.6-38 and libcx 0.6.3-1 are in the same directory.

http://rpm.netlabs.org/experimental/00/zip/poppler-0_59_0-1_oc00.zip

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 27
  • Posts: 818
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #10 on: October 07, 2018, 01:30:30 am »
Here we see another drawback of the RPM way of doing things.  Since Lucide is provided as a WPI,  why didn't whoever built it add the obscure required DLLs to it?  From what I have seen the WPI format allows for testing of various files to check they are the ones needed and put them in the required places.

Thinking about it I suppose the fact there is no way of knowing which version of a RPM loaded DLL is, no buildlevel, which makes it rather difficult.  It also assumes that all the newer DLLs are backwards compatible with the earlier ones, which isn't always the case.  This was the reason I gave up using SUSE Linux many years ago - updating one program had the tendency to break others.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 9
  • -Receive: 109
  • Posts: 1569
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #11 on: October 07, 2018, 01:48:21 am »
I guess ideally the system keeps track of the RPM installed ones and others may be installed in other places and forgotten, leading to problems.
Bldlevel info is slowly getting added, with the goal that everything will eventually have it.
Code: [Select]
K:\usr\lib>bldlevel popple70.dll
Build Level Display Facility Version 6.12.675 Sep 25 2001
(C) Copyright IBM Corporation 1993-2001
Signature:       @#bww bitwise works GmbH:0.59.0#@##1## 20 Aug 2018 18:15:31
 ECS26154618::::0::@@poppler
Vendor:          bww bitwise works GmbH
Revision:        0.59.0
Date/Time:       20 Aug 2018 18:15:31
Build Machine:   ECS26154618
File Version:    0.59
Description:     poppler

I'm somewhat surprised you had problems with SUSE and libraries getting updated as Linux has much better shared library support then we can dream of.  Not only can you have micro and minor versions symlinked to the major version, you can have versioned symbols and even compile a program to look in a certain place for its shared libraries along with multiple versions installed and loaded.
I've only ever used deb based package managers and it has been problem free besides a long time ago where updating libc05 to glibc06 took manual intervention. That was before apt.

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 27
  • Posts: 818
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #12 on: October 07, 2018, 11:58:59 am »
Hi Dave,

It is good to see that there is a move towards adding bldlevel info to these DLLs, it should make keeping track of them a little easier.

It was a very long time ago when I had problems with SUSE and I moved over to a deb based system, which as far as I am concerned works much better - a case of 'once bitten twice shy' I don't trust the RPM package system.

Andreas Schnellbacher

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 16
  • Posts: 330
    • View Profile
Re: Lucide 141b9 or 141b10
« Reply #13 on: October 07, 2018, 09:04:21 pm »
Yes, I had made the same experience with SuSE. It was long ago, in the times before openSUSE existed. Recent distros seem to work better, but I don't try much.