Author Topic: Apache Open Office fail  (Read 602 times)

Matt Walsh

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 1
  • Posts: 28
    • View Profile
Apache Open Office fail
« on: December 04, 2018, 06:23:43 pm »
Just downloaded the latest 4.1.6GA and on install got a fail message, but the dll is in the package.  Any suggestions.
Matt Walsh

David

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 3
  • Posts: 8
    • View Profile
Re: Apache Open Office fail
« Reply #1 on: December 04, 2018, 08:24:01 pm »
I too have downloaded and installed Apache OpenOffice 4.1.6 from Bitwiseworks.

I also encountered the same error as you.  In reading the README it lists the following requisites which can be installed from a command line :

yum install libc libgcc1 libgcc-fwd openssl curl libjpeg libxslt libicu zlib libxml2 mmap pthread urpo libstdc++6 libstdc++ uclip

I ran the above line and then ran into the same error as you.  I then ran the above line again and looked carefully at the results which I should have done in the first place. 
When I ran the above command a second time I noticed that one item did not install properly, that there was a prompt to answer y/n to installing a new item and yet that prompt scrolled past and I was not able to answer with a y or n.  I reran the YUM line cited above again and this time I was given the opportunity to answer y to the prompt and thereafter OpenOffice 4.1.6 ran without error thankfully.

In appreciation for their work I bought a development unit for both Apache OpenOffice and QT5 to say thank you for all the work that goes into supporting us ArcaOS users.  I believe we are most fortunate to have people work on ArcaOS applications for us to use.

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 39
  • Posts: 1082
    • View Profile
Re: Apache Open Office fail
« Reply #2 on: December 04, 2018, 08:53:58 pm »
I used the Arca Noae Package Manager https://www.arcanoae.com/wiki/anpm/ to do the requirements. It demanded a reboot (as it should) before completing the operation. Perhaps that is what causes the problem. After doing the updates, I installed AOO 4.1.6, and it works, as it should. I haven't tried anything, that didn't work before, yet.

Rene Hvidsoe

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 32
    • View Profile
Re: Apache Open Office fail
« Reply #3 on: December 04, 2018, 11:43:05 pm »
Hi Matt

No issues here all seems to be working. Sure you have the prereq ?

Also did pay for a development unit to say thanks for BWW hard work.

Matt Walsh

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 1
  • Posts: 28
    • View Profile
Re: Apache Open Office fail -Fixed
« Reply #4 on: December 05, 2018, 01:02:51 am »
I went back and did the Arca Noae Yum install and it now works.   I did the initial install and used the AOO-4160-GA-rpm.wpi and I thought the readme implied that would be satisfactory, but apparently not.  Looks like you have to do both that rpm and the other separate dll installs.
But I'm happy with the project and will buy some units of support.
Matt W. :)

Shmuel (Seymour J.) Metz

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 8
    • View Profile
Re: Apache Open Office fail
« Reply #5 on: December 07, 2018, 08:26:14 pm »
There are two packages; a base and a language specific. Can you give the URLs you downloaded and the ArcaOS release you installed on?

David Graser

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 11
  • Posts: 230
    • View Profile
Re: Apache Open Office fail
« Reply #6 on: December 08, 2018, 07:20:11 am »
There are around 7 base wpi packages and 7 language wpi packages; DE, US, ES, FR, IT, NL and RU. To access the download page, one must have bought a support unit in the past or present.  Once done, a password will be emailed to you if you have bought a support unit.  If purchased for a prior version, one will be emailed a new password to download with a request to please purchase a new support unit.  I have it installed on AraOS 5.03.

There is also an RPM wpi.  Not sure what this one does.

Matt Walsh

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 1
  • Posts: 28
    • View Profile
Re: Apache Open Office fail
« Reply #7 on: December 08, 2018, 05:24:20 pm »
Packages downloaded from BWW were: 
AOO-4160-GA-base-en-US.wpi
AOO-4160-GA-langpack-en-US.wpi
AOO-4160-GA-rpm.wpi
and AOO-4160readme.txt

If you use WarpIn to open the base file it picks up and also loads the language and rpm packs.  In my case I also had to use my Arca Noae Yum installer and the info from the readme to install two more dll files.  Now everything works very well.  BitWise does great work and I have bought several support units!
Matt W.

Ian Manners

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 36
  • -Receive: 24
  • Posts: 292
  • I am the computer, it is me.
    • View Profile
    • ComKal Networks Australia
Re: Apache Open Office fail
« Reply #8 on: December 09, 2018, 05:31:47 pm »
The AOO-4160-GA-langpack-en-US.wpi is not required with AOO-4160-GA-base-en-US.wpi, ditto the other Language packs if you only want the one language.
ie,

You only need
AOO-4160-GA-base-xx.wpi
and
AOO-4160-GA-rpm.wpi (if you do not already have the RPM's installed)

I removed my old AOO install and simply installed The AOO-4160-GA-langpack-en-US.wpi
All appears to be working fine after I marked the DLL's to load in highmem.
Cheers
Ian B Manners