Author Topic: Can't connect to Google after Update using ANPM  (Read 785 times)

Mark Szkolnicki

  • Jr. Member
  • **
  • Thank You
  • -Given: 6
  • -Receive: 0
  • Posts: 95
    • View Profile
Can't connect to Google after Update using ANPM
« on: November 27, 2019, 11:18:45 pm »
Hi All!

Its been a busy year and one half for me, especially with Forest Fire response, so haven't had much time to hang about. But I ran into a problem this morning after doing an update to ArcaOS 5.0.4 using ANPM, and thought I'd stop by.

After the update, opening SeaMonkey v2.35, I tried to connect to Google. Seamonkey looked up the site, said it had connected, then ended off with Done in the status bar and an empty window.

Was wondering if anyone else has run into this at all, after the latest updates?

I suspect if there is a problem the most likely culprits would be the update to NSPR or NSS although that's only a guess. Prior to the update I had 4.12.0-4 of NSPR installed, updated now to 4.23.0-1 and NSS at 3.23.0-4 upgraded to 3.47.0-1. Prior to the update, everything was working fine for months, no connection problems whatsoever. It may affect connecting to other websites as well, but Google was the most prominent issue I ran into today

I was trying to backout both those updates using ANPM , to see if it would solve the problem, but ran into the ANPM multiple dependencies errors, where all the files needed to be back leveled  at the same time. So I was also wondering if someone knows some trick to doing that with ANPM. You seem to be able to upgrade installing all necessary dependencies - you don't seem to have an obvious way to back out those same dependencies all at once.

Any bright ideas welcome as always. And a fine Thanksgivng tomorrow to those of you in the US or any others celebrating a holiday tomorrow!

Best!

Mark

Mark B. Szkolnicki

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 149
  • Posts: 2168
    • View Profile
Re: Can't connect to Google after Update using ANPM
« Reply #1 on: November 28, 2019, 12:29:40 am »
Yea, stuff like this happens when using the exp repository. The problem is NSS and not agreeing with some secure connections (https).  Simplest fix is to update to Firefox 45.9 ESR or SeaMonkey 2.42.9ESR or, harder, downgrade NSPR and NSS, they're interdependent.
« Last Edit: November 28, 2019, 12:49:09 am by Dave Yeo »

Mark Szkolnicki

  • Jr. Member
  • **
  • Thank You
  • -Given: 6
  • -Receive: 0
  • Posts: 95
    • View Profile
Re: Can't connect to Google after Update using ANPM
« Reply #2 on: November 28, 2019, 04:07:02 pm »
Yea, stuff like this happens when using the exp repository. The problem is NSS and not agreeing with some secure connections (https).  Simplest fix is to update to Firefox 45.9 ESR or SeaMonkey 2.42.9ESR or, harder, downgrade NSPR and NSS, they're interdependent.

Thanks, Dave for confirming where the problem lay.

I've tried 2.42.9ESR, various incarnations, in the past and for a variety of reasons stuck with 2.35. I haven't tried it with the full refresh to 5.0.4 but may try it again hopefully in the Christmas season (by hopefully, I mean not being called out to yet another emergency situation for weeks on end).

So took the harder route (not as hard as I thought, after 27 years of doing this).

Had a look at the ANPM contents lists for the five packages in question with interdependencies and back leveled the files from my second ArcaOS partition. SeaMonkey 2.35 operating as per normal yet again.

A fine rest of the week to you, Sir, and Best as always!

M

guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 18
  • Posts: 307
    • View Profile
Re: Can't connect to Google after Update using ANPM
« Reply #3 on: December 02, 2019, 12:58:00 am »
Just before reading this thread I spent half an hour trying to figure out how to downgrade NSS. The version in the exp repo leads to traps in firefox 45,9,0 too. This is how I downgraded:
From the directory where the packages are located (here F:\var\cache\yum\netlabs-rel\packages\) execute:
rpm -Uvh nss-3.23.0-4.oc00.i686.rpm nss-util-3.23.0-4.oc00.i686.rpm nss-softokn-3.23.0-4.oc00.i686.rpm nss-softokn-freebl-3.23.0-4.oc00.i686.rpm  --oldpackage

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 149
  • Posts: 2168
    • View Profile
Re: Can't connect to Google after Update using ANPM
« Reply #4 on: December 02, 2019, 08:41:28 am »
I had some experimental updates to NSS and NSPR which worked fine here, but I had to downgrade a few times due to needing to distribute the binaries, and they also wouldn't connect to secure sites with the older official versions. I found it was as easy as doing yum downgrade with a list of all the packages, which here includes the development ones. Getting the list was the harder part.
And thanks for confirming the instability, which I never had with the experimental ones I had here, built by Tellie.
I've run into another weird issue, linking xul.dll is failing due to not finding lib_s.a which doesn't make sense, everything seems to be present, need to look more.

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 171
    • View Profile
Re: Can't connect to Google after Update using ANPM
« Reply #5 on: December 02, 2019, 10:08:12 am »
Just before reading this thread I spent half an hour trying to figure out how to downgrade NSS. The version in the exp repo leads to traps in firefox 45,9,0 too. This is how I downgraded:
From the directory where the packages are located (here F:\var\cache\yum\netlabs-rel\packages\) execute:
rpm -Uvh nss-3.23.0-4.oc00.i686.rpm nss-util-3.23.0-4.oc00.i686.rpm nss-softokn-3.23.0-4.oc00.i686.rpm nss-softokn-freebl-3.23.0-4.oc00.i686.rpm  --oldpackage
why not reporting possible traps in our github repos? As when we see no reports we move it to netlabs rel repo. And to be honest on my system and the testers system it seems stable and connects to all sites, but this might be luck. I don't know.

just to say it once again: no report on github or even netlabs trac there will be no fix.

regards
Silvan
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 18
  • Posts: 307
    • View Profile
Re: Can't connect to Google after Update using ANPM
« Reply #6 on: December 02, 2019, 01:56:50 pm »
Just before reading this thread I spent half an hour trying to figure out how to downgrade NSS. The version in the exp repo leads to traps in firefox 45,9,0 too. This is how I downgraded:
From the directory where the packages are located (here F:\var\cache\yum\netlabs-rel\packages\) execute:
rpm -Uvh nss-3.23.0-4.oc00.i686.rpm nss-util-3.23.0-4.oc00.i686.rpm nss-softokn-3.23.0-4.oc00.i686.rpm nss-softokn-freebl-3.23.0-4.oc00.i686.rpm  --oldpackage
why not reporting possible traps in our github repos? As when we see no reports we move it to netlabs rel repo. And to be honest on my system and the testers system it seems stable and connects to all sites, but this might be luck. I don't know.

just to say it once again: no report on github or even netlabs trac there will be no fix.

regards
Silvan

The reason I did not report it is because it was in the experimental repo. I assumed it is work in progress and not supposed to be bug free. Didn't want to clutter up the github repo wirh unnecessary bug reports, Ticket made.

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 171
    • View Profile
Re: Can't connect to Google after Update using ANPM
« Reply #7 on: December 02, 2019, 02:35:12 pm »
Just before reading this thread I spent half an hour trying to figure out how to downgrade NSS. The version in the exp repo leads to traps in firefox 45,9,0 too. This is how I downgraded:
From the directory where the packages are located (here F:\var\cache\yum\netlabs-rel\packages\) execute:
rpm -Uvh nss-3.23.0-4.oc00.i686.rpm nss-util-3.23.0-4.oc00.i686.rpm nss-softokn-3.23.0-4.oc00.i686.rpm nss-softokn-freebl-3.23.0-4.oc00.i686.rpm  --oldpackage
why not reporting possible traps in our github repos? As when we see no reports we move it to netlabs rel repo. And to be honest on my system and the testers system it seems stable and connects to all sites, but this might be luck. I don't know.

just to say it once again: no report on github or even netlabs trac there will be no fix.

regards
Silvan

The reason I did not report it is because it was in the experimental repo. I assumed it is work in progress and not supposed to be bug free. Didn't want to clutter up the github repo wirh unnecessary bug reports, Ticket made.
if all think like that, then we will never find issues. as usually what we add to exp works for us. and mostly it just gets moved after some weeks.
Please send the trap's also to Dave, as I see a lot traps in XUL and not NSS. Eventually he sees something in his ffox which is wrong.
And as said, we will of course take a closer look as well.
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 18
  • Posts: 307
    • View Profile
Re: Can't connect to Google after Update using ANPM
« Reply #8 on: December 02, 2019, 04:21:37 pm »
These are the trap files.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 149
  • Posts: 2168
    • View Profile
Re: Can't connect to Google after Update using ANPM
« Reply #9 on: December 02, 2019, 04:33:45 pm »
Thanks Guzzi. This is one of my builds? If so, could you test with the last Bitwise release? Also could you look in popuplog.os2 for any crashes?

guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 18
  • Posts: 307
    • View Profile
Re: Can't connect to Google after Update using ANPM
« Reply #10 on: December 02, 2019, 04:56:48 pm »
Thanks Guzzi. This is one of my builds? If so, could you test with the last Bitwise release? Also could you look in popuplog.os2 for any crashes?

Yes, your build firefox-45.9.0.en-US.os2-Pentium-m.zip packed 23-12-18. No corresponding crashes in popuplog.

Mark Szkolnicki

  • Jr. Member
  • **
  • Thank You
  • -Given: 6
  • -Receive: 0
  • Posts: 95
    • View Profile
Re: Can't connect to Google after Update using ANPM
« Reply #11 on: December 02, 2019, 06:33:49 pm »
Just before reading this thread I spent half an hour trying to figure out how to downgrade NSS. The version in the exp repo leads to traps in firefox 45,9,0 too. This is how I downgraded:
From the directory where the packages are located (here F:\var\cache\yum\netlabs-rel\packages\) execute:
rpm -Uvh nss-3.23.0-4.oc00.i686.rpm nss-util-3.23.0-4.oc00.i686.rpm nss-softokn-3.23.0-4.oc00.i686.rpm nss-softokn-freebl-3.23.0-4.oc00.i686.rpm  --oldpackage
why not reporting possible traps in our github repos? As when we see no reports we move it to netlabs rel repo. And to be honest on my system and the testers system it seems stable and connects to all sites, but this might be luck. I don't know.

just to say it once again: no report on github or even netlabs trac there will be no fix.

regards
Silvan

Hi Silvan!

Just was wondering what browser(s) both you and the tester were using developing the upgrades - as I mentioned starting this thread I am still using Seamonkey 2.35, mainly because of the stability (v2.42..9 ESR and the latest of Dave's Firefox 45 builds have much more functionality, but I'm more interested in simply reading and connecting in a seamless manner).

Also I use NoScript and Adblock extensively on 2.35, some items  I seem to recall Dave saying were causing problems when used with 2.42.9 ESR, when I mentioned it a year and one half ago (but that may be a faulty recollection, Dave, given how full of details my mind is at the moment)

The problem with connecting was immediately noticeable especially related to Google, and to a few websites like www.stockcharts.com, where you could only partially connect.

I'm not a programmer, but I am a troubleshooter - I suspect I caught the connection issue simply because the interdependencies in various modules have evolved significantly from the 2.35 framework to the 2.42.9ESR framework and much of what your developing now is focused on the latest versions of the current browsers. It was one of the reasons I didn't file a bug report in this situation related to NSPR and NSS, as I was essentially using older browser technology.

Would you like this bug to be filed at GitHub, based on using 2.35 instead of the latest browser versions? Both you and Dave are doing excellent work, trying to breadboard and rewire a very old browser technology, but there are limits to what can be done with earlier versions as you press forward. If most others are able to use the latest SeaMonkey and Firefox versions, I'm cool with using whats here now, that works for me.

Best Sir!

Mark


Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 149
  • Posts: 2168
    • View Profile
Re: Can't connect to Google after Update using ANPM
« Reply #12 on: December 02, 2019, 06:59:30 pm »
Hi Mark, I opened https://github.com/bitwiseworks/nss-os2/issues/2 about the not connecting issue. Guzzi opened issue #1 about the crashyness though I think it might be more of a NSPR issue but it's hard to say. NSPR and NSS are intertwined, building them standalone leads to the NSS libraries etc being built in the NSPR tree.
About NoScript and Adblock, there has been reports of Adblock not playing nice with 45ESR, AdblockPlus (downloadable from their site) seems better. I've been using NoScript fine on SM 2.42.9 but it is a newer NoScript that is not compatible with 38esr, also available at the NoScript site.