Author Topic: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install  (Read 947 times)

Andreas Schnellbacher

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 26
  • Posts: 464
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #15 on: January 19, 2020, 01:31:25 pm »
The 'kLIBC Pathwriters' that I installed (klibccfg_1_0_2_1.exe) did not added TEMP, TMPDIR, LOGFILES on the config.sys.
Martin, I've read what you wrote again. My answer doesn't seem to match your problem.

AFAIR, the temp dir entries in CONFIG.SYS are added by the installation of ArcaOS. At least that's what I remember for eCS.

I guess that should be added to the prerequisites. I would create an entry in the bug tracker, because AFAIR, also non-ArcaOS systems are supported with ANPM.

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 15
  • Posts: 645
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #16 on: January 19, 2020, 04:26:35 pm »
Hi Travis,
Hi Doug:
    Thanks for the link.  I have read that page, and the software section.  Maybe I'm missing something, but none of the information seems to help my particular situation.

What are the specifics of what you are seeing?

I ask b/c on the surface (symptom wise) it may look like the same issue Martin had, details may tell a different story.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 428
  • -Receive: 90
  • Posts: 2504
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #17 on: January 19, 2020, 05:14:13 pm »
Hi

My issue seem to was that on a plain OS/2 Warp 4.52 VM, just by installing WarpIN 1.0.22, kLIBC Pathrewriters, 1.0.2 and ANPM 1.04, was not was enough to RPM/YUM and ANPM to run fine.
I did other config.sys tweaking for it to work, but I can not recall the exact steps. I had to set all the unixroot stuff, home, temp, etc and tweak that until it worked.

I will need to do the same experiment again to see what was missing on the config.sys.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 428
  • -Receive: 90
  • Posts: 2504
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #18 on: January 19, 2020, 05:59:20 pm »
Hi

I tried it again to get the same error.

The plain VM with OS/2 has on its config.sys:
- SET ETC=C:\MPTN\ETC
- SET TMP=C:\TCPIP\TMP

On my plain OS/2 Warp 4.52 (14.106) I installed WarpIn 1.0.22 and klibccfg_1_0_2_1.exe
It only installed this on my config.sys
   SET LIBC_HOOK_DLLS=C:\OS2\DLL\klibccfg.dll@_kLIBCInitPath!pathrewrite
On the last line of the disorganized config.sys.
klibccfg.dll got copied on c:\OS2\DLL
- Reboot.

Now I run ANPM 1.0.4 exe installer
- supported libraries got installed on C:\OS2\APPS\DLL
- Reboot

Time to run ANPM
- Tells me that YUM/RPM are not installed.  Clicked Yes, selected i686
- Downloading file.  (rpm-yum-base-os2-i686-2019-08-24.exe)
- "Select base Path" - Selected C:
- Tells me that config.sys is changed. Press ok
- REXXAPI.DLL Error shows up. (Click end) (attached pic)
- Reboot

Run ANPM again
- It tells me that I don't have RPM/YUM and I get stuck in the ANPM loop asking me to reboot and tell I don't have RPM/YUM.

I got again to the same issue. Now I will tweak the config.sys again and put some attention.

Regards




« Last Edit: January 19, 2020, 06:05:45 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 428
  • -Receive: 90
  • Posts: 2504
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #19 on: January 19, 2020, 06:35:43 pm »
Hi

Next. I Removed from the config.sys
SET TMP=C:\TCPIP\TMP

and set at the end. (directories where already created with the RPM/YUM install attempt)
SET TMP=C:\var\temp
SET TEMP=C:\var\temp
SET TMPDIR=C:\var\temp
SET HOME=C:\Home
SET USER=Martini
SET UNIXROOT=C:

Added at the end of path ",:C:\USR\LOCAL\BIN;C:\USR\SBIN;C:\USR\BIN;" and libpath ".;C:\usr\local\lib;C:\usr\lib;"
- Reboot

Run ANPM and it gets angry. Yes, angry.  :D
- It tells me to fix my config.sys. I select "yes"
- Reboot

Run ANPM and it works.
- I did a "Yum Update All" and it starts updating all the stuff.

I'm still updating the files see if RPM/YUM and ANPM are working fine. I will install all firefox dependencies and try firefox 45.

Regards


« Last Edit: January 19, 2020, 06:42:08 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 51
  • Posts: 1280
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #20 on: January 19, 2020, 07:33:45 pm »
Quote
Added at the end of path ",:C:\USR\LOCAL\BIN;C:\USR\SBIN;C:\USR\BIN;" and libpath ".;C:\usr\local\lib;C:\usr\lib;"
- Reboot

Run ANPM and it gets angry. Yes, angry.  :D
- It tells me to fix my config.sys. I select "yes"
- Reboot

Run ANPM and it works.

I find it amazing, that people still try to be smarter than package installers. The paths need to be in the order that ANPM insists on, for normal operation (and ANPM will, correctly, add the paths that you manually entered). That order can be modified, and ANPM can be set to ignore that, but there would need to be a very good reason to do that (perhaps a developer, working on updates to the RPM/YUM stuff), and you are likely to have weird problems, when you forget that you did it. As you noticed, after ANPM corrected your attempt to do it incorrectly, it works as it should.

Since RPM/YUM, doesn't (can't) clean up old files that it doesn't actually know about, you probably should analyze the OLD stuff, that RPM/YUM replaces, and remove older duplicates, before some program loads the wrong one, and something is broken until that wrong DLL is unloaded from memory. This is how you get a program to work perfectly, then it doesn't work, then it does again.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 428
  • -Receive: 90
  • Posts: 2504
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #21 on: January 19, 2020, 07:53:39 pm »
I find it amazing, that people still try to be smarter than package installers.
Software can not get angry.  :o

You are missing the point. The point is not that I included on purpose at the end of the path and libpath the /usr to make ANPM fix that (maybe it would be shorter to added the path correctly on the first try). 

The point is that on a basic OS/2 Warp 4.52 machine, you can not install ANPM easily with the defaults "package installers".
But it seems that it was needed to have usr/bin on the path for ANPM to start working. And none of the "smart package installers" did that on this case. Or maybe it is the error I'm getting on REXXAPI.DLL.

All are welcome to try that and let me know if my VM is the one giving problems, or it is common for OS/2 Warp 4.52.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 51
  • Posts: 1280
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #22 on: January 19, 2020, 08:38:02 pm »
Quote
The point is that on a basic OS/2 Warp 4.52 machine, you can not install ANPM easily with the defaults "package installers".
But it seems that it was needed to have usr/bin on the path for ANPM to start working. And none of the "smart package installers" did that on this case. Or maybe it is the error I'm getting on REXXAPI.DLL.

Did you follow the directions at: https://www.arcanoae.com/wiki/anpm/? It tells you what needs to be done in different install scenarios.

While testing these things, I have started with no RPM/YUM installed, and installing ANPM put it all together for me. ANPM is installed by WarpIn. ANPM then determines if CONFIG.SYS entries need to be modified, and does it if necessary. Then it makes sure that a usable RPM/YUM install is present, and installs it new, if not, Then, it runs the YUM program, so the user can install whatever they need. One of the more difficult scenarios is if an old RPM/YUM is installed, but has never been used. The RPM/YUM install may be too old to work. The directions do describe what to do about that.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 428
  • -Receive: 90
  • Posts: 2504
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #23 on: January 20, 2020, 02:12:37 am »
Did you follow the directions at: https://www.arcanoae.com/wiki/anpm/? It tells you what needs to be done in different install scenarios.

Yes.

- Prerequisite - Checked.
- IMPORTANT: Systems with existing RPM & YUM which have not been updated recently (including fresh eCS installations) - DO NOT APPLY ON THIS CASE
- Initial setup of RPM & YUM. For systems with existing Python installations - DO NOT APPLY ON THIS CASE
- On systems with no existing RPM & YUM installation....  - This is the case but it explain you what the installer does, not any extra things you need to do.
- Post-bootstrap tasks. Reinstall bootstrapped packages - I was not able to reach to this part. (without doing the undocumented tweak I just did for ANPM to work)

A person reported to me that he was not able to install ANPM on a plain OS/2 Warp 4.52 (systems with no existing RPM & YUM installation) , that is why I started doing this to see my results.

Regards
« Last Edit: January 21, 2020, 10:08:48 pm by miadmin »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 428
  • -Receive: 90
  • Posts: 2504
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #24 on: January 20, 2020, 03:02:05 am »
Hi

At the end I completed the exercise to install firefox 45.9 on an OS/2 Warp 4.52 VM machine.

With ANPM I installed the prerequisites.
- pango  (includes fontconfig, pixman, cairo), hunspell, libicu, libjpeg, libkai, libvpx.

After that I unpacked and copied firefox-45.9.0-4.oc00.pentium4.7z
The easiest way for me to get files without the internet was to create an ISO CD-ROM file with the installers files from the Host machine and mount it on the OS/2 guest. (here it is the very basic ISO file)

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 164
  • Posts: 2281
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #25 on: January 20, 2020, 03:40:48 am »
When I first installed RPM/YUM on Warp v4, I already had UNIXROOT set to pointing to an EMX developer setup, talk about fun.
As for RPM's with no internet, or really bad internet, I found the simplest is to just have a local repository.

Travis Thoms

  • Newbie
  • *
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 15
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #26 on: January 21, 2020, 09:47:15 am »
Martin, you are a beautiful man!

It seems to have worked!

Thank you so much for all of your effort..