Author Topic: Updated Uniaud32 build  (Read 14572 times)

Renee Senger

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 47
    • View Profile
Re: Updated Uniaud32 build
« Reply #150 on: August 10, 2020, 12:33:01 am »
I am with ArcaOS 5.0.5 and Uniaud package 20200506. As usual, after installation (and reboot) "Master Front Playback Volume" and "Front Playback Volume" is switched ON but level setted to zero. Volume.exe has no effect. All sound level is controlled only by Unimix settings. I saw that unimix -save <file> not works anymore (always file missing message output). Motherboard interface is High Definition Audio NVidia.


Renee Senger

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 47
    • View Profile
Re: Updated Uniaud32 build
« Reply #151 on: August 10, 2020, 12:42:29 am »
Details of the interface, if helps

[E:\]unimix -card
Command line mixer for UNIAUD32. Version 1.1
Detected UNIAUD version 2.02.06
Detected 1 audio adapter(s)
Card info for adapter 0:
  num: 0
  id: NVidia
  driver: HDA-Intel
  name: HDA NVidia
  longname: HDA NVidia at 0xebef8000 irq 23
  mixer: VIA VT1708S
  componenets: HDA:11064397,18490397,00100000

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 68
  • Posts: 614
    • View Profile
Re: Updated Uniaud32 build
« Reply #152 on: August 10, 2020, 02:59:58 am »
Does http://smedley.id.au/tmp/uniaud32-linux-3.14.79-20200810.zip help at all? In reviewing the diff from the original sources - something screwy had happened; so I took a fresh copy of the 3.14.79 sources and re-applied the diffs from 3.12.x. The diff looks much cleaner now. Driver still loads/works in Virtualbox, no time before work today to test on real hardware.

The sound is exceptional using PM123 and VLC. 

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 355
    • View Profile
Re: Updated Uniaud32 build
« Reply #153 on: August 10, 2020, 04:52:41 am »
Does http://smedley.id.au/tmp/uniaud32-linux-3.14.79-20200810.zip help at all? In reviewing the diff from the original sources - something screwy had happened; so I took a fresh copy of the 3.14.79 sources and re-applied the diffs from 3.12.x. The diff looks much cleaner now. Driver still loads/works in Virtualbox, no time before work today to test on real hardware.

Same as previous 3.14.79 (it doesn't work)
No mixer found and /A:1 not taken, adapter 0 is always taken despite the /A:1 flag

Could this help you ?
unimix -card:
[C:\mmos2]unimix -card
Command line mixer for UNIAUD32. Version 1.1
Detected UNIAUD version 2.02.05
Detected 1 audio adapter(s)
Error: invalid number of PCM instances for adapter 0
Card info for adapter 0:
  num: 0
  id: Intel
  driver: HDA-Intel
  name: HDA Intel
  longname: HDA Intel at 0xf7414000 irq 16
  mixer:
  componenets: HDA:80862808,80860101,00100000

Then, find why /A:1 is ignored
[ note: adapter 1 is on irq22  while irq16 is for adapter 0 ]
« Last Edit: August 10, 2020, 05:18:49 am by Remy »

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 23
  • -Receive: 76
  • Posts: 636
    • View Profile
Re: Updated Uniaud32 build
« Reply #154 on: August 10, 2020, 04:59:46 am »
Hi Remy,

Does http://smedley.id.au/tmp/uniaud32-linux-3.14.79-20200810.zip help at all? In reviewing the diff from the original sources - something screwy had happened; so I took a fresh copy of the 3.14.79 sources and re-applied the diffs from 3.12.x. The diff looks much cleaner now. Driver still loads/works in Virtualbox, no time before work today to test on real hardware.

Same as previous 3.14.79 (it doesn't work)
No mixer found and /A:1 not taken, adapter 0 is always taken despite the /A:1 flag

Interesting - I tested with my X250 earlier and might be seeing something similar.  I'll investigate as time permits.

Just confirming - 3.12.x work OK?

Cheers,

Paul

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 23
  • -Receive: 76
  • Posts: 636
    • View Profile
Re: Updated Uniaud32 build
« Reply #155 on: August 10, 2020, 05:00:17 am »
Hi David,

Does http://smedley.id.au/tmp/uniaud32-linux-3.14.79-20200810.zip help at all? In reviewing the diff from the original sources - something screwy had happened; so I took a fresh copy of the 3.14.79 sources and re-applied the diffs from 3.12.x. The diff looks much cleaner now. Driver still loads/works in Virtualbox, no time before work today to test on real hardware.

The sound is exceptional using PM123 and VLC.

Thanks for confirming!

Cheers,

Paul

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 355
    • View Profile
Re: Updated Uniaud32 build
« Reply #156 on: August 10, 2020, 05:05:01 am »
Hi Remy,

Does http://smedley.id.au/tmp/uniaud32-linux-3.14.79-20200810.zip help at all? In reviewing the diff from the original sources - something screwy had happened; so I took a fresh copy of the 3.14.79 sources and re-applied the diffs from 3.12.x. The diff looks much cleaner now. Driver still loads/works in Virtualbox, no time before work today to test on real hardware.

Same as previous 3.14.79 (it doesn't work)
No mixer found and /A:1 not taken, adapter 0 is always taken despite the /A:1 flag

Interesting - I tested with my X250 earlier and might be seeing something similar.  I'll investigate as time permits.

Just confirming - 3.12.x work OK?

Cheers,

Paul

With 3.12, a mixer is found but /A:1 doesn't work too !  (only adapter 0 is taken)
See my post : https://www.os2world.com/forum/index.php/topic,2436.msg27702.html#msg27702

I need to use adapter 1 to get sound  (how to when the /A:1 has no effect)
« Last Edit: August 10, 2020, 05:07:52 am by Remy »

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 23
  • -Receive: 76
  • Posts: 636
    • View Profile
Re: Updated Uniaud32 build
« Reply #157 on: August 10, 2020, 06:00:58 am »
Hi Remy,

Hi Remy,

Does http://smedley.id.au/tmp/uniaud32-linux-3.14.79-20200810.zip help at all? In reviewing the diff from the original sources - something screwy had happened; so I took a fresh copy of the 3.14.79 sources and re-applied the diffs from 3.12.x. The diff looks much cleaner now. Driver still loads/works in Virtualbox, no time before work today to test on real hardware.

Same as previous 3.14.79 (it doesn't work)
No mixer found and /A:1 not taken, adapter 0 is always taken despite the /A:1 flag

Interesting - I tested with my X250 earlier and might be seeing something similar.  I'll investigate as time permits.

Just confirming - 3.12.x work OK?

Cheers,

Paul

With 3.12, a mixer is found but /A:1 doesn't work too !  (only adapter 0 is taken)
See my post : https://www.os2world.com/forum/index.php/topic,2436.msg27702.html#msg27702

I need to use adapter 1 to get sound  (how to when the /A:1 has no effect)

Are you able to confirm the latest one of my builds that works for you? That should help me narrow down the code change that broke things.

On my X250 - 3.10.x seems to identify the mixer correctly, 3.12.74 gives lines like the following in the log, can you confirm you see similar?
hda-intel : Clearing TCSEL

hda-intel : codec_mask = 0x1

hda-intel : azx_get_response timeout, polling the codec once: last cmd=0x000f0000

hda-intel : azx_get_response timeout, polling the codec once: last cmd=0x000f0000

<4>hda-intel : azx_get_response timeout, switching to polling mode: last cmd=0x000f0000

<4>hda-intel : Codec #0 probe error; disabling it...

hda-intel : codec_mask = 0x1

<3>hda_intel: azx_get_response timeout, switching to single_cmd mode: last cmd=0x000f0000

Cheers,

Paul
« Last Edit: August 10, 2020, 07:35:50 am by Paul Smedley »

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 355
    • View Profile
Re: Updated Uniaud32 build
« Reply #158 on: August 10, 2020, 10:08:50 am »
Quote
Are you able to confirm the latest one of my builds that works for you? That should help me narrow down the code change that broke things.

On my X250 - 3.10.x seems to identify the mixer correctly, 3.12.74 gives lines like the following in the log, can you confirm you see similar?
hda-intel : Clearing TCSEL

hda-intel : codec_mask = 0x1

hda-intel : azx_get_response timeout, polling the codec once: last cmd=0x000f0000

hda-intel : azx_get_response timeout, polling the codec once: last cmd=0x000f0000

<4>hda-intel : azx_get_response timeout, switching to polling mode: last cmd=0x000f0000

<4>hda-intel : Codec #0 probe error; disabling it...

hda-intel : codec_mask = 0x1

<3>hda_intel: azx_get_response timeout, switching to single_cmd mode: last cmd=0x000f0000

Cheers,

Paul

Hi Paul,

- Are you able to confirm the latest one of my builds that works for you?
  uniaud32-linux-3.10.108-20200808.zip  works

- 3.12.74 gives lines like the following in the log, can you confirm you see similar?
 
  Yes, extract follows :

pci_register_driver: matched 29 8086:160c/40300 with 8086:ffffffff/40300 ffffff (hda_intel)
request_irq: irq 16
hda-intel : chipset global capabilities = 0x3001

hda-intel : Clearing TCSEL

hda-intel : codec_mask = 0x1

hda-intel : azx_get_response timeout, polling the codec once: last cmd=0x000f0000

hda-intel : azx_get_response timeout, polling the codec once: last cmd=0x000f0000

<4>hda-intel : azx_get_response timeout, switching to polling mode: last cmd=0x000f0000

<4>hda-intel : Codec #0 probe error; disabling it...

hda-intel : codec_mask = 0x1

<3>hda_intel: azx_get_response timeout, switching to single_cmd mode: last cmd=0x000f0000

<3>hda-codec: No codec parser is available


Regards
Rémy


« Last Edit: August 10, 2020, 10:10:23 am by Remy »

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 23
  • -Receive: 76
  • Posts: 636
    • View Profile
Re: Updated Uniaud32 build
« Reply #159 on: August 10, 2020, 10:39:22 am »
Thanks for confirming... Are you also able to confirm that http://smedley.id.au/tmp/uniaud32-linux-3.11.10-20200810.zip also works? It seems to recognise the mixer on my X250 - sound quality sucks on this hardware, but that's a separate issue...

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 355
    • View Profile
Re: Updated Uniaud32 build
« Reply #160 on: August 10, 2020, 10:52:34 am »
Thanks for confirming... Are you also able to confirm that http://smedley.id.au/tmp/uniaud32-linux-3.11.10-20200810.zip also works? It seems to recognise the mixer on my X250 - sound quality sucks on this hardware, but that's a separate issue...

Hi Paul,

Yes, this build works too.

Regards
Rémy

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 23
  • -Receive: 76
  • Posts: 636
    • View Profile
Re: Updated Uniaud32 build
« Reply #161 on: August 10, 2020, 11:59:19 am »

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 10
  • -Receive: 15
  • Posts: 267
    • View Profile
Re: Updated Uniaud32 build
« Reply #162 on: August 10, 2020, 01:56:08 pm »
 Paul,

These 810 versions of 3.12 and 3.14 both work well here...

Regards,

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 355
    • View Profile
Re: Updated Uniaud32 build
« Reply #163 on: August 10, 2020, 03:01:19 pm »
OK, please test with:
http://smedley.id.au/tmp/uniaud32-linux-3.12.74-20200810.zip
http://smedley.id.au/tmp/uniaud32-linux-3.14.79-20200810.zip

Fixes my X250 and sound works nicely for the 1st time.

It works for me too (great job Paul)
Sound is very nice

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 517
  • -Receive: 101
  • Posts: 2812
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Updated Uniaud32 build
« Reply #164 on: August 10, 2020, 05:18:23 pm »

http://smedley.id.au/tmp/uniaud32-linux-3.14.79-20200810.zip

This version worked fine on the Thinkpad L420. No trap, sound working, sound volume working.
For the moment this is a winner for me.
Martin Iturbide
OS2World NewsMaster
... just share the dream.