Author Topic: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible  (Read 535 times)

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 355
  • Karma: +0/-0
    • View Profile
Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« on: September 16, 2020, 12:08:41 pm »
I just installed ffmpeg from netlabs-exp. During the installation, it installs dlls and one of them is the package libtheora 1.1.1-1 from netlabs-rep.
After installation and reboot, I start firefox but as soon I open a web link with available video/audio media, it closes.
Under popuplog.os2, i have:

AVCODE57->THEORAE1._th_info_init
127

I then renamed new theora*.dll and put back my older saved theora* dlls.
After reboot, firefox stays up and no more issue.

Either libtheora has a problem or firefox may need be upgraded to work with libtheora 1.1.1-1 build
 
Regards
Remy

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 192
  • Posts: 2638
  • Karma: +5/-0
    • View Profile
Re: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« Reply #1 on: September 16, 2020, 05:04:13 pm »
Is there a FFmpeg-libs legacy package? And did you try installing it? Really Firefox shouldn't be trying to load AVCODE57, the newest it should load is AVCODE55, perhaps a bug in  Dmitiriy's code.
I'll boot to an install with netlabs-exp enabled and test later.
Thanks for the report.

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 14
  • -Receive: 17
  • Posts: 775
  • Karma: +0/-0
    • View Profile
Re: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« Reply #2 on: September 16, 2020, 05:56:25 pm »
Is there a FFmpeg-libs legacy package? ...

Nope, no legacy package out there.

FF here Dave pulls in AVCODED57, also happens to pull in AVUTIL55.DLL, not sure if there is a corelation between the two though (other than both are coming from my non-RPM/YUM DLL path).

On the other hand, 'PSTAT /L' only shows the following for FF:

Code: [Select]
G:\APPS\TCPIP\FIREFOX\FIREFOX.EXE   00CD       27     
                                 G:\USR\LIB\LIBC066.DLL
                                 G:\USR\LIB\LIBCN0.DLL*
                                 G:\OS2\DLL\DOSCALL1.DLL*
                                 G:\USR\LIB\LIBCX0.DLL
                                 G:\USR\LIB\LIBCN0.DLL*
                                 G:\OS2\DLL\DOSCALL1.DLL*
                                 G:\MPTN\DLL\TCPIP32.DLL*
                                 G:\USR\LIB\GCC1.DLL*
                                 G:\OS2\DLL\SESMGR.DLL*
                                 G:\OS2\DLL\PMWIN.DLL*
                                 G:\OS2\DLL\DOSCALL1.DLL*
                                 G:\USR\LIB\NSPR4.DLL
                                 G:\USR\LIB\LIBC066.DLL*
                                 G:\OS2\DLL\DOSCALL1.DLL*
                                 G:\USR\LIB\GCC1.DLL*
                                 G:\MPTN\DLL\TCPIP32.DLL*
                                 G:\USR\LIB\LIBCX0.DLL*
                                 G:\OS2\DLL\SESMGR.DLL*
« Last Edit: September 16, 2020, 06:01:21 pm by Dariusz Piatkowski »

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 179
  • Karma: +0/-0
    • View Profile
Re: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« Reply #3 on: September 16, 2020, 06:05:18 pm »
I just installed ffmpeg from netlabs-exp. During the installation, it installs dlls and one of them is the package libtheora 1.1.1-1 from netlabs-rep.
After installation and reboot, I start firefox but as soon I open a web link with available video/audio media, it closes.
Under popuplog.os2, i have:

AVCODE57->THEORAE1._th_info_init
127

I then renamed new theora*.dll and put back my older saved theora* dlls.
After reboot, firefox stays up and no more issue.

Either libtheora has a problem or firefox may need be upgraded to work with libtheora 1.1.1-1 build
 
Regards
Remy

Did you reboot after update? As ffmpeg works w/o issues here. Might be you had a older libtheora loaded somewhere.
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 355
  • Karma: +0/-0
    • View Profile
Re: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« Reply #4 on: September 16, 2020, 09:05:33 pm »
I just installed ffmpeg from netlabs-exp. During the installation, it installs dlls and one of them is the package libtheora 1.1.1-1 from netlabs-rep.
After installation and reboot, I start firefox but as soon I open a web link with available video/audio media, it closes.
Under popuplog.os2, i have:

AVCODE57->THEORAE1._th_info_init
127

I then renamed new theora*.dll and put back my older saved theora* dlls.
After reboot, firefox stays up and no more issue.

Either libtheora has a problem or firefox may need be upgraded to work with libtheora 1.1.1-1 build
 
Regards
Remy

Did you reboot after update? As ffmpeg works w/o issues here. Might be you had a older libtheora loaded somewhere.

As  I wrote it, reboot was done and the problem is not within ffmpeg but in firefox 45.9.0
With libtheora 1.1.1-1 installed, try to open following page:
https://icecast-yp.internet-radio.com/

To resolve the problem, I just removed new libtheora 1.1.1-1 and put back my older theora*.dll
( This means that I removed my older theora*.dll and renamed them *.dl_before installing new ones. I'm very careful with dlls to always develop a correct avxcat code with correct   ffmpeg version and correct dlls build ) 

Regards
Rémy

Full log:
09-16-2020  09:22:45  SYS2070  PID 0080  TID 0001  Slot 0095
W:\PROGRAMS\FIREFOX\FIREFOX.EXE
AVCODE57->THEORAE1._th_info_init
127


« Last Edit: September 16, 2020, 09:31:06 pm by Remy »

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 68
  • Posts: 619
  • Karma: +0/-0
    • View Profile
Re: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« Reply #5 on: September 17, 2020, 12:18:11 am »
In ArcaOS 5.06, I installed  libtheora 1.1.1-1 using YUM, rebooted, and opened FF 45.9.0 to the following web page.

https://icecast-yp.internet-radio.com/

Page opened just fine.  I then used YUM to install ffmpeg package, rebooted, open FF 45.9.0 to the same web page and page came up just fine.

No problem here.  This ArcaOS partition was a brand new install with the latest YUM updates.

David

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 14
  • -Receive: 17
  • Posts: 775
  • Karma: +0/-0
    • View Profile
Re: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« Reply #6 on: September 17, 2020, 02:23:57 am »
Chances are this could be something that's being invoked by an add-on, or perhaps a media codec. More importantly, we could all be talking about very different builds of FF, I know I am:

Code: [Select]
about:buildconfig
Build platform
target
i386-pc-os2-emx
Build tools
Compiler Version Compiler flags
gcc.exe 5.5.0 -Wall -Wempty-body -Wpointer-to-int-cast -Wsign-compare -Wtype-limits -Wno-unused -Wcast-align -Zomf -std=gnu99 -fgnu89-inline -fno-strict-aliasing -Zomf -fno-math-errno -pthread
c++ 5.5.0 -idirafter g:/OS2TK45/h -Wall -Wempty-body -Woverloaded-virtual -Wsign-compare -Wwrite-strings -Wno-invalid-offsetof -Wcast-align -fno-exceptions -fno-strict-aliasing -Zomf -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -DNDEBUG -DTRIMMED -g -march=amdfam10 -O2 -fomit-frame-pointer
Configure arguments

--enable-application=browser '--enable-optimize=-mtune=generic -march=pentium-m -O2' '--enable-optimize=-march=amdfam10 -O2' --disable-debug --enable-debug-symbols --disable-tests --enable-os2-high-mem --without-x --enable-system-cairo --enable-system-pixman --with-intl-api --with-system-icu --with-system-zlib --with-system-nss --with-system-nspr --with-system-libvpx --disable-startupcache

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 192
  • Posts: 2638
  • Karma: +5/-0
    • View Profile
Re: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« Reply #7 on: September 17, 2020, 03:30:23 am »
Everything is working as expected.
Go to https://midimusic.github.io/browsertest/index.html with the old ffmpeg-libs-2.8.2 (0c00) and under diagnostic audio, click the mp3 link, music plays. Update to 4.2.2-1.0c00, close Firefox or SeaMonkey in my case and try again, no music, click the ogg link and music. We need a ffmpeg-legacy-libs package or such.
@Remy, the RPM version of theorae1.dll is missing that import while my build has it, both have it in theora0.dll not sure what is the difference in the build process that created the difference but yes, mixing one of my FFmpeg builds with the new RPM theora will crash. Workaround with LIBPATHSTRICT and BEGINLIBPATH for now. Not sure why your crash shows AVCODE57 as Firefox shouldn't try to load that one. Needs more investigation.
@Dariusz, the FFmpeg libs are dynamically loaded by Firefox, so pstat may not show it, libavcodec has a dependency on libavutil, you're seeing their 8.3 name versions.
Are you sure that Firefox pulled in AVCODE57? The build shouldn't matter, I think even FF 45.5 will show the same behaviour.
@David, did you enable netlabs-exp?
Everyone, there is probably problems with other versions of FFmpegs libraries on your LIBPATHS.
One thing is that it is easy to downgrade the libs, remove the main FFmpeg package if it is still there, I didn't have it installed and in ANPM, right click on the ffmpeg-libs package and choose "Get specific release" and pick 2.8.6-2

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 192
  • Posts: 2638
  • Karma: +5/-0
    • View Profile
Re: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« Reply #8 on: September 17, 2020, 03:47:43 am »
Correction, avcode57 is the latest that Firefox can load while the new package has avcode58. And yes, my FFmpeg builds get broken with the new theora.
I opened https://github.com/bitwiseworks/ffmpeg-os2/issues/3
« Last Edit: September 17, 2020, 03:52:04 am by Dave Yeo »

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 355
  • Karma: +0/-0
    • View Profile
Re: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« Reply #9 on: September 17, 2020, 12:06:24 pm »
Everything is working as expected.
Go to https://midimusic.github.io/browsertest/index.html with the old ffmpeg-libs-2.8.2 (0c00) and under diagnostic audio, click the mp3 link, music plays. Update to 4.2.2-1.0c00, close Firefox or SeaMonkey in my case and try again, no music, click the ogg link and music. We need a ffmpeg-legacy-libs package or such.
@Remy, the RPM version of theorae1.dll is missing that import while my build has it, both have it in theora0.dll not sure what is the difference in the build process that created the difference but yes, mixing one of my FFmpeg builds with the new RPM theora will crash. Workaround with LIBPATHSTRICT and BEGINLIBPATH for now. Not sure why your crash shows AVCODE57 as Firefox shouldn't try to load that one. Needs more investigation.
@Dariusz, the FFmpeg libs are dynamically loaded by Firefox, so pstat may not show it, libavcodec has a dependency on libavutil, you're seeing their 8.3 name versions.
Are you sure that Firefox pulled in AVCODE57? The build shouldn't matter, I think even FF 45.5 will show the same behaviour.
@David, did you enable netlabs-exp?
Everyone, there is probably problems with other versions of FFmpegs libraries on your LIBPATHS.
One thing is that it is easy to downgrade the libs, remove the main FFmpeg package if it is still there, I didn't have it installed and in ANPM, right click on the ffmpeg-libs package and choose "Get specific release" and pick 2.8.6-2

I'm currently running the ffmpeg from netlabs-exp but I replace the theora*.dll with those from my backup.
It seems to work until now.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 192
  • Posts: 2638
  • Karma: +5/-0
    • View Profile
Re: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« Reply #10 on: September 17, 2020, 04:11:01 pm »
I'm currently running the ffmpeg from netlabs-exp but I replace the theora*.dll with those from my backup.
It seems to work until now.

You must be picking up different DLLs as the ffmpeg from netlabs-exp has avcode58.dll in it and is fine with the theora*.dll's.
If you put the theora*.dlls in @unixroot\usr\local\lib, they should get picked up before the ones in @unixroot\usr\lib if you have the usual setup.

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 355
  • Karma: +0/-0
    • View Profile
Re: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« Reply #11 on: September 17, 2020, 04:24:59 pm »
I'm currently running the ffmpeg from netlabs-exp but I replace the theora*.dll with those from my backup.
It seems to work until now.

You must be picking up different DLLs as the ffmpeg from netlabs-exp has avcode58.dll in it and is fine with the theora*.dll's.
If you put the theora*.dlls in @unixroot\usr\local\lib, they should get picked up before the ones in @unixroot\usr\lib if you have the usual setup.

My older Dlls are put back into @unixroot\usr\local\lib while those installed from libtheora 1.1.1-1 under @unixroot\usr\lib are removed.