Author Topic: DOS session does not work. Motherboard Asrock B85  (Read 409 times)

Igor

  • Newbie
  • *
  • Thank You
  • -Given: 5
  • -Receive: 5
  • Posts: 17
  • Karma: +0/-0
    • View Profile
DOS session does not work. Motherboard Asrock B85
« on: November 19, 2020, 10:31:02 pm »
After starting a full-screen DOS session, a screen with "C:\" appears as in the picture (see attachment).
After pressing any key, the screen closes and the popuplog.os2 is formed.
Code: [Select]
19.11.2020  22:58:30  SYS   0  PID 0038  TID 0001  Slot 00A7
C:\OS2\PMSHELL.EXE
16D7FFFF
EEF3FFFF
P1=FB92E113  P2=2F0CE14B  P3=FF62F000  P4=FEE2E10E
EAX=00006247  EBX=0000FFFF  ECX=0000E118  EDX=0000FEC2
ESI=000091C3  EDI=00001240
DS=0348  DSACC=1092  DSLIM=00010FFF
ES=FFFF  ESACC=0000  ESLIM=00000000
FS=0000  FSACC=0000  FSLIM=00000000
GS=0000  GSACC=0000  GSLIM=00000000
CS:EIP=EB00:00000313  CSACC=0000  CSLIM=00000000
SS:ESP=FFFF:00000A74  SSACC=0000  SSLIM=00000000
EBP=00000A6A  FLG=000A6212

What can be done?
Motherboard Asrock B85. Bios UEFI and compatible.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 195
  • Posts: 2720
  • Karma: +16/-0
    • View Profile
Re: DOS session does not work. Motherboard Asrock B85
« Reply #1 on: November 20, 2020, 12:19:53 am »
Are you running AOS? If so, you should open an issue. I don't remember anyone having that failure.
If not, buying AOS 5.1 might help as UEFI DOS support seems better then BIOS based systems.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 532
  • -Receive: 105
  • Posts: 2863
  • Karma: +5/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: DOS session does not work. Motherboard Asrock B85
« Reply #2 on: November 20, 2020, 05:21:31 pm »
Hi Igor.

Are you with UEFI support enabled and with a latest ArcaOS on this machine. As far as I understood there were some changes/updated on the drivers to run VDM (Virtual DOS) on UEFI mode. Maybe the issue goes on that side.

If the issue is happening on ArcaOS 5.0.6 with UEFI mode, I think it will be good to open a ticket.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Andreas Schnellbacher

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 32
  • Posts: 592
  • Karma: +1/-0
    • View Profile
Re: DOS session does not work. Motherboard Asrock B85
« Reply #3 on: November 20, 2020, 09:44:14 pm »
As far as I understood there were some changes/updated on the drivers to run VDM (Virtual DOS) on UEFI mode.
Not in a released version. It's an announced feature. As Dave wrote, it's planned for 5.1.

Igor

  • Newbie
  • *
  • Thank You
  • -Given: 5
  • -Receive: 5
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: DOS session does not work. Motherboard Asrock B85
« Reply #4 on: November 25, 2020, 02:40:54 pm »
Are you with UEFI support enabled and with a latest ArcaOS on this machine. As far as I understood there were some changes/updated on the drivers to run VDM (Virtual DOS) on UEFI mode. Maybe the issue goes on that side.

If the issue is happening on ArcaOS 5.0.6 with UEFI mode, I think it will be good to open a ticket.

Okay, I'll update the system to ArcaOS in the future. Hope there will be Christmas discounts.
Or is it better to wait for version 5.1?

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 195
  • Posts: 2720
  • Karma: +16/-0
    • View Profile
Re: DOS session does not work. Motherboard Asrock B85
« Reply #5 on: November 25, 2020, 04:11:24 pm »
Okay, I'll update the system to ArcaOS in the future. Hope there will be Christmas discounts.
Or is it better to wait for version 5.1?

Version 5.1 might be 6 months away. (Always hard to predict)

Alexander

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: DOS session does not work. Motherboard Asrock B85
« Reply #6 on: November 27, 2020, 02:20:09 am »
After starting a full-screen DOS session, a screen with "C:\" appears as in the picture (see attachment).
After pressing any key, the screen closes and the popuplog.os2 is formed.

What can be done?

Try to disable dos=umb

set
DOS=HIGH,NOUMB
in config.sys

and check in vdm settings of each dos session shotcut , incl win/os2 sessions

Ps dos+emm386 runs on this motherboard with
device=c:\dos\emm386.exe  /nomovexbda noems ram