Author Topic: [Resolved] Apache Openoffice 417 suddenly crashing at loading/splash screen.  (Read 360 times)

Ibrahim Hakeem

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 4
  • Posts: 41
  • Karma: +1/-0
    • View Profile
Hi all.

After installing a fresh copy of OpenOffice (version 417), I'm no longer able to get past the splash screen, it pretty much flashes and exits straight away without any kind of error or .TRP output. Even the older version (416) which used to work is now also presenting the same crash.

PMDLL shows that all required DLLs are available, I've tried the "Enable High Mem code loading" script, resetting the user folder and everything else in my environment (i.e, Virtualbox, VLC, Firefox, Java, etc) is running perfectly fine; it only seems to be OpenOffice which is suddenly presenting this issue.

I wish I had more details than that but I'm totally baffled. Is there any advice that I could possibly follow on how to approach this?

Thanks in advance  ;D

EDIT: I'm not sure how relevant this might be, but I just realized this may have started after updating to the latest version of CUPS, npth, poppler and libassuan. I'm unable to add new printers (log says: A non-recoverable error has occurred, very informative :P) but the printers I already had installed are working fine. There's probably no correlation but due to the closeness of both incidents I felt like it might be worth including just in case.
« Last Edit: November 21, 2020, 10:39:52 am by Ibrahim Hakeem »

andreas

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Apache Openoffice 417 suddenly crashing at loading/splash screen.
« Reply #1 on: November 20, 2020, 02:26:44 pm »
not sure if it helps in your case. i'm still using version 4.111.
found out that the progran didn't start with newer versions of libc066.dll.
i copied a version from 10/26/2014 into the program folder to get the program running...
« Last Edit: November 20, 2020, 02:29:42 pm by andreas »

Andi B.

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 24
  • Posts: 526
  • Karma: +0/-0
    • View Profile
Re: Apache Openoffice 417 suddenly crashing at loading/splash screen.
« Reply #2 on: November 20, 2020, 03:07:39 pm »
I think I've all RPM packages up to date (-rel not -exp) but had to backlevel libicu at some time.

But before changing RPM packages start with a new/without \home\default\openoffice\4\ tree. IIRC there was some discussion here or github about that.

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 180
  • Karma: +1/-0
    • View Profile
Re: Apache Openoffice 417 suddenly crashing at loading/splash screen.
« Reply #3 on: November 20, 2020, 03:15:12 pm »
EDIT: I'm not sure how relevant this might be, but I just realized this may have started after updating to the latest version of CUPS, npth, poppler and libassuan. I'm unable to add new printers (log says: A non-recoverable error has occurred, very informative :P) but the printers I already had installed are working fine. There's probably no correlation but due to the closeness of both incidents I felt like it might be worth including just in case.
this sounds a bit strange. But all is possible with exp rpm. The non-recoverable issue might put some message to popuplog.os2

For the AOO ssue i'm pretty sure you updated ICU. This is known to not work with AOO. A new AOO wich then works is about to be released soon.
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 14
  • -Receive: 20
  • Posts: 821
  • Karma: +4/-0
    • View Profile
Re: Apache Openoffice 417 suddenly crashing at loading/splash screen.
« Reply #4 on: November 21, 2020, 03:18:15 am »
Hi Ibrahim,

Do you have freetype installed?

I believe AOO still uses this, or at least some portions of it. Prior to upgrading to AOO 4.17 I un-installed the remaining Innovate FreeType software that I had all in an attempt to clean the OS/2 install a tad...only to discover that this was required.

Now to simplify things, there is a RPM package out there, I have:

Installed Packages
Name        : freetype
Arch        : pentium4
Version     : 2.10.0
Release     : 2.oc00
Size        : 417 k
Repo        : installed

There are i686 and i386 packages out there as well.

Anyways, what you describe is a symptom I was seeing until I went ahead and deployed this RPM.

Ibrahim Hakeem

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 4
  • Posts: 41
  • Karma: +1/-0
    • View Profile
Re: Apache Openoffice 417 suddenly crashing at loading/splash screen.
« Reply #5 on: November 21, 2020, 05:26:37 am »
Quote
this sounds a bit strange. But all is possible with exp rpm. The non-recoverable issue might put some message to popuplog.os2

For the AOO ssue i'm pretty sure you updated ICU. This is known to not work with AOO. A new AOO wich then works is about to be released soon.


Thank you for the pointer! I checked out popuplog.os2 and by the looks of it, it almost certainly seems to be ICU.
Quote
11-21-2020  15:22:29  SYS2070  PID 009b  TID 0001  Slot 0087
C:\PROGRAMS\APACHEOPENOFFICE.4\PROGRAM\SOFFICE.BIN
I18NPOOL->ICUUC.__ZN3icu22RuleBasedBreakIterator5resetEv
127

I'll try my luck with downgrading ICU once I am back at my desk and report in with results.
« Last Edit: November 21, 2020, 05:54:03 am by Ibrahim Hakeem »

Ibrahim Hakeem

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 4
  • Posts: 41
  • Karma: +1/-0
    • View Profile
Re: Apache Openoffice 417 suddenly crashing at loading/splash screen.
« Reply #6 on: November 21, 2020, 05:53:33 am »
Solved! Downgrading to libicu 56.1-2 was all that was needed in the end :)

Thank you so much Silvan and everyone, I was genuinely worried I'd be stuck with Lotus SmartSuite for a while longer ;D

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 195
  • Posts: 2720
  • Karma: +16/-0
    • View Profile
Re: Apache Openoffice 417 suddenly crashing at loading/splash screen.
« Reply #7 on: November 21, 2020, 06:15:28 am »
Another thing to watch for is sometimes libraries get moved to legacy packages. For example, one of the Mozilla dependencies is/was libvpx, now it is libvpx-legacy-4 (or even libvpx-legacy-2 for older builds).
Ideally Bitwise should release an ICU legacy package but ICU is actually a pretty complicated beast so perhaps it is easier to rebuild OO.

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 60
  • Posts: 1383
  • Karma: +0/-0
    • View Profile
Quote
perhaps it is easier to rebuild OO.

This was probably influenced by AOO 4.1.8 now being available too...