Author Topic: [SOLVED] OS/2 Warp 4.52 VM, changing audio to Uniaud  (Read 899 times)

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3690
  • Karma: +36/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
[SOLVED] OS/2 Warp 4.52 VM, changing audio to Uniaud
« on: September 19, 2022, 08:04:14 pm »
Hi

I'm playing with some Warp 4.52 VM. It had the SoundBlaster working with, but I want to test to change it to Uniaud with Intel HD (on VirtualBox).

Problem: I installed the UniAud drivers (Uniaud-20220807-beta.exe), added them on the config.sys, changed the VM to use Intel HD as audio, but I get no sound.

I remember that someone once post a trick that you have to update also some INIs to make that kind of change.  Am I remember correctly? What was the trick?

Regards
« Last Edit: September 27, 2022, 11:16:53 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

David McKenna

  • Sr. Member
  • ****
  • Posts: 432
  • Karma: +17/-0
    • View Profile
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #1 on: September 19, 2022, 08:59:11 pm »
 Hi Martin,

 You need to edit your MMPM2.INI file to use the new driver. Minstall is what normally does that. First you have to remove the Soundblaster driver using Minstall (tell it 0 cards to remove), then install UniAud using Minstall. Or do it by hand, but it is very tricky and can cause your system to not boot if not done right. Adding/removing sound cards on OS/2 is a true PITA.

Regards,


Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3690
  • Karma: +36/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #2 on: September 19, 2022, 10:05:25 pm »
Thanks David.

I will try with MInstall first. Are you referring the one from Martin Kiewitz or the IBM one?.
 
It seems that modifying the INI directly, with all the stuff it has there, it will be long and hard.

Regards
« Last Edit: September 19, 2022, 10:08:18 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

David McKenna

  • Sr. Member
  • ****
  • Posts: 432
  • Karma: +17/-0
    • View Profile
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #3 on: September 20, 2022, 12:05:46 am »
 Hi Martin,

  The IBM one... the Kiewitz one always gave me problems when trying to uninstall, but it works well to install. Definitely hard to do by hand... if you have trouble, post your MMPM2.INI file and I'll take a stab at editing it it for UniAud... if you like to live dangerously :-)

Regards,

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3690
  • Karma: +36/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #4 on: September 22, 2022, 11:38:54 pm »
Hi

After some tries with the IBM MMInstall, I need to ask how to uninstall it.  I don't know to which path should I point the mminstal (or which driver to download) to put 0 card to remove sound blaster.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Neil Waldhauer

  • Hero Member
  • *****
  • Posts: 851
  • Karma: +21/-0
    • View Profile
    • Blonde Guy
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #5 on: September 23, 2022, 02:13:48 am »
If I remember this correctly, you need to install 0 instances of your current driver. So you need to know what your current driver is, and you have to have the installation files.
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Lars

  • Hero Member
  • *****
  • Posts: 990
  • Karma: +50/-0
    • View Profile
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #6 on: September 23, 2022, 06:51:39 am »
Or you could try the uninstall that I once wrote and that is part of a uniaud install.
It will take file cardinfo.dll as a base of what to uninstall.
So, even if it was written for uniaud, you can use it in conjunction with the SB drivers. You just need to run it from the directory where the SB installation files are located. That should contain a file cardinfo.dll.

David McKenna

  • Sr. Member
  • ****
  • Posts: 432
  • Karma: +17/-0
    • View Profile
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #7 on: September 23, 2022, 04:04:16 pm »
 Hi Martin,

  Look in the C:\MMOS2\INSTALL folder. There should be a folder with the SoundBlaster install files in it....

Regards,

mauro

  • Sr. Member
  • ****
  • Posts: 350
  • Karma: +3/-0
    • View Profile
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #8 on: September 24, 2022, 10:52:18 am »
Hi Martin,

 You need to edit your MMPM2.INI file to use the new driver. Minstall is what normally does that. First you have to remove the Soundblaster driver using Minstall (tell it 0 cards to remove), then install UniAud using Minstall. Or do it by hand, but it is very tricky and can cause your system to not boot if not done right. Adding/removing sound cards on OS/2 is a true PITA.

Regards,

thanks to your post I have remembered what to do to complete the installation of the Uniaud; running the exe installer of the driver wasn't enough then.

@Martin , with the successful installation now I hear the system sounds but just that. If I run a video either from web or media player I only hear a rippy noise and video play very slowly making Seamonkey (in case of web streaming) almost unusable.
OS2 Warp. 4.52 on Virtualbox 6.x Windows hosted,  audio setted on Windows Direct Sound, ACH97 selection

Dave Yeo

  • Hero Member
  • *****
  • Posts: 3697
  • Karma: +78/-0
    • View Profile
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #9 on: September 24, 2022, 05:36:50 pm »
Hi mauro, you need "SET KAI_AUTOMODE=DART" in your environment (config.sys is simplest) to force the Mozilla apps to use DART rather then UNIAUD for sound. UNIAUD is broken as you found.
Edit: Actually the set command should work for any program using libkai for audio.
« Last Edit: September 24, 2022, 07:45:33 pm by Dave Yeo »

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3690
  • Karma: +36/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #10 on: September 24, 2022, 06:32:02 pm »
Hi Martin,

  Look in the C:\MMOS2\INSTALL folder. There should be a folder with the SoundBlaster install files in it....

Regards,

Thanks for the feedback, but I don't find nothing (control file or SB files) on the install folder.

I guess I need to find some SB control.scr file somewhere to do the uninstall with MMOS2.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

mauro

  • Sr. Member
  • ****
  • Posts: 350
  • Karma: +3/-0
    • View Profile
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #11 on: September 24, 2022, 08:44:29 pm »
Hi mauro, you need "SET KAI_AUTOMODE=DART" in your environment (config.sys is simplest) to force the Mozilla apps to use DART rather then UNIAUD for sound. UNIAUD is broken as you found.
Edit: Actually the set command should work for any program using libkai for audio.

Hi Dave, in my config.sys I had the two active call sametime
SET KAI_AUTOMODE=DART
SET KAI_AUTOMODE=UNIAUD

so I tried to REM one first, then just one/other, then both.
Rebooted system on each change.
Nothing happened, system sound ok but no audio from video clip.

I believe there is some issue with Virtualbox audio filters.
Thank you

PS in the other UNIAUD thread I read Paul is continuously updating the drivers, I keep using a version downloaded on beginning september

David McKenna

  • Sr. Member
  • ****
  • Posts: 432
  • Karma: +17/-0
    • View Profile
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #12 on: September 24, 2022, 09:12:49 pm »
Hi Martin,

  Strange there is no folder with the soundblaster drivers... I guess you will have to find the original driver package and use that (maybe at Hobbes - or on the OS/2 Warp disk you used?). Open a command prompt, navigate to the folder with the soundblaster install files, then run Minstall there. Use '0' (zero) for the number of cards in order to remove it.

Regards,

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3690
  • Karma: +36/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #13 on: September 25, 2022, 02:23:08 pm »
Hi

I installed the Warp 4.52 Sound Blaster driver when I created the image with the "Warp 4 Setup and Installation". I search on the CD if there was the Sound Blaster driver alone with the .scr file and I was not able to find it.  Any other tip?

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

David McKenna

  • Sr. Member
  • ****
  • Posts: 432
  • Karma: +17/-0
    • View Profile
Re: OS/2 Warp 4.52 VM, changing audio to Uniaud
« Reply #14 on: September 25, 2022, 04:15:02 pm »
Hi Martin,

  Without the install files, you are pretty much stuck with trying to edit MMPM2.INI by hand, unfortunately.

Regards,