Author Topic: Samba Users and Groups  (Read 19066 times)

Neil Waldhauer

  • Hero Member
  • *****
  • Posts: 1045
  • Karma: +25/-0
    • View Profile
    • Blonde Guy
Re: Samba Users and Groups
« Reply #30 on: January 28, 2024, 04:40:16 pm »
I think my old tdb files may have been one problem solved. Now smbpasswd behaves better, but with a few messages. I'm still having some problems connecting,  though.

Code: [Select]
These are the results of smbpasswd test after deleting the private directory

{0}[f:\programs\samba] smbpasswd -a root
Unknown parameter encountered: "display charset"
Ignoring unknown parameter "display charset"
lpcfg_do_global_parameter: WARNING: The "null passwords" option is deprecated
New SMB password:
Retype new SMB password:
tdbsam_open: Converting version 0.0 database to version 4.0.
tdbsam_convert_backup: updated F:\MPTN\ETC/samba/private/passdb.tdb file.
tdb(F:\MPTN\ETC/samba/lock/winbindd_idmap.tdb): tdb_open_ex: could not open file
 F:\MPTN\ETC/samba/lock/winbindd_idmap.tdb: No such file or directory
Added user root.

{0}[f:\programs\samba] smbpasswd -a Warp30
Unknown parameter encountered: "display charset"
Ignoring unknown parameter "display charset"
lpcfg_do_global_parameter: WARNING: The "null passwords" option is deprecated
New SMB password:
Retype new SMB password:
Added user Warp30.

{0}[f:\programs\samba] smbpasswd -a User
Unknown parameter encountered: "display charset"
Ignoring unknown parameter "display charset"
lpcfg_do_global_parameter: WARNING: The "null passwords" option is deprecated
New SMB password:
Retype new SMB password:
Added user User.

{0}[f:\programs\samba] smbpasswd -a zonker
Unknown parameter encountered: "display charset"
Ignoring unknown parameter "display charset"
lpcfg_do_global_parameter: WARNING: The "null passwords" option is deprecated
New SMB password:
Retype new SMB password:
Added user zonker.

{0}[f:\programs\samba] smbpasswd -a -n guest
Unknown parameter encountered: "display charset"
Ignoring unknown parameter "display charset"
lpcfg_do_global_parameter: WARNING: The "null passwords" option is deprecated
Added user guest.

I started the servers, and no errors. I can't quite browswe from my other computer with arcamapper. A domain icon appears with my hostname, but no machines or shares.

If I try to connect, I get the following added to log\log.smbd..192.168.46.22

[2024/01/28 07:28:54.985000,  2] ../../libcli/auth/ntlm_check.c:480(ntlm_password_check)
  ntlm_password_check: NTLMv1 passwords NOT PERMITTED for user Warp30
[2024/01/28 07:28:54.989000,  2] ../../source3/auth/auth.c:353(auth_check_ntlm_password)
  check_ntlm_password:  Authentication for user [Warp30] -> [Warp30] FAILED with error NT_STATUS_WRONG_PASSWORD, authoritative=1
[2024/01/28 07:28:54.989000,  2] ../../auth/auth_log.c:858(log_authentication_event_human_readable)
  Auth: [SMB2,(NULL)] user [BEACH2]\[Warp30] at [Sun, 28 Jan 2024 07:28:54.989000 PST] with [NTLMv1] status [NT_STATUS_WRONG_PASSWORD] workstation [GARBOPEEP] remote host [ipv4:192.168.46.22:59146] mapped to [BEACH2]\[Warp30]. local host [ipv4:192.168.46.80:445]
  {"timestamp": "2024-01-28T07:28:54.989000", "type": "Authentication", "Authentication": {"version": {"major": 1, "minor": 3}, "eventId": 4625, "logonId": "0", "logonType": 3, "status": "NT_STATUS_WRONG_PASSWORD", "localAddress": "ipv4:192.168.46.80:445", "remoteAddress": "ipv4:192.168.46.22:59146", "serviceDescription": "SMB2", "authDescription": null, "clientDomain": "BEACH2", "clientAccount": "Warp30", "workstation": "GARBOPEEP", "becameAccount": null, "becameDomain": null, "becameSid": null, "mappedAccount": "Warp30", "mappedDomain": "BEACH2", "netlogonComputer": null, "netlogonTrustAccount": null, "netlogonNegotiateFlags": "0x00000000", "netlogonSecureChannelType": 0, "netlogonTrustAccountSid": null, "passwordType": "NTLMv1", "clientPolicyAccessCheck": null, "serverPolicyAccessCheck": null, "duration": 500000}}

There must be something I can add to smb.conf to permit less secure connections...
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

David McKenna

  • Hero Member
  • *****
  • Posts: 773
  • Karma: +25/-0
    • View Profile
Re: Samba Users and Groups
« Reply #31 on: January 28, 2024, 07:27:40 pm »
Hi Neil,

 You could try adding 'ntlm auth = Yes' to your server smb.conf. That should enable NTLMv1 authentication (which is off by default I believe). You may also need 'server min protocol = NT1' as well...

 https://www.samba.org/samba/docs/current/man-html/smb.conf.5.html is a good reference for all the smb.conf parameters.

Regards,
« Last Edit: January 28, 2024, 07:43:45 pm by David McKenna »

Neil Waldhauer

  • Hero Member
  • *****
  • Posts: 1045
  • Karma: +25/-0
    • View Profile
    • Blonde Guy
Re: Samba Users and Groups
« Reply #32 on: January 29, 2024, 05:16:06 am »
With those two changes, I am now able to see files on the Samba Server v 4.19 from ArcaMapper on an ArcaOS 5.1 machine. I didn't do any stress or capability test yet. Thanks David, and thanks, Paul.

Code: [Select]
        server min protocol = NT1
        ntlm auth = Yes

Curiously, I cannot see those same shares in the ArcaMapper Network Browser. I added Workgroup to my smb.conf, and now I can see the machine, but not the shares. When I try to refresh the list of shares in the Network browser, the following lines appear in smb.log..192.168.46.22

Code: [Select]
[2024/01/28 20:07:43.792000,  2] ../../source3/param/loadparm.c:2951(lp_do_section)
  Processing section "[HOMES]"
[2024/01/28 20:07:43.792000,  2] ../../source3/param/loadparm.c:2951(lp_do_section)
  Processing section "[D]"
[2024/01/28 20:07:43.792000,  2] ../../source3/param/loadparm.c:2951(lp_do_section)
  Processing section "[E]"
[2024/01/28 20:07:43.792000,  2] ../../source3/param/loadparm.c:2951(lp_do_section)
  Processing section "[F]"
[2024/01/28 20:07:43.792000,  2] ../../source3/param/loadparm.c:2951(lp_do_section)
  Processing section "[H]"
[2024/01/28 20:07:43.792000,  2] ../../source3/param/loadparm.c:2951(lp_do_section)
  Processing section "[M]"
[2024/01/28 20:07:43.792000,  2] ../../source3/param/loadparm.c:2951(lp_do_section)
  Processing section "[P]"
[2024/01/28 20:07:43.792000,  2] ../../source3/param/loadparm.c:2951(lp_do_section)
  Processing section "[S]"
[2024/01/28 20:07:43.792000,  2] ../../source3/param/loadparm.c:2951(lp_do_section)
  Processing section "[Y]"
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

David McKenna

  • Hero Member
  • *****
  • Posts: 773
  • Karma: +25/-0
    • View Profile
Re: Samba Users and Groups
« Reply #33 on: January 29, 2024, 12:25:23 pm »
 Neil,

  I also cannot see anything with the ArcaMapper Network Browser when running SAMBA 4.19. Not sure why - haven't spent any time troubleshooting it yet...

Regards,