Author Topic: [SOLVED] Networking not working In Virtual Box  (Read 2807 times)

Eugene Tucker

  • Sr. Member
  • ****
  • Posts: 366
  • Karma: +12/-0
    • View Profile
[SOLVED] Networking not working In Virtual Box
« on: January 31, 2024, 07:12:13 pm »
For some reason in my virtual machine (new) Networking does not work. the system set it up for an Intel network card while the card is a Realtek.
« Last Edit: February 12, 2024, 03:11:07 am by Martin Iturbide »

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4662
  • Karma: +41/-1
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Networking not working In Virtual Box
« Reply #1 on: January 31, 2024, 09:10:39 pm »
Hello Eugene.

Feel free to post the picture of you networking settings on the VirtualBox host.

- Which OS is your VirtualBox host ? Windows, or are you using the older VirtualBox Host for OS/2?
- If OS/2-ArcaOS is the guest. Does it gives you a booting error that does not recognize the card?

In my case I have a Windows 11 Host, the Guest OS is presented with an "Intel PRO 1000" card, and ArcaOS 5.1 loads the "MMLEM.OS2" driver on boot. (picture attached)

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Eugene Tucker

  • Sr. Member
  • ****
  • Posts: 366
  • Karma: +12/-0
    • View Profile
Re: Networking not working In Virtual Box
« Reply #2 on: February 10, 2024, 04:30:21 pm »
My host is the same Windows 11 and card show up as the same one. I am sorry for the late reply as just got out of the hospital.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4662
  • Karma: +41/-1
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Networking not working In Virtual Box
« Reply #3 on: February 11, 2024, 02:33:17 pm »
Hi Eugene.

- Does ArcaOS (or OS/2) complains that he can not find IP, some DHCP message waiting, when it boots as a guest?
- Which network river is installed on the OS/2 guest?
- Did it used to work in the past and suddenly stopped working? or it never worked from the start?

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Eugene Tucker

  • Sr. Member
  • ****
  • Posts: 366
  • Karma: +12/-0
    • View Profile
Re: Networking not working In Virtual Box
« Reply #4 on: February 11, 2024, 06:26:48 pm »
Martin, thanks for the response but I got it working.