Author Topic: RPM/YUM question - Latest Libc - GCC  (Read 2835 times)

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 430
  • -Receive: 90
  • Posts: 2508
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
RPM/YUM question - Latest Libc - GCC
« on: January 15, 2015, 04:29:05 pm »
Hi

I was trying StarFighter that was recently ported.

I noticed it asked for the following requirements:
- ftp://ftp.netlabs.org/pub/gcc/gcc4core-1_2_2.wpi (*.dll)
- ftp://ftp.netlabs.org/pub/gcc/libc-0.6.6-csd6.zip (*.dll)
- http://hobbes.nmsu.edu/download/pub/os2/dev/SDL-1.2.15-20140930.zip (*.dll)
- https://dl.dropboxusercontent.com/u/76425158/gcc-4.9.2-os2-20141102.zip (gcc492.dll, included)

So I noticed I was missing libc066.dll from libc-0.6.6-csd6.zip (10/26/2014). Since I'm using RPM/YUM I tried to installed that way, but I can not find it.

Is this package missing on netlabs RPM server? Do you know which commands do you use to know to which RPM server is your RPM/YUM trying to connect?

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

guzzi

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 18
  • Posts: 309
    • View Profile
Re: RPM/YUM question - Latest Libc - GCC
« Reply #1 on: January 15, 2015, 05:03:02 pm »
Libc066 is in the experimental repository. To use that, create a file

x:\etc\yum\repos.d\netlabs-exp.repo

with content:

[netlabs-exp]
name=Netlabs experimental repository $releasever - $basearch
baseurl=http://rpm.netlabs.org/experimental/$releasever/$basearch/
enabled=1

David McKenna

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 10
  • Posts: 219
    • View Profile
Re: RPM/YUM question - Latest Libc - GCC
« Reply #2 on: January 15, 2015, 06:27:48 pm »
  You could also just type: YUM INSTALL NETLABS-EXP

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 35
  • Posts: 1066
    • View Profile
Re: RPM/YUM question - Latest Libc - GCC
« Reply #3 on: January 15, 2015, 07:53:10 pm »
You must have downloaded a different libc-0.6.6+-csd6.zip from the one I downloaded because I have it in my download.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 430
  • -Receive: 90
  • Posts: 2508
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: RPM/YUM question - Latest Libc - GCC
« Reply #4 on: January 15, 2015, 09:25:37 pm »
Thanks

"yum install netlabs-exp" (lower case) worked fine for me.

It installed the Netlabs experimental repository. On the next "yum update" it showed me the experimental updated, included libc 0.6.6.

   
Martin Iturbide
OS2World NewsMaster
... just share the dream.