OS/2 - Technical => Applications => Topic started by: Dave on 2007.05.22, 06:27:52

Title: Warpin and java programs
Post by: Dave on 2007.05.22, 06:27:52
this is two separate questions..
1. I've installed Warpin 1.0.15, but it will not open..I uninstalled it and installed ver 1.0.14, but still it will not open
(warpin.exe).. Nor will any wpi pacages open..this is a recent occurance.

2. I have some java programs, that use to work...LimeWire, Artofillusion, etc:   Now none of them open.

is there some way of testing what is going wrong or am I up the  creak without the paddle.
PS. I don't know what might have caused this, I have made no major changes to my system, except in the case
of Java I did reinstall the innotek runtime...and thats when my java programs stopped working.
Title: Re: Warpin and java programs
Post by: ChrisR on 2007.05.25, 06:58:56
Warpin stops working when the database gets to big, I had the same kind of problem.
Deleting DATABAS_F.INI did solve the problem but of course you lose the install history.
This file is getting bigger and bigger, specially when you update programs often with warpin, many programs
do appear 10 or more times in the database, update manually, extracting the files and then just overwrite is what I'm doing from now on.
When you don't want to lose your database of installed programs, then you could edit DATABAS_F.INI with a ini editor and remove all the doubles and maybe the programs you never will remove again.

Inotec java does depend on the inotec runtime, probably installing java again could solve the problem.
Typing java at a command prompt should tell more.
Title: Re: Warpin and java programs
Post by: Pete on 2007.05.25, 15:42:55
Hi Dave

ChrisR has probably hit on the answer, the related database file of installed software is probably munged.

Sadly that problem happens so often here that I do my best to avoid warpin wrapped applications; I'd rather install most manually and avoid the extra problems  :-)

Reinstalling the Innotek Runtime has probably reset some Registry entries that java142 needs so my only suggestion is to reinstall java142 to the original location and see if that cures the problem.



Title: Re: Warpin and java programs
Post by: Dave on 2007.05.25, 19:13:32
Thanks guys.. I'm going to check that .ini file  I noticed this happen when I tried to update the warpin program...
I have tried to uninstall it 2 or 3 times, so we'll see
   I am not running the innotek rt, I'm using Golden Code which was working fine until.
 My (java -version) shows java 1.1.8   I  have sent an email to GC. first time this has been a problem.
Title: Re: Warpin and java programs
Post by: ChrisR on 2007.05.27, 09:13:35
When your java version is showing 1.1.8 then your libpath and path (classpath) are not correct or are messed up.
The path and libpath are pointing to the java1.1.8 directory (folder) instead or before the gc java.
You should have a critical look at the paths in your config.sys.
And see how long they are, the paths in the config can become too long and often half of the paths are not really needed as long as there is a . (dot) as first item in the libpath.
DLL files that are only used by one program should not be in the libpath, these DLL's belong in the same folder with the rest of the application.
Mostly you start your programs from a desktop icon, no need to have them in the path either.
That's another reason to install applications manually and see if they really need to modify the comfig.sys.
Warpin does make it to easy to modify the paths, often there is no need for it at all.
Another possibility is to launch programs with setevironment command file when only one application needs a special evironment settings, mostly its smart to launch java programs with a commandfile, specially with more version of java on the same machine.
It seems your default java is 1.1.8, but how are you starting your java programs? 

Chris Roossien.
Title: Re: Warpin and java programs
Post by: Dave on 2007.05.28, 11:43:49
Chris, thanks.
         Sorry I'm an (end user). even though I've never run windows, and I'm not new to os/2\eCS, I really lack
the knowledge that the hard core OS/2 lovers have.
          here are two or three things I do notice about the libpath and path..
I see  a lot of this ( C:\;  or ;.;), also the gcc.dll in the libpath...Now I know from another person that
the libpath should not have a named file in it..so I am told.
   the path should   I have no  Java 1.1.8 folder on  my system, don't think I installed it
when I did the original install.. I did install innotek, but was having trouble with some java   script
websites, so I bought the Golden Code version 1.4.1.. I did uninstall the innotek version.
   I do have a few references to java 11 and its referenced many times in the "Classpath"
  Except for 1 or 2 occurences  Golden Code says to just unzip the program  into a folder. and thats
all that is needed.
  I'll be checking and try to remove unwanted  paths and libs see if that helps..
Thanks again