OS2World OLD-STATIC-BACKUP Forum

OS/2 - Technical => Hardware => Topic started by: Phil on 2009.04.16, 16:22:35

Title: Exceptions
Post by: Phil on 2009.04.16, 16:22:35
Hi to all:
Been running ecom RC6a for successfully for sometime, but last boot, threw this exception --exception = c0000005 occured at EIP = 1f763634 and system halted with a blinking cusor.  this happened right after the snap logo screen went away.  Any thoughts as to what caused this exception and how to fix?
Thoughts, suggestions and advice are always greatly appreciated.

Regards:
Phil
Title: Re: Exceptions
Post by: ivan on 2009.04.17, 10:39:20
Hi Phil,

I don't know much about eCs, don't have it here, but with OS/2 a trap 0005 is a BOUND RANGE EXCEEDED - contact software support.

The question is, have you added any programs or changed anything that might cause the trap, also have you tried rebootong and if so what was the result?
Title: Re: Exceptions
Post by: Radek on 2009.04.17, 12:27:24
INT 05 is range exception but the c0000005 code is reoprted by a normal GP fault. Phil, what exactly occurs on the "chernobyl screen"? Do you get a line like TRAP D or TRAP 5 something like? Does the output to the chernobyl screen hang during outputting the text (that's very bad)?
At any rate, try to comment out drivers in the CONFIG.SYS Most likely, you will need your CD and start the console from it. Try to comment out as much drivers as possible - all network, multimedia, PSD, APM and so on. Leave only video and HD. If you pass then start uncommenting "groups" - network, and so on. If you don't pass even with bare bones (HD and video) then the problem is hardware related most likely.
Title: Re: Exceptions
Post by: rudi on 2009.04.17, 16:52:49
Is that trap in module VIDEOCFG.DLL ?

If so, boot to a command line and remove the files \OS2\VIDEO.CFG and
\OS2\VIDEO.TFG.
Title: Re: Exceptions
Post by: Phil on 2009.04.18, 16:59:32
Hi Ivan
    Thanks for your response,  no I haven't changed, added or subtracted anything recently.  Tried rebooting several times with same result.

Hi radek
    Thanks for your response.  By chernobyl screen, I assume you mean the black screen with msg and blinking cursor.  There was no "trap msg come up, just the one line stating the exception.  Hang on outputting text, don' t know.   Time permitting I will try your suggestions but first, will try replacing config.sys with and earlier one and see what happens.  Hardware related ?  would that not also affect my vista side of the house ?

Hi Rudi:
    Thanks for your response.  There was no trap in module.......,  just the single line stating the exception

regards to all
Phil
Title: Re: Exceptions
Post by: abwillis on 2009.04.18, 19:00:40
I wish now I hadn't already reformatted (so I could check the exact message).  I had that type of error on my eCS 2.0 RC6a system.  Initially it was working fine but as I had done a migration I thought there was a chance there had been a problem there and didn't pursue it before just formatting and loading fresh.
Andy
Title: Re: Exceptions
Post by: Radek on 2009.04.20, 11:29:22
If you can run winblows on your machine then the HW is okay. Nevertheless, something is wrong, because you should get a whole text screen and not only one line. Most likely something failed, the system started the "chernobyl screen" and then you got trap in the video driver so that the computer got hanged during outputting the first line of text. Therefore, the problem seems to relate to video driver, too. Starting "bare bones" can fail. Well, you will see.