WebSite Information => Article Discussions => Topic started by: Saijin_Naib on 2010.09.15, 23:12:41

Title: Odin32 new build
Post by: Saijin_Naib on 2010.09.15, 23:12:41
Anyone play with this yet?

I've found it to run more programs than the previous build but it still hits many of the same limitations of the old ones. MSVCRT dlls, GDIPLUS dlls, and DirectX dlls (audio/input/etc).

However, it looks very promising. I'm going to keep tweaking with it to see if I can't get some important (to me) apps to run.
Title: Re: Odin32 new build
Post by: melf on 2010.09.16, 12:06:51
just tried a bit. Found that one program I've used, PhotoFiltre now seems to support printing wich didn't work before. Also see that text under buttons in 7zip is there constantly, which wasn't the case before.
Title: Re: Odin32 new build
Post by: Saijin_Naib on 2010.09.16, 17:59:02
Also, minor issue with this build. It does not includ OdinTool & OdinGUI 1.9 so I'd avise that anyone interested get both tools. OdinGUI simply for ease of running applications and OdinTool so you can set your NT Level and other settings.

Speaking of, I do believe OdinTool should be updated to allow us to put in more NT Levels. For instance, many of my apps check NT Level to make sure that it is at least XP Sp2 level which Odin Tool does not currently set.
Title: Re: Odin32 new build
Post by: hecom on 2010.09.16, 19:10:01
I have Flash10 installed on my desktop computer and after installing Odin, Seamonkey and Firefox are crashing when starting flash contents.
Title: Re: Odin32 new build
Post by: Saijin_Naib on 2010.09.16, 19:31:50
AIM6: Not working
Windows Vista Style Builder: not Working
BTProx: Not working (MSCOREE.dll)
ColorPic 4.1: Not Working (Exception Access Violation)
DC++: Not Working
DNRGarmin: Not Working (MSVBVM60.dll, OLEAUT32.dll)
Eusing Free Registry Cleaner: Works great (some minor drawing issues)
Eusing Free Registry Defrag: Launches fine, does not find registry to defrag (minor drawing issues)
Foxit Reader: Not Working (MSIMG32.dll, MSVCRT.dll)
Garmin MapInstall: Not Working (GDIPLUS.dll)
Google Earth: Not Working (OpenGl32.dll, MSVCRT.dll)
IE9: Not Working
TreeSize Free: Not Working
MplayHomeCenter: Not Working
Amnesty Generator: Not Working (MSCOREE.dll, .NET Framework)
Microsoft Small Basic: Not Working (MSCOREE.dll, .NET Framework)
Microsoft Expression Encoder 4: Not Working (MSCOREE.dll, .NET Framework)
Microsoft File Transfer Manager: Not Working (VC++ Runtime termination)
Microsoft VirtualPC: Not Working (Kernel32.dll error)
Mobile Media Converter: Not Working
MixMesiter BMP Analyzer: Not working
Windows Movie Maker 2.1: Not Working (WMVCore.dll, GDIPLUS.dll)
Windows Movie Maker 2.6: Not Working (WMVCore.dll, GDIPLUS.dll)
ResourceHacker Mostly Working (won't find anything but .dll files when viewing directories)
Skype: Not Working (User32.dll)
Steam: Not Working (Win32 Error: Cant set file permissions) - Launches/downloads platform updates, cant apply them
SpeedFan: Not Working (NVAPI.dll)
Taksi: Not Worknig (MSVR80.dll)
Tunatic: Not Working (MSIMG32.dll, User32.dll)
uTorrent: Not working
WeGame Client: Not Working (GDIPlus.dll)
Windows Installer Cleanup: Not working (MSVBVM60.dll, OLEAUT32.dll)
Windows Live Suite: Not Working (MSVCR90.dll)
WordPad: Not Working (MFC42U.dll)
Windows Photo Viewer: Not Working (STI.dll, API-MS-WIN-CORE-LOCALREGISTRY-L1-1-0.dll)
Windows Sidebar: Not Working (ATL.dll)
XML Notepad 2007: Not Working (MSCOREE.dll, .NET Framework)
Apophysis: Not working (HHCTRL.OCX, MSVCRT.dll)
ArcGIS: Not Working (GDIPLUS.dll)
Audacity: Not Working
Ballance: Not Working (No text in error message, likely DX related)
Chaser: Not Working (DINPUT8.DLL)
Chaser Dedicated Server Launcher: Working-ish (launches/configs fine, can't host games [DINPUT8.DLL])
Chaser FS Utility: Not Working (Exception Access Violation)
Chaser WorldStudio 2000: Not Working (Crash after load, likely DirectX related)
CMap Tools: Not Working (Java Error: Cannot find the main class)
CrashDay: Not Working (QueUser APC Kernel32.dll)
CrayonPhysics Deluxe: Not Working (D3D9.dll) - Uses SDL, might be able to work around
DropBox: Not Working
Fate: Not Working (D3D8.dll)
FEAR: Not Working (D3D9.dll)
FireFox: Not Working
Adobe Flex Builder 3: Working-ish (Launch then hang) Likely needs updated JVM, Eclipse, and Flash, but looks promising
HammerHead: Working-ish (Drawing issues, sound unconfirmed [no sound in VM])
IDRISI Andes: Not Working
Juno Nemesis: Not Working (D3DXOF.dll)
Kompozer: Not Working
LeafDrums 2: Not Working
FlashPlayer10 Stand Alone: Not Working
NFS ProStreet: Not Working (D3D9.dll)
NFS World: Not Working (MSCOREE.dll)
Nifflas Games FINCK: Not Working
Nifflas Games Knytt: Working-ish (Slow, sound unconfirmed)
Nifflas Games Knytt Stories: Not Working
Nifflas Games Within A Deep Forest: Not Working (DSOUND.dll)
OpenOffice 3.2.1: Not Working (MSVCR90.dll)
Opticks 4.3.2: Not Working (Memory Allocation Error)
Outwars: Not Working
Painkiller: Not Working (DINPUT8.dll)
PainEditor: Not Working (DINPUT8.dll)
Penumbra Games [HPL Engine]: Not working (OpenGL32.dll)
Quake2: Working-ish (crash after load)
Quake3: Working-ish (no crash, engine stops because of no OpenGL subsystem)
Quake4: Not Working (OpenGL32.dll)
Quake4 Dedicated Server Tools: Not Working (OpenGL32.dll)
RainMeter: Not Working (GDIPLUS.dll)
RocketMania Deluxe: Not Working (likely DirectX)
Secret Service: Not Working (MSVCR80.dll)
Soldier of Fortune Payback: Not Working (DINPUT8.dll)
Sonique 1.96: Not Working (Image loading errors, GDI?)
Spectra: Working-ish (Color bar blank, everything else okay)
StarShip Troopers: Not Working (DINPUT8.dll)
Synaesthete: Not Working (PowerProf.dll)
KWorld TiVME: Not Working (MSCOREE.dll)
TrackMania United Forever: Not Working (D3D9.dll)
Tuniac: Not Working (OpenGL32.dll)
Unigene Heaven: Not Working (Directx/OpenGL)
XNview: Working-ish (drawing issues, slow)
ZSNES: Not Working (DirectX)
PakScape: Working
UnetBootin: Not Working
WinDV: Working-ish (Can't confirm access to firewire camera)
Capture.NET: Not Working (MSCOREE.dll)
CCleaner: Not Working
wPrime: Not Working (MSVBVM60.dll)
CPUMon: Working-ish (Possible VM issues)
CrystalMark Tools: Not working (Admin privileges, Kernel32.dll)
DivFix: Not Working (Access Exception Violation)
DragonUnpacker: Working-ish (Image is not valid, related to Sonique issues?)
FastResolver: Working-ish (Drawing issues, resolving works 100%)
FontCreator 5.5 Portable: Not Working (Out Of Memory)
Hasher: Working-ish (Cursor drawing issue, works great)
SRWare Iron Portable: Not Working (Kernel32.dll)
lithUnwrap: Not Working (OpenGL32.dll)
Minitab v16:
MP3Val: Working
nrg2iso: Working (can't confirm convert)
PunkBuster: Not Working
RDP Password Encrypt: Working-ish (Hash seems to fail)
ReNamer (Regular Expression Namer): Working
TerraIM: Working-ish (severe drawing issues)

Title: Re: Odin32 new build
Post by: Pete on 2010.09.17, 00:22:48
Hi hecom

I'm guessing that installing the new odin files overwrites the existing odin files supplied with Flash10.

To test that Uninstall Odin and reinstall Flash10.


Title: Re: Odin32 new build
Post by: pcmzzz on 2010.09.17, 22:14:26
The Flash 10 dlls are (or should be) stored separately from your odin installation. You could try removing odin\system32 from your libpath to see what happens.
Title: Re: Odin32 new build
Post by: Saijin_Naib on 2010.09.17, 22:21:15
Melf, what release version of 7-zip are you using successfully? I'm using the 9.x beta and under each button I'm only getting the "@" symbol, but this is a marked improvement over having the buttons not drawn properly/moving around as in prior Odin builds.
Title: Re: Odin32 new build
Post by: hecom on 2010.09.18, 00:53:41
The Flash 10 dlls are stored separately from my odin installation.
I replaced advapi32.dll in flash10 directory with advapi32.dll from new odin instalation and now Flash10 preperly work in my browser.
Title: Re: Odin32 new build
Post by: Pete on 2010.09.18, 13:40:44
Hi hecom

Does your system have more than 1 cpu core in use? - Just wondering if you have found a fix for flash10 crashing the system on multicore systems.


Title: Re: Odin32 new build
Post by: Pete on 2010.11.12, 02:42:05
Hi All

How do I get odin working with the codepages (850,437) that I normally use?

Here is a simple problem: I can run OO3.2.0 for Windows Writer app using odin but when I open existing files some characters are replaced by "foreign" characters; a typical example is "ú" instead of "£".

Is there some way of sorting this out?



Title: Re: Odin32 new build
Post by: CDRWSel on 2010.11.12, 12:34:57
Hi pete,

I found following syntax for ODIN.INI (may be you could give it a try)



Title: Re: Odin32 new build
Post by: Pete on 2010.11.12, 18:21:05
Hi Remy

Yes, I tried that without any success before posting.

Looks like the current odin build is stuck on whatever codepage the developers set it to.

Ah well, guessing it is back to installing and running OO115 using ar5os2.exe instead of odin.


Title: Re: Odin32 new build
Post by: RobertM on 2010.11.14, 06:00:54
Have you tried the locale tool, as well as the "WinRegistry" tool (regedit2 if memory serves, though there may be something better or newer in the newer versions of eCS)? I'd search for the current CP values and look for the appropriate sections/keywords that may need to be changed.
Title: Re: Odin32 new build
Post by: Pete on 2010.11.14, 18:08:31
Hi Robert

I've had a rummage through the Registry, Control Panel settings and changed the instances of "ú" to "£". Sadly it makes no difference, documents still contain "ú" instead of "£".

Locale looks correct ie cp 850, altcp 437, Ansicp 1252