OS2World OLD-STATIC-BACKUP Forum

WebSite Information => Article Discussions => Topic started by: kimhav on 2011.07.28, 00:13:44

Title: OS2world Forum Access Problem & Workarround
Post by: kimhav on 2011.07.28, 00:13:44
http://www.os2world.com/content/view/20985/81/ (http://www.os2world.com/content/view/20985/81/)
Quote
Posted by Martin Iturbide - Wednesday, 27 July 2011


There is . .. .

This little annoying issue should be solved now, but please report if you find and other areas of the site which generates similar issues.

How to fix ‘Function eregi() is deprecated’ in PHP 5.3.0?
The issues that we had is related to used php function is deprecated and in our case it's both eregi() and split(); the quick fix for this is to replace eregi() with mb_eregi() and split() with explode(); at least it worked for the issues that we had.
Title: Re: OS2world Forum Access Problem & Workarround
Post by: rudi on 2011.07.28, 08:12:14
It doesn't seem to be fixed.  I get errors on login and logout.

Code: [Select]
8192: Function eregi() is deprecated
File: .../administrator/components/com_sef/sef.functions.php
Line: 168

Code: [Select]
2: session_destroy() [<a href='function.session-destroy'>function.session-destroy</a>]: Trying to destroy uninitialized session
File: .../forum/Sources/Subs-Auth.php
Line: 174

as well as the occasional:

Code: [Select]
Fatal error: Cannot call overloaded function for non-object in .../modules/mod_mainmenu.php on line 405
Title: Re: OS2world Forum Access Problem & Workarround
Post by: kimhav on 2011.07.28, 09:24:28
First error message that you received has been fixed; checked with a new browser session and I got the same error. So this one should be fixed now.

The 2nd one only seems to apply when login and logout directly via Joomla; directly login via SMF doesn't generates this error. As a starter I upgraded the SMF to the latest version, which didn't make any difference for this error and is purely related to Joomla once again... Bah. So need to google around a bit more to find a solution for this one. As the path for the erroneous script points .../forum/... it's Small Machine Forum who is the generator of the error message. But, due to that we make use of integration modules between joomla and smf.

The 3rd error message I got one time last night and so did Martin; so first believed it was a caching error or one time session error. But, seems not.

Starting to wonder if we should go back to php 5.2.x instead as this seems to be continuous never ending story of correcting errors.
Title: Re: OS2world Forum Access Problem & Workarround
Post by: IBManners on 2011.07.28, 15:24:11
Hi Kim,

Quote
Starting to wonder if we should go back to php 5.2.x instead as this seems to be continuous never ending story of correcting errors.

Sometimes you have to bit the bullet going forward, has to be done sooner rather than later for scripting upgrades.

Cheers
Ian
Title: Re: OS2world Forum Access Problem & Workarround
Post by: ivan on 2011.07.28, 21:13:11
Hi Kim,

Another error message that I get at odd times:

2: session_destroy() [<a href='function.session-destroy'>function.session-destroy</a>]: Trying to destroy uninitialized session
File: /home/os2worldcom/httpd/html/forum/Sources/Subs-Auth.php
Line: 174
Title: Re: OS2world Forum Access Problem & Workarround
Post by: sXwamp on 2011.07.29, 01:39:18
First error message that you received has been fixed; checked with a new browser session and I got the same error. So this one should be fixed now.

The 2nd one only seems to apply when login and logout directly via Joomla; directly login via SMF doesn't generates this error. As a starter I upgraded the SMF to the latest version, which didn't make any difference for this error and is purely related to Joomla once again...

If you decide to update everything and bite the bullet as Ian said.

You may want to consider SMF 2.0 Final as 1.1.14 is no longer the stable branch of SMF, as SMF 2.0 is being released and will be consider the stable branch, 1.1.14 will remain in maintenance stage.

Greggory
Title: Re: OS2world Forum Access Problem & Workarround
Post by: rudi on 2011.08.02, 16:45:10
One more problem: Clicking on page 8 on the thread:

http://www.os2world.com/component/option,com_smf/Itemid,63/topic,3092.120/

produces:

Quote
8: Undefined offset: 0
File: /home/os2worldcom/httpd/html/components/com_smf/smf.class.php
Line: 449


Title: Re: OS2world Forum Access Problem & Workarround
Post by: kimhav on 2011.08.06, 15:54:58
One more problem: Clicking on page 8 on the thread:

http://www.os2world.com/component/option,com_smf/Itemid,63/topic,3092.120/

produces:

Quote
8: Undefined offset: 0
File: /home/os2worldcom/httpd/html/components/com_smf/smf.class.php
Line: 449

Got it; but that seems to be a pure wrapper problem in combination with Joomla plugin and smf; so don't want to touch that error since it will most likely break something else if I fiddle around too much with smf... This one we have to live with until the move to latest joomla or another cms system. Also as mentioned earlier if there are issues with some threads; give it a try accessing the forum without the joomla wrapping; www.os2world.com/forum