Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - DougB

Pages: [1] 2 3 ... 28
1
Paul:

Quote
FWIW - I don't recommend removing the CONFIG_SITE reference.

Well, I get a LOT further without it, than I do with it. It always stops with:
Code: [Select]
configure.:3322: error: in `U:/wget-1.14':
configure.:3325: error: failed to load site script u:/moztools/config.site-gcc335b4
See `config.log' for more details

When I look in config.log, the only relevant thing that I see, are these three lines, which tell me nothing.

If I REM the site entry in GCC335.cmd (I also added set grep=grep.exe), I get a lot of output, that looks pretty reasonable, then it stops at:
Code: [Select]
./configure.lineno: 6947: Syntax error: "!" unexpected

If I look in the configure file (which I have to assume this is working with), line 6947 is blank. I have no idea what it wants.

Dave: I haven't got around to trying anything that you suggested, yet. More when I find the time.

2
Thanks guys. This will take a bit of study, and experimenting, and I don't have time at the moment.

Quote
BTW, I didn't release that moztools though it is basically the same as the one I use.

Sorry, I was thinking of MZFNTCFGFT.

I suppose that I really should get a new copy of Paul's build environment, but what I have is working well for what I actually use it for so I hate to upset the apple cart.

More, when I find the time...

3
Well, now I am running into configuration problems. For some reason, Paul's build seems to want to configure to build a Mozilla derivative, and it wants to use U:\moztools\config.site-gcc335b4. That file is from a release of moztools, as released by Dave Yeo, not too long ago. It bears no relation, at all, to my system, and a number of the entries don't make sense, to me. I don't think it should be using that anyway.

So, I removed the environment variables for MOZILLA, and CONFIG_SITE. Then, I get some reasonable output from:
Code: [Select]
ash ./configurebut it seems to want a different GREP than what is available. The error lines, from config.log are;
Code: [Select]
configure:5382: checking for grep that handles long lines and -e
configure:5433: error: no acceptable grep could be found in U:\foo;U:\usr\bin;U:\usr\local\bin;U:\GLIBIDL335\GLIB\gcc\bin;U:\GLIBIDL335\LIBIDL\gcc\bin;u:\PERL\bin;u:\bin;U:\MOZTOOLS;U:\EMX\bin;u:\extras\bin;u:\dev\qt\trunk\bin;U:\python25;M:\MPTN\BIN;M:\IBMCOM;M:\ECS\SYSTEM\Samba;M:\ECS\BIN;M:\TCPIP\BIN;W:\PROGRAMS\EMX\BIN;M:\IBMGSK50\BIN;M:\IBMGSK40\BIN;M:\IBMGSK\BIN;M:\OS2;M:\OS2\SYSTEM;M:\OS2\INSTALL;M:\;M:\OS2\MDOS;M:\OS2\APPS;M:\ECS\KLIBC\BIN;W:\PROGRAMS\JAVA142\BIN;M:\MMOS2\FREEDB;M:\MMOS2;M:\MMOS2\MMPLAYER;W:\PROGRAMS\4OS2;W:\PROGRAMS\OPENSSH;W:\UTILITY;W:\APPS\WGET\BIN;W:\TOOLS\dfsee\bin;W:\ODIN\SYSTEM32;W:\LOTUSW4\COMPNENT;W:\LOTUSW4\ORGANIZE;W:\LOTUSW4\APPROACH;W:\LOTUSW4\FLG;W:\LOTUSW4\WORDPRO;W:\APPS\BA2KWS;W:\PROGRAMS\qt4\bin;W:\APPS\EMBLSH;M:\ecs\ACPI\UTIL;U:\WATCOM\BINP;U:\WATCOM\BINW;U:\VISPRORX;;;/usr/xpg4/bin

Question: What is that all about?

4
Quote
I think it may help if someone can write some article on the EDM/2 on how to set up Paul's environment.

Setting up the environment means following the readme.os2 that comes with it. There is no magic there, just do as it says. Of course, you do complicate things somewhat, if you use a different drive letter.

I think the main problem is "what do I do now?" I guess the answer would be to pick a project that you want to build, and then do it. Then, it will either build, or it won't. If it does, you can be pretty sure that your basic setup is good. If it won't build, you need to figure out why it won't build, and that is where asking lots of questions (without being a PITA) comes in. The WGET program was suggested as a reasonable staring point, because it is relatively simple, and it is known to build, without problems (at least that is what I understand, I haven't actually tried it, so let's have a go.

The source is available at: http://www.gnu.org/software/wget/

You have the basic choice of an HTML page, or a FTP page. Now, you need to determine what package to get. Lets be brave, and pick the latest version (1.14). Now, there are 4 files for that. 2 are .sig files, which are probably some sort of file verification thing. We will ignore them. Now, you have a choice between wget-1.14.tar.gz or wget-1.14.tar.xz. I have no idea what .xz is, but .gz is something that the eCS archive viewer will unwrap, so lets see what we get. Looks okay to me (but what do I know?).

The download file contains a directory (wget-1.14). Put that on the same drive as Paul's build environment. Then, click on the icon that you built to launch paul's build environment. That should get you to a command line. Change to the wget-1.14 directory, and now we need to figure out how to build it. Paul's instructions are a little confusing at this point (and somewhat incomplete in some more complicated cases).

Since I am tired, I will quit here, and hopefully, somebody will make this a little easier. I am not at all sure if I still have the original setup files, or if I have messed around with them. I don't normally use the setup as Paul supplied it (which seems to be set up to build a mozilla derivative, and I do not have the latest version), so I am somewhat lost here. I am sure that most people will have the same problem.

5
Quote
I don't think anyone is asking you to stop doing what you are doing to write a manual.

I agree. Paul is not the one to write the manual. He developed his methods the hard way, learning as he went. That usually makes a person skip the obvious, simply because it is obvious (to him). What we need, is somebody to go through the procedure, asking questions along the way, and documenting what needed to be done, and why. I am sure that there are enough people who have done the basics, that we should be able to answer questions, and get something to work.

Any volunteers?

6
Quote
Have there been any updates that I have missed for successfully hibernating of eCS?

I don't think so, but I may have missed something too.

The ACPI project is still struggling to try to get suspend and resume to work on the majority of systems. Hibernation is a whole new adventure, after that works.

7
Quote
and it still doesn't set me on going. Its too short

Actually, it is enough to get you going, but you need to pick a relatively simple project to start with. Something that has already been done, so you know that it will compile  a proper program, so that you aren't fighting with program incompatibilities, as well as with setup problems.

Quote
because the things where the compilation hangs are always the same things

I'll bet that Paul, and the others, are rolling on the floor, laughing at that statement. They are also crying, because it isn't always that simple.

Paul suggests getting the WGET source, and work with that to get started. It is an excellent starting point because the program is not all that complicated, and you don't need to worry about fancy things, like which direction the window locations count. Once you get the basics to work, you can progress into more complicated things. After you do a few of those types of project, you can move on to more advanced projects, learning as you go.

I found that the hardest part, of getting started, was to tweak my setup so that it would work. Once I got that going, other things were easier. You don't want to be starting off by trying to build Firefox, simply because you would have no idea if a problem was caused by your setup, or by some code incompatibility.  The most important thing, is don't be afraid to try things, but be aware, that doing that can cause damage to your system, if you get really unlucky.

8
Utilities / Re: dfsee
« on: 2012.09.22, 23:35:21 »
ikeyxxx is not the program name. You need to use ikeyos2 when booted to OS/2 (eCS) or ikeywin when booted to windows.

9
Quote
So we have to invest in "how do you do that" in development

Quote
I also agree we need more information on porting software.

Paul Smedley actually released his whole build environment, and others have been using that to port things. I don't know what the details are now, I got the package when it first appeared, and it does work. I am pretty sure that you need to request the package, and possibly pay a modest fee, to get it now. The package does contain a very brief set of instructions on how to use it, but a user does have to do some serious digging, to learn how to go about porting software, especially when it won't build without modifying the code.

Unfortunately, it is probably not as simple as saying "do this..." with a set of instructions. Each program could require something different, so you would need a set of instructions for each program. The trick is, to get good enough at doing the job, that you can write your own instructions, but learning how to do it, is a lot of work.

10
A few years ago, the OS/4 kernel was described, by the developers, as "rearranging chunks of the OS/2 kernel, to make it work better" (or something to that effect). That would mean that every "chunk" was somebody else's work (belonging to IBM), and it was being used in new work, without the original owner's consent. If that is not copyright infringement, I don't know what is. Of course, some people seem to think that copyright laws are meant to be broken, if it is inconvenient to obey them. In this case, it is very inconvenient to obey the law, but it is the law (right, or wrong), so you need to obey it, or get it changed.

I am not sure of the actual "corporate" status of OS2World, but Mensys is a business, and a business cannot afford to break the law. There is also the requirement to provide legal software to their customers. Since the OS/4 kernel has not (probably cannot) been proven to be original work, neither one of them can take the chance that it isn't.

For the record, I am not sure that something like the OS/4 kernel (assuming it is legal) needs to be open source. If a company can build such a thing, and can get their own copyright for it, I don't see any real problem with Mensys (or  any other entity that may end up with OS/2)  paying them a reasonable royalty for their work. The main problem with doing it that way, is that the company could suddenly decide to raise the cost, or they could go out of business, or decide to terminate the project. That, of course, should be properly handled in the contract with them, so that costs are controlled, and the source (and all rights) defaults to Mensys, if they go out of business, or terminate the project. So far, Mensys seems to be rather poor at making binding contracts, but that has nothing to do with the discussion here.

11
Networking / Re: Wake on LAN
« on: 2012.09.16, 16:50:07 »
Quote
There is no need to care especially about WakeOnLan in MultiMac.

Unfortunately, that is not true, for two main reasons:

1) There needs to be a way for eCS to turn on the feature. It seems that in most cases, it is disabled. If the user does not have another OS installed, that is capable of turning it on, it can't be done. It seems that BIOS no longer has control over that, as it did in earlier machines. BIOS can prevent it from being turned on, but it cannot turn it on by itself.

2) It seems that newer machines (my Lenovo ThinkPad T510, for instance), will not leave that setting turned on, unless the driver enables it at shutdown (obviously some sort of security feature). So, if I run Win7, and enable magic packets, I can shut down, and I can use your program (well done, by the way) to turn it back on. Now, if I boot to eCS, it works fine, until I shut down, then I cannot turn it back on, using magic packets, until I run windows again, and that requires a manual power on, using the machine switch, not magic packets.

Those two "problems" should be addressed, and Multimac seems to be the way that it needs to be done (at least for the the devices operated by the Multimac driver).

I have opened an incident in TRAC for Multimac. Whether it will be fixed, or not, is up to the developers.

12
Quote
Its really the question if we are going to keep the old throttle tool alive (powerman)

Discard Powerman.EXE (and it should be deleted if found). The new ACPI does much better, and I am pretty sure that it works with many more systems.

I think you are slightly confused between Powerman.EXE, and the new ACPI configuration program. The configuration program works good, to configure ACPI, but you do need to wait for ACPIDaemon.EXE to get ready before it will work (Not sure why, it is simply used to set the contents of \MPTN\ETC\AcpiD.cfg). I have seen that take up to about 3 minutes after the rest of the boot is finished.

13
Quote
I just tried this release of ACPI on the Thinkpad R51 (1838-PS0) and the standy mode is working.

My Lenovo ThinkPad T510 will go to sleep, but it will not turn the screen back on, after waking it up (the back light stays off). Otherwise, S/R appears to work (although with no activity on the screen, it is really difficult to tell if it really did wake up). Wireless never did work, so that is waiting for the Multimac project to catch up.

Quote
I also found that Jan's pmtposd2 works on my Z61m

That works fine on my IBM ThinkPad A22e and my T43. It does not work on my Lenovo T510.

14
Networking / Re: Wake on LAN
« on: 2012.09.14, 17:46:24 »
Quote
On my IBM ThinkPad T43 (1871-W8M), I can't seem to convince it to work. I suspect that I may not have found the right BIOS, and/or, windows settings, yet.

Exactly. It seems that you need to enable the LAN ROM feature, before you can enable the magic packet feature. Oddly enough, once it is enabled, you can turn off the ROM feature again.

So, the bottom line is that the script works, but the user does need to do more than just use the script to make it turn a machine on. It also looks like the Multimac project will need to support the feature, depending on what windows version, and NIC is being used. I have no idea what other operating systems would need to make them allow a power on.

15
Rexx / Re: Get MAC address of one or more computers on LAN
« on: 2012.09.10, 23:26:50 »
Interesting approach. However, I use the SAMBA server, not PEER, so my NET commands are different. I cannot seem to find one that will produce a similar output to NET VIEW. FINDSMB.CMD seems to be close, but I am not sure if the output will work for what you are using it for. The output looks like:

Code: [Select]
                                *=DMB
                                +=LMB
IP ADDR         NETBIOS NAME     WORKGROUP/OS/VERSION
-------------------------------------------------------------------------------
192.168..100    IREBBS7        * DOMAIN/Win 95/unknown                       
192.168..101    IREBBS7        * DOMAIN/Win 95/unknown                       
192.168..108    IREBBS7        * DOMAIN/Win 95/unknown                       
192.168..110    IREBBS7        * DOMAIN/Win 95/unknown                       

The NETBIOS NAME (IREBBS7) is the name of the local machine. The IP ADDR entries are all of the machines that are online (or have been online recently), including the local machine. Also, note that the double dot in the address really should have a zero in the middle (192.168.0.100). FINDSMB.CMD is also not in the path, so a full path needs to be supplied.

There is also a "-D" parameter, that gives more information, including the MAC address, however, the MAC address is always listed as all zeros (apparently it doesn't work in eCS).

Any thoughts?

Pages: [1] 2 3 ... 28