Author Topic: New to the Board  (Read 2231 times)

AlexinOkotoks2

  • Newbie
  • *
  • Posts: 2
    • View Profile
New to the Board
« on: 2009.01.08, 06:25:44 »
Hi folks.  Well I decided to dust off the old OS/2 disks and put it on an older machine.  Turns out my old machine is more than OS/2 can handle. ;D At least with the drivers it came with.  So any thoughts as to where to turn to find more current drivers and updates?  Large HDD issue seems first to fix.

Alex

RobertM

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2034
    • View Profile
    • A.I.BuiltPC - using OS/2 Warp Server & eComStation for Custom Web and Database Solutions
Re: New to the Board
« Reply #1 on: 2009.01.08, 06:54:50 »
Hi Alex,

Please post a little more info and we will help as we can!

For instance:
Machine specs
- (CPU, HDD, Mobo, chipset video card)

OS Version:
- (Warp 4, Warp 3, WSeB, eCS, etc)

Thanks,
Robert
|
|
Kirk's 5 Year Mission Continues at:
Star Trek New Voyages
|
|


Pete

  • Hero Member
  • *****
  • Posts: 865
    • View Profile
Re: New to the Board
« Reply #2 on: 2009.01.08, 19:08:17 »
Hi Alex

You will find a lot of updates here including the last IBM free updates  http://www.os2site.com/sw/

A large HD issue probably needs the IBM IDE update applied and then you need to change the IBM1S506.ADD and IBMATAPI.flt for the DANIS506.ADD and DANIATAPI.FLT drivers as they are far more capable than the IBM drivers.

Hope the above provides a starting point. If you want more advice then you would need to be more specific about which version of OS/2 and what hardware is involved; be "chipset specific" about mainboard rather than giving a manufacturers model name/number.

Regards

Pete

AlexinOkotoks2

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: New to the Board
« Reply #3 on: 2009.01.08, 19:47:13 »
Thanks all.  Here is the list of HW.

Motherboard Gigabyte 7N400 Pro 2 Rev 2 nForce2 chipset

nVidia FX5900XT

HDD I probably have a smaller one. 20-40 Gig IDE and "perhaps" a 1GIG.

OS/2 all of them (used to do beta on OS/2 back when...) So probably Warp 4.

What of the 4.52?  Not clear on it's differences.

Alex

DougB

  • Sr. Member
  • ****
  • Posts: 407
    • View Profile
Re: New to the Board
« Reply #4 on: 2009.01.10, 00:51:35 »
Quote
Hi folks.  Well I decided to dust off the old OS/2 disks and put it on an older machine.  Turns out my old machine is more than OS/2 can handle. Grin At least with the drivers it came with.  So any thoughts as to where to turn to find more current drivers and updates?  Large HDD issue seems first to fix.

Welcome to the group...

I think your hardware should work, but you may need a more current disk driver, to get OS/2 to install. Warp 4 can be a bit of a challenge, on any hardware that is newer than about the year 2000. If you do have 4.52 (AKA MCP2), I would suggest starting with that, since it is significantly newer than the old warp 4 (it is also based on Warp Server for E-Business, rather than the older warp 4). Of course, the easy way to get the updates, and a much better installer, is to get eComStation (no, I am not part of that, except as a satisfied customer). ECS also gets you access to the latest available updates, which you can no longer get from IBM.

However, you should be able to plug in the DaniDasd IDE driver, and get something to work. Go to HOBBES:

http://hobbes.nmsu.edu/

and get danis506r185.zip. The instructions are in the docs. While you are at it, also get daniatapi040.zip.

You will have to create boot diskettes, and modify them, to get it to install using the new driver.

Hopefully, that will get you off the ground, but prepare for further problems, that may require updates, that you just can't get anywhere but  with eComStation.