Author Topic: Uniaudio and ALC 260  (Read 2635 times)

Radek

  • Full Member
  • ***
  • Posts: 201
    • View Profile
Uniaudio and ALC 260
« on: 2009.04.14, 12:16:10 »
After installing RC6a, I got problems with my Realtek ALC 260 codec. The codec used to work with Uniaudio, more preciesly, I was able to play WAVs, I wasn't able to play audio CDs. But the WAVs were enough for me.
After installing RC6a, only the operating system can use the sound card. When I try a WAV from an application, I get no sound and I lose the sound completely. The only way (known to me) to get the sound back is a reboot. This happens even if I try to play a WAV from, for example, the Chess game or from the
Solitaire, so that the problem isn't caused by badly written apps.

Blonde Guy

  • Sr. Member
  • ****
  • Posts: 283
    • View Profile
    • Blonde Guy
Re: Uniaudio and ALC 260
« Reply #1 on: 2009.04.14, 17:30:48 »
There is a dance between UniAud and ACPI. If you want to get an HD Audio sound system to work, then you will need to experiment with various versions of both. Play with versions of UniAud first. That's are easier to change.

I find it useful to note what works with each version, because when I work with the ACPI versions I may want to return to choosing UniAud version.  You need beta zone for them, but you already have rc6a, so you probably have access to betazone, too. Versions of UniAud that freeze and hang with one version of ACPI may well work with some other version of ACPI.

In particular, some of Paul Smedley's later UniAud 1.9.x builds have worked for me for HD audio, yet others did not.
Expert Consulting for OS/2 and eComStation

Paul Smedley

  • Sr. Member
  • ****
  • Posts: 322
    • View Profile
Re: Uniaudio and ALC 260
« Reply #2 on: 2009.04.18, 00:38:28 »
In particular, some of Paul Smedley's later UniAud 1.9.x builds have worked for me for HD audio, yet others did not.

Hopefully 1.9.12 works best of all versions....

Radek

  • Full Member
  • ***
  • Posts: 201
    • View Profile
Re: Uniaudio and ALC 260
« Reply #3 on: 2009.04.20, 12:54:22 »
I have tried 1.9.12 - the same result.
Sometimes, I am getting a debug log with "cannot find national language DLL, trying to load default one", sometimes I don't get this message. I didn't get this message before, when Uniaudio worked. I will try to set LANG to en_US.

Pete

  • Hero Member
  • *****
  • Posts: 865
    • View Profile
Re: Uniaudio and ALC 260
« Reply #4 on: 2009.04.20, 17:54:03 »
Hi Paul

Hopefully 1.9.12 works best of all versions....


Err, No...

1.9.2 (should that be .02?) works best with the nVidia HDA MCP61/Realtek AD1988 audio chipsets

Regards

Pete