Author Topic: OS/2 WSeB can't operate hard disk !?  (Read 2713 times)

WarpWorld

  • Global Moderator
  • Full Member
  • *****
  • Posts: 140
    • View Profile
OS/2 WSeB can't operate hard disk !?
« on: 2009.09.10, 15:00:33 »
Hi
I have Warp 4.5 Server.That is one bootable CD without floppies,maybe correctly to say internal revision 14.086_UNI (Aurora).It works very well on old pentium 2 with 333Mhz and HD of 7.85 GB.It works and on laptop Dell with HD of 40 GB, but when I put disk in computer with hard disk of 80 GB it says that can't operate my hard disk and floppy disk drives,and it stopped and says that I must restart computer...What's the problem? Do I need boot floppies which can recognize bigger HD? That HD already has FAT32 and NTFS partition,and maybe I must format to FAT32? Or maybe Warp can't work on that computer because definition of HPFS says that is the biggest HD is 64GB?
« Last Edit: 2009.09.10, 15:03:35 by Bojan89 »

warpcafe

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 746
  • Failure is not an option.
    • View Profile
Re: OS/2 WSeB can't operate hard disk !?
« Reply #1 on: 2009.09.10, 15:08:16 »
Hi,

"not able to operate hard disk" usually (IIRC) is due to a missing (nor not-loaded) driver.
It could also be (I'm not sure about the 14_048) that it already required LVM fingerprints on the volumes. But that should not prevent the 1st phase from coming up.
I tend to believe it's your IDE (?) controller which is not supported correctly. I doubt it has to do with filesystems and partitions at THAT point in bootup. I am sure others will have more, other and/or better proposals on what to check. I would continue by asking "is that an SATA controller where the 80GB is connected?"...

Cheers,
Thomas
"It is not worth an intelligent man's time to be in the majority.
By definition, there are already enough people to do that"
- G.H. Hardy

WarpWorld

  • Global Moderator
  • Full Member
  • *****
  • Posts: 140
    • View Profile
Re: OS/2 WSeB can't operate hard disk !?
« Reply #2 on: 2009.09.10, 15:13:50 »
I correct my mistake about internal revision...You want to say that I can install it on HD bigger than 64 GB...Maybe to make 2 HPFS partition of 63 and 17 GB and to try to install?

Radek

  • Full Member
  • ***
  • Posts: 201
    • View Profile
Re: OS/2 WSeB can't operate hard disk !?
« Reply #3 on: 2009.09.10, 15:23:21 »
If I understand well, you were trying to create a 80 GB HPFS partition. The biggest HPFS partition is 64 GB. Therefore, either create 2 partitions or use JFS, which does not have the 64 GB limit.

RobertM

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2034
    • View Profile
    • A.I.BuiltPC - using OS/2 Warp Server & eComStation for Custom Web and Database Solutions
Re: OS/2 WSeB can't operate hard disk !?
« Reply #4 on: 2009.09.10, 18:11:37 »
If I understand well, you were trying to create a 80 GB HPFS partition. The biggest HPFS partition is 64 GB. Therefore, either create 2 partitions or use JFS, which does not have the 64 GB limit.

Though HPFS can handle a 64GB partition, I find the most success at about the 50GB range. Also, anything over a certain size reports weird numbers to BootManager (assuming you have it installed) and some third party drive utilities (older - and possibly newer - versions of the disk widget for WPSWizard for instance). In the case of BootManager, you may find that it shows a negative (or some other weird) value for the size of the partition - simply ignore this. For the disk widget for WPSWizard (at least the version I am using - havent bothered checking for an update) it doesnt seem to calculate free space correctly - again, nothing that causes issues.

Also, in doing a long format (assuming you select that), you may find that the format progress goes to 100% and then starts again, finishing at some odd low percentage. Inotherwords:

95%
...
100%
...
5%
...
10%
...
17%
...
Format Complete.

That is apparently "normal" and can be ignored. The disk is being properly formatted and again it simply seems to be an error in calculating the partition size for the status messages which does not seem to affect the actual format operation in any way.

-Rob
|
|
Kirk's 5 Year Mission Continues at:
Star Trek New Voyages
|
|


warpcafe

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 746
  • Failure is not an option.
    • View Profile
Re: OS/2 WSeB can't operate hard disk !?
« Reply #5 on: 2009.09.10, 18:18:06 »
Rob,

wow. I never experienced either one of these problems (...but lots of different ones, sigh).
Anyway - seems like you really went through a shitload of OS/2 installs in your life! :) :)

CU
Thomas
"It is not worth an intelligent man's time to be in the majority.
By definition, there are already enough people to do that"
- G.H. Hardy

Fahrvenugen

  • Full Member
  • ***
  • Posts: 203
    • View Profile
Re: OS/2 WSeB can't operate hard disk !?
« Reply #6 on: 2009.09.11, 05:57:37 »
Hi,

I've run into the strange partition size reporting issues using large HPFS volumes too.  I've found it generally doesn't occur if you have the latest HPFS386 driver installed and have the updated fdisk / boot manager.  Since it is the server version you've got, if you do have the version with HPFS386 you might want to use that (its quicker then the older hpfs.ifs too).  On the other hand, the older 16 bit hpfs.ifs along with the older fdisk / boot manager can report strange things.

Another suggestion - on the computer with the 80 GB HDD, I'd suggest replacing ibm1s506.add with  Danis506.add driver if you havn't already.  This fixes a lot of issues with with large drives.