Author Topic: Lost XPager on desktop, please help  (Read 1653 times)

cytan

  • Full Member
  • ***
  • Posts: 213
    • View Profile
Lost XPager on desktop, please help
« on: 2009.10.29, 15:45:18 »
Hi guys,
   For some reason, my display of Xpager is not displayed on the desktop anymore although Xpager is still working. I suspect it's offscreen somewhere. Is there a way to reset its position on the desktop?

Thanks!

cytan

warpcafe

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 746
  • Failure is not an option.
    • View Profile
Re: Lost XPager on desktop, please help
« Reply #1 on: 2009.10.29, 16:49:20 »
Hi,

I have no clue if this will work - I can't check it out at the moment:
If XPager can somehow become "activated" by selecting it from the running tasks or by alt-tabbing to it, there is some chance that it reacts to ALT-F7 (although not visible). This would then make it "moveable" (perhaps, dunno the window style flags...).
In case it works, moving the mouse pointer around the visible area should drag the window with it. Click button 1 once the desired window position is reached - done.

As I said: It depends on the window style of XPager if this works at all... I think chances are few because it ain't really a "standard" PM window...

HTH,
Thomas
"It is not worth an intelligent man's time to be in the majority.
By definition, there are already enough people to do that"
- G.H. Hardy

cytan

  • Full Member
  • ***
  • Posts: 213
    • View Profile
Re: Lost XPager on desktop, please help
« Reply #2 on: 2009.10.29, 17:57:32 »
Nope, XPager is not a PM task. It is run as a daemon XWPDAEMN. I know how to restart XWPDAEMN when it dies with a -D. Are there any options besides trying to hack the registry?

cytan

cytan

  • Full Member
  • ***
  • Posts: 213
    • View Profile
Re: Lost XPager on desktop, please help
« Reply #3 on: 2009.10.29, 22:45:02 »
Here's the solution (Thanks to Mike O'Connor from the XWorkplace newsgroup on GMANE):

>You could also of course remove it completely via the XWP Setup Notebook
> on the Mouse & Keyboard Features|disable XWP hook, then if
> XWorkplace:Hook is still in the os2.ini under Applications, delete it,
> or at least its key for PagerwinPos, restart the Desktop and then
> re-enable the Hook!
>

That got my XPager back on the desktop.

cytan