Author Topic: ClamAV GUI version 2.1.0  (Read 6994 times)

David McKenna

  • Full Member
  • ***
  • Posts: 130
    • View Profile
Re: ClamAV GUI version 2.1.0
« Reply #15 on: 2011.03.06, 20:28:29 »
Hi Remy,

  I received your updated INI and EXE files and applied them.

  Now it seems I always get /etc/clamd.conf and /etc/freshclam.conf when I go to 'Clamdscan (conf)' or 'Freshclam (conf)' - even after I hit 'save' in ClamAV GUI settings. Thanks!

  One thing still seems not right...  every time I hit 'save' in ClamAV GUI settings - even if I do not make any changes - a new freshclam.conf is written the first time I run ClamAVGUI settings. Now with this new version it is written in /etc and overwrites my original ClamAV freshclam.conf (and creates a backup). Is this what you intend? It seems to me that a new one should only be written if a change that effects freshclam.conf is made.

  With respect to the RPM checkbox - yes, now that you mention it it makes sense to set that first. Maybe you could somehow check when the startup object (or line in CONFIG.SYS) is created that the file the object is set to use actually exists and if not, give a warning message? Just a thought...

  Thanks for your continued development.

Regards,

Dave McKenna

CDRWSel

  • Sr. Member
  • ****
  • Posts: 420
    • View Profile
Re: ClamAV GUI version 2.1.0
« Reply #16 on: 2011.03.06, 21:12:24 »
You already have a message about * unixroot * used ot not into parameters title but I'm no able to know if this one is used through RPM/YUM or WPI !

I'll think about how to make things better.

This should only occur at very first run time "freshclam.conf" creation due no database path was specified at this time or found in the freshclam*.conf file.
As soon it is specified, no backup should be created until it is changed

Do you have a databasedirectory entry into your freshclam.conf file ?
Case sensitive.
e.g.
DatabaseDirectory C:/var/lib/clamav

If not, then I assume no database path exist !
This is a requirement for me and if no entry exist, "save" will create a new config file with the corresponding entry. If it is missing, add this entry into your existing config file and it should not be replaced.  

FYI (For Your Information)
As soon the ini file is loaded, I check the freshclam.conf file for the databasedirectory. If it is found and is valid, I set both old path as well current path to this value. Next called general process, compares both value and if they aren't equal, a backup is created and a new conf.file created using default value
(this may be improved next to preserve other entries but the new freshclam should give correct result and backup links for updates)

Cheers
Remy    
« Last Edit: 2011.03.06, 21:36:37 by CDRWSel »

David McKenna

  • Full Member
  • ***
  • Posts: 130
    • View Profile
Re: ClamAV GUI version 2.1.0
« Reply #17 on: 2011.03.06, 22:39:46 »
Hi Remy,

  Freshclam.conf (and clamd.conf) does have the DatabaseDirectory entry as:

DatabaseDirectory /var/lib/clamav

  There is no leading C: - presumably it gets that from the UNIXROOT= value. This is how ClamAV (the RPM version) creates clamd.conf and freshclam.conf. I now notice when ClamAVGUI writes freshclam.conf it adds the leading C: to this line. Maybe this is where the trouble is?

Regards,

Dave McKenna

CDRWSel

  • Sr. Member
  • ****
  • Posts: 420
    • View Profile
Re: ClamAV GUI version 2.1.0
« Reply #18 on: 2011.03.06, 23:54:02 »

 Hi Dave,

Yes, I think so.
Could you change it and add the c: and give feedback ?
Thanks

I'll reviewed my code with this information and construct the full path using both value unixroot and this value when available with databasedirectory not having drive information.

* update for test emailed * 

Cheers
Remy
« Last Edit: 2011.03.07, 00:31:21 by CDRWSel »

David McKenna

  • Full Member
  • ***
  • Posts: 130
    • View Profile
Re: ClamAV GUI version 2.1.0
« Reply #19 on: 2011.03.08, 00:11:38 »
Hi Remy,

  I got your latest update (2.1.3f). It seems that now clamd.conf and freshclam.conf files created by ClamAVGUI leave off the leading C: (good!) on paths with RPM checked. But still I get a new freshclam.conf file written the first time I save ClamAVGUI settings after starting ClamAVGUI. It is strange it is only the first time...

Regards,

Dave McKenna

CDRWSel

  • Sr. Member
  • ****
  • Posts: 420
    • View Profile
Re: ClamAV GUI version 2.1.0
« Reply #20 on: 2011.03.08, 00:33:02 »
Strange,

It looks like the value you save (databasedirectory) isn't equal to the value read from the freshclam.conf file!
Hum ! Is the c: in upper characters or lower characters ?

I sent you a build which doesn't take care about mixed case characters for databasedirectory name. 

Cheers
Remy  
 
« Last Edit: 2011.03.08, 00:40:14 by CDRWSel »

David McKenna

  • Full Member
  • ***
  • Posts: 130
    • View Profile
Re: ClamAV GUI version 2.1.0
« Reply #21 on: 2011.03.08, 02:13:18 »
Hi Remy,

  I got your new build - thanks! - but it still does the same thing.

  There is no C: anymore - even ClamAVGUI does not put a C: in its *.conf files. I believe this is the way it should be for the RPM version of ClamAV.

  What is strange is even ClamAVGUI created freshclam.conf files will be re-written the first time after starting ClamAVGUI and saving ClamAVGUI settings. Every time after that if I click 'save' in ClamAV GUI settings, no new freshclam.conf file is created.

  Here is a step-by-step example:

1. Start ClamAVGUI
2. Go to 'Settings' -> ClamAV GUI
3. Click 'Save'. The console says a new freshclam.conf is created and the old one is saved with a new suffix.
4. Go to 'Settings' -> ClamAV GUI
5. Click 'Save'. The console says nothing and no new files are created.
6. You can repeat 4 & 5 and always nothing.
7. Close ClamAVGUI
8. Restart ClamAVGUI
9. Go to 'Settings' -> ClamAV GUI
10. Click 'Save' The console says a new freshclam.conf file is created and the old one saved with a new suffix.
11. Go to 'Settings -> ClamAV GUI
12 Click 'Save' The console says nothing and no new file is created.
...etc...

  Is there something different about the way ClamAVGUI determines whether the freshclam.conf file has been changed the first time it looks compared to later times?

Regards,

Dave McKenna

CDRWSel

  • Sr. Member
  • ****
  • Posts: 420
    • View Profile
Re: ClamAV GUI version 2.1.0
« Reply #22 on: 2011.03.08, 08:58:02 »
Hi Dave,
Thanks for the details. I'll investigate deeper and come back soon..

Cheers
Remy

CDRWSel

  • Sr. Member
  • ****
  • Posts: 420
    • View Profile
Re: ClamAV GUI version 2.1.0
« Reply #23 on: 2011.03.08, 10:26:01 »
Hi Dave,

I have found why this happens and only in RPM/YUM mode.
I sent you an updated build you can test.

Kind regards,
Remy

David McKenna

  • Full Member
  • ***
  • Posts: 130
    • View Profile
Re: ClamAV GUI version 2.1.0
« Reply #24 on: 2011.03.08, 14:19:53 »
Hi Remy,

  Yes... the new one you sent now works correctly. Thanks for your great work!

Regards,

Dave McKenna

CDRWSel

  • Sr. Member
  • ****
  • Posts: 420
    • View Profile
Re: ClamAV GUI version 2.1.0
« Reply #25 on: 2011.03.08, 23:30:57 »
Thanks Dave for the feedback.

ClamAV-GUI 213 is now online   (v2.1.3h)
It has improvements for RPM/YUM installed ClamAV as you can read in above exchange.

(h build has a small update into clamdscan process without verbose)

Kind regards,
Remy