Author Topic: Getting 1.2 to boot on 64 bit  (Read 11341 times)

OriAl

  • Jr. Member
  • **
  • Posts: 95
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #15 on: 2011.03.28, 20:02:10 »
I have two drives, and many partitions.  

What  I eventually want to have on Boot Manager is XP, eCS 1.2, and eCS 2.0 (migrated over 1.2.)  Can I have two eCS bootable partitions labeled as C:, or is that not possible?  Unfortunately, due to the way my system has been set up over the years, the boot drive has to be C:

Update - with just the 1.2 partition with the updated files set as C:, I got a boot, but no mouse.  Mouse is a USB Kensington Expert Mouse trackball.  I tried booting with mouse.sys, and then with the Expert Mouse driver which replaces it, but neither worked (there were other problems with the Expert driver boot, too.)
« Last Edit: 2011.03.28, 22:06:57 by OriAl »

Pete

  • Hero Member
  • *****
  • Posts: 865
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #16 on: 2011.03.29, 00:27:22 »
Hi OriAl

Not sure how many you can have - but only 1 "C" can be active at a time.

You could try the AMouse driver package http://www.lemsys.de/nbsoftware/driver-for-mice-with-single-wheel.html - but if the Kensington Expert worked previously then it should still work.

As you've changed the mainboard recently I suspect that the mainboard BIOS may need a tweak: Try Disabling a setting something like "USB Legacy Support".

Also check you have the necessary USB lines in config.sys - the number and type of Controllers may be different to your previous mainboard:-

BASEDEV=USBUHCD.SYS
BASEDEV=USBOHCD.SYS
BASEDEV=USBEHCD.SYS

You need 1 line for each instance of every Controller on the mainboard eg 2UHCD + 1 EHCD:-

BASEDEV=USBUHCD.SYS
BASEDEV=USBUHCD.SYS
BASEDEV=USBEHCD.SYS


Hope the above is of some help.

Pete

OriAl

  • Jr. Member
  • **
  • Posts: 95
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #17 on: 2011.03.29, 20:08:43 »
How do I find the number of controllers on the motherboard?

I'll check the bios.

Thank you.-

ivan

  • Hero Member
  • *****
  • Posts: 593
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #18 on: 2011.03.29, 22:35:23 »
Just grab usbcfgb071.zip from hobbes, unzip and run install then use usbcfg to tell you how many of each controllers you have.

ivan

Pete

  • Hero Member
  • *****
  • Posts: 865
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #19 on: 2011.03.30, 00:49:27 »
Hi OriAl

Boot to a mouseless Desktop and run USBcfg - http://hobbes.nmsu.edu/download/pub/os2/system/USBcfgb071-eCS-only.wpi

The Controllers are listed on the 1st page so you should be able to set those correctly without a mouse  :-) 

If the "Controller Drivers Installed" do not match the Type / Quantity displayed in "Controllers Available" use the Tab key to get to the "Default" button and press Enter; that should change the "Controller Drivers Installed" to the type and quantity listed in "Controllers Available".

Regards

Pete

ivan

  • Hero Member
  • *****
  • Posts: 593
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #20 on: 2011.03.30, 01:49:38 »
Hi Pete,

I knew there was an eCS version from things you have said before but I couldn't remember what it was.

ivan

David McKenna

  • Full Member
  • ***
  • Posts: 130
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #21 on: 2011.03.30, 02:19:00 »
OriAl,

  An alternative to Pete's suggestion is boot to a command line (via the <alt>F1 menu) and type: HCIMONIT

  You will get a message saying exactly what and how many USB controllers are detected. Then you can manually change CONFIG.SYS using TEDIT.

Regards,

Dave McKenna

OriAl

  • Jr. Member
  • **
  • Posts: 95
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #22 on: 2011.03.31, 20:23:08 »
I'll try these suggestions.  Booting to command line seems like a better idea, because I don't see how I can run usbcfg without a mouse.

RobertM

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2034
    • View Profile
    • A.I.BuiltPC - using OS/2 Warp Server & eComStation for Custom Web and Database Solutions
Re: Getting 1.2 to boot on 64 bit
« Reply #23 on: 2011.04.05, 19:40:01 »
I'll try these suggestions.  Booting to command line seems like a better idea, because I don't see how I can run usbcfg without a mouse.

Judicious use of the tab and spacebar key. Tab obviously goes forward a field. Alt-Tab goes backwards. Spacebar "presses" buttons (radio, push or checkbox) or activates notebook tabs that are "highlighted". The Enter key works interchangeably with the spacebar key for some of those as well.
|
|
Kirk's 5 Year Mission Continues at:
Star Trek New Voyages
|
|


OriAl

  • Jr. Member
  • **
  • Posts: 95
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #24 on: 2011.04.10, 19:23:40 »
Update - I used the usbcfg (it was already on the 1.2 partition), and changed the settings to drivers matched available.  Rebooted, and I have my mouse (with mouse.sys, not the Kensington driver - I'll try to install that after using this for a while.)  I still have no sound, but didn't before, either.

There is no AHCI in config.sys.  That isn't needed for 1.2, if I gather right.

Now that I'm here, how do I find the network name and other things eCS 2 install asks?  I'm eventually going  to save this, and migrate 2.0 over a copy.

OriAl

  • Jr. Member
  • **
  • Posts: 95
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #25 on: 2011.04.12, 18:49:50 »
I tried to install the Kensington Expert mouse driver.  The mouse wasn't found during boot (it's usb), so I uninstalled that, and rebooted using mouse.sys.  Boot went fine, mouse was working, but system quickly locked up.  So, I'm back in XP.

OriAl

  • Jr. Member
  • **
  • Posts: 95
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #26 on: 2011.04.23, 20:15:11 »
Same problem remains - system boots to 1.2 (with mouse.sys), works for a few minutes, then locks up.  No popuplog.os2.  Something's still not right.  I believe I installed or replaced all the files I was told about.

I will need the Expert Mouse driver to work as it did prior to the 64 bit motherboard, in 1.2 and 2.0.  I'm disabled, and require the Locked Down setting for the upper left and right buttons.

Thanks, as always.
« Last Edit: 2011.04.23, 20:19:04 by OriAl »

RobertM

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2034
    • View Profile
    • A.I.BuiltPC - using OS/2 Warp Server & eComStation for Custom Web and Database Solutions
Re: Getting 1.2 to boot on 64 bit
« Reply #27 on: 2011.04.23, 20:54:14 »
Have you tried aMouse.sys? I've had better success with that.
|
|
Kirk's 5 Year Mission Continues at:
Star Trek New Voyages
|
|


OriAl

  • Jr. Member
  • **
  • Posts: 95
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #28 on: 2011.05.04, 20:52:25 »
Amouse doesn't have a setting to lock down the top buttons on the Expert Mouse.  I need that.

I'm booting with mouse.sys, but the lockups continue.

Andi

  • Sr. Member
  • ****
  • Posts: 264
    • View Profile
Re: Getting 1.2 to boot on 64 bit
« Reply #29 on: 2011.05.05, 12:30:01 »
As you have these problems for a long time I can not remember exactly what you all have tried and did not help. So probably I cant help. But 'sudden lookups' triggered my memory. I've seen such behavior with Realtek rtgnaxxx network drivers (maybe in conjunction with ACPI /APIC switch), Dawicontrol SCSI driver and with smplayer (uniaud, SNAP, dani...???).