Author Topic: eCS 2.1 installation.. crashed...  (Read 1752 times)

xchris

  • Newbie
  • *
  • Posts: 49
    • View Profile
eCS 2.1 installation.. crashed...
« on: 2012.02.23, 01:33:04 »
After I ejected an 160GB HDD (could not see the contents of the drive anyway (due to the current bugy NTFS))
I got a nice NTFS crash error.. then I rebooted the system...

now the OS boots and stops on the "EVFS eComstation Virtual File System Driver v.1.002"

I really don't understand.. I just ejected a device and the eCS auto-corrupted?! f unbelievable!
(note I was on JFS filesystem)

any ideas?

Chris

RobertM

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2034
    • View Profile
    • A.I.BuiltPC - using OS/2 Warp Server & eComStation for Custom Web and Database Solutions
Re: eCS 2.1 installation.. crashed...
« Reply #1 on: 2012.02.23, 02:03:37 »
May wish to boot to command prompt and disable the NTFS driver as a start, to get you booted again.
|
|
Kirk's 5 Year Mission Continues at:
Star Trek New Voyages
|
|


Pete

  • Hero Member
  • *****
  • Posts: 865
    • View Profile
Re: eCS 2.1 installation.. crashed...
« Reply #2 on: 2012.02.23, 02:52:01 »
Hi Chris

As you've discovered the NTFS filesystem driver does not work very well so do not bother with it.

If you really need to share a drive between eCS and Windows then use FAT32 - not brilliant but it does work - slowly.

 I suspect that the NTFS crash has left the eCS filesystem "dirty" but marked as "clean" so boot from the eCS Install CD and go to the Maintenance Console. Once booted open a command window and run chkdsk [drive]: /f against the boot drive that no longer boots.

Hopefully that will fix things.


Regards

Pete

xchris

  • Newbie
  • *
  • Posts: 49
    • View Profile
Re: eCS 2.1 installation.. crashed...
« Reply #3 on: 2012.02.23, 09:35:37 »
Alas, I will have to do a complete re-installation...
the boot cd went to maint mode and I did the check disk... then  I booted from the hdd again and
I faced the same situation...
also. booting on recover mode (ALT F1) did not work either (OS stopped on  "EVFS eComstation....")

The strange thing is i just unmounted an external HDD .. I mean how the NTFS driver corrupted the whole OS
because of it.. ok you know I am pissed off.. I even can use that external drive on an  Amiga 4k using a 20yrs old OS and a "freeware" driver!

chris


melf

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 606
    • View Profile
Re: eCS 2.1 installation.. crashed...
« Reply #4 on: 2012.02.23, 10:28:33 »
Use the boot CD again and go to maintance consol. Use the texteditor to rem out the ntfs driver as Robert suggested (and possibly also the evfs driver). Then it would be possible to boot.

I had similar problems with my USB HDD and NTFS. However these problems were solved when I did a complete erase and repartition of that HDD. (I used DFsee but can't really remember how. Also there is of course a risk to do wrong things with dfsee, and get other troubles). I now have two NTFS partitions and a JFS on that harddrive. As the NTFS partitions is just readonly for eCS its mostly usable as a storage for eg music videos etc.
/Mikael

xchris

  • Newbie
  • *
  • Posts: 49
    • View Profile
Re: eCS 2.1 installation.. crashed...
« Reply #5 on: 2012.02.23, 10:42:50 »
Thx... I managed to boot (disabled evfs) I just copied my files on a spare fat32 partition and now I am re-installing the eCS....