Author Topic: QT 4.x framework Port  (Read 21722 times)

Pete

  • Hero Member
  • *****
  • Posts: 865
    • View Profile
Re: QT 4.x framework Port
« Reply #45 on: 2010.01.24, 19:06:50 »
Hi

Using kva(slow) keeps the video playing - but it is far too jerky to be used for watching anything. This was reported to Silvan previously, within these forums.

I now find that I have no audio produced. Switching video output back to kva(faster) does not cure that so I'm not sure if that is a result of sacking acpi and reverting to os2apic recently. I doubt I'm interested in swapping back to a barely functioning acpi to find out.


Regards

Pete

magog

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
    • Personal Homepage (Ports, Development,...)
Re: QT 4.x framework Port
« Reply #46 on: 2010.01.25, 20:56:35 »
I think you are using the wrong audio output setting. As I haven't installed SMPlayer I can't tell you where to set it exactly (maybe there is a setting to allow user-defined settings).

For audio you should be able to use "kai:dart" or "kai:uniaud".

For video you can choose between:
"kva:dive", "kva:snap" or "kva:wo"

Dive should always works, snap obviously only with SNAP installed (I'm not sure if a card supported by SNAP Overlay is needed) and wo is for WarpOverlay only.

All settings can also set in a global mplayer configuration (c:\home\default\.mplayer\config).
Regards,
Juergen
*** Java Movie Database - http://www.jmdb.de/

Pete

  • Hero Member
  • *****
  • Posts: 865
    • View Profile
Re: QT 4.x framework Port
« Reply #47 on: 2010.01.26, 02:50:51 »
Hi magog

I think you have hit on the problem: The current mplayer uses kai:dart (or kai:uniaud) but the smplayer qt4 build does not offer those choices. The choice is "kai" or "user defined, dart"; not "kai:dart".

As mplayer works fine on the command line using ao=kai:dart in the mplayer config file I can only guess that smplayer is not offering the correct choices and the configuration value supplied by smplayer to mplayer overrides the mplayer configuration hence the missing audio.

Regards

Pete



Pete

  • Hero Member
  • *****
  • Posts: 865
    • View Profile
Re: QT 4.x framework Port
« Reply #48 on: 2010.01.26, 02:56:24 »
Hi

And the answer to the missing sound with the smplayer qt4 build is to edit the %HOME%\.smplayer\smplayer.ini file to change this line
driver\ao=dart
to this
driver\ao=kai:dart


Regards

Pete

zizban

  • Newbie
  • *
  • Posts: 25
    • View Profile
Re: QT 4.x framework Port
« Reply #49 on: 2010.02.08, 21:04:13 »
The link on the front page to QT4 GA is wrong.

It should be:
ftp://ftp.netlabs.org/pub/qt4/4.5.1-ga/