Author Topic: Missing CD drive running DaniS506 1.8.x  (Read 3058 times)

djcaetano

  • Full Member
  • ***
  • Posts: 205
    • View Profile
Missing CD drive running DaniS506 1.8.x
« on: 2008.02.08, 17:46:47 »

  Since I had installed DaniS506 1.8.0 and 1.8.1 I had noticed that I am not able to access my CD drive. On my Warp 4.52 machine I reverted back to the latest 1.7.x and the CD drive came back; on the eCS machine, though, I was not able to revert to 1.7.x, since the newest ACPI installed require 1.8.x.
  Anyone has any tips or clues about what is happening? Anyone with the same problems?

  Thanks in advance.

Saijin_Naib

  • Hero Member
  • *****
  • Posts: 1357
  • Birdie Num-Nums
    • View Profile
    • Synperz Domain
Re: Missing CD drive running DaniS506 1.8.x
« Reply #1 on: 2008.02.08, 17:58:55 »
I believe I had the same issue with a build of the Dani driver on my old Compaq Presario laptop. A backleveled version worked fine, but the newest builds would lose the CD-ROM drive. I am not sure what caused this, but I guess its a temporary regression in Dani's code. Im sorry, Im not sure what you can do about it other than maybe email her with your concern, or keep the backleveled versions for now, and not use ACPI?

El Vato

  • Guest
Re: Missing CD drive running DaniS506 1.8.x
« Reply #2 on: 2008.02.08, 18:07:13 »

[...]
  Anyone has any tips or clues about what is happening? Anyone with the same problems?

  Thanks in advance.

You may want to install the corresponding newer Daniela ATAPI filter driver, in addition to DaniS506...

IBMIDECD.flt, IBMATAPI.flt as well as DaniATAPI.flt are responsible for the CDROM devices.  If you have both in your OS/2 CONFIG.SYS file, you may try remming out one of them so as to avoid issues

djcaetano

  • Full Member
  • ***
  • Posts: 205
    • View Profile
Re: Missing CD drive running DaniS506 1.8.x
« Reply #3 on: 2008.02.08, 21:36:51 »
You may want to install the corresponding newer Daniela ATAPI filter driver, in addition to DaniS506...

  I'm afraid it's already installed. Well, if no one had this problem/could find a solution, I believe it is time to mail Daniela a bug report. :)

El Vato

  • Guest
Re: Missing CD drive running DaniS506 1.8.x
« Reply #4 on: 2008.02.08, 22:59:48 »
You may want to install the corresponding newer Daniela ATAPI filter driver, in addition to DaniS506...

  I'm afraid it's already installed. Well, if no one had this problem/could find a solution, I believe it is time to mail Daniela a bug report. :)
Also read Daniela's driver documentation for certain relevant options that might be needed in her new driver releases.

If you are absolutely sure that Daniela's ATAPI driver has completely replaced the older driver in your <drive>:\OS2\BOOT directory, then you may want to check on the date of your OS2CDROM.DMD AND OS2DASD.DMD (unless you have daniDASD.dmd from 2001-2002, of course). 

Further, you may even want to try out the last equivalent versions of those drivers from IBM.  They are packaged in an zipped file named --if I remember well-- IBMIDE.zip (or IDEDASD.EXE).

A word of caution:  if you use the zip/exe packaged IBM alternatives, you will find two different versions of OS2DASD.DMD that are not interchangeable (because you will loose access to your CDROM device).  Paraphrasing:

If your machine has Warp Server for e-business,
 Warp Server for e-business Convenience Pak, or Warp 4 Convenience Pak, (or eCS --I think) rename the DASD32.DMD to OS2DASD.DMD.  Otherwise rename the DASD16.DMD to OS2DASD.DMD.

Good luck.

abwillis

  • Sr. Member
  • ****
  • Posts: 325
    • View Profile
Re: Missing CD drive running DaniS506 1.8.x
« Reply #5 on: 2008.02.16, 00:17:10 »
I had this issue when I first switched to these drivers.  It turned out there was an older version of danis506.add in the root of the drive.  The order of use I believe is boot root then \os2 and then \os2\boot.