ASRock B450M Pro 4

From OS2World.Com Wiki
Jump to navigation Jump to search
B450M Pro4(L1).png

General Specs

Socket
AMD AM4 Socket
Chipset
Tested Processor
AMD Ryzen 3 3200G 2nd generation
  • Supports DDR4 3200+ (OC)
  • 1 PCIe 3.0 x16, 1 PCIe 2.0 x16, 1 PCIe 2.0 x1
  • AMD Quad CrossFireX™
  • Graphics Output: HDMI, DVI-D, D-Sub
  • 7.1 CH HD Audio (Realtek ALC892 Audio Codec), ELNA Audio Caps
  • 4 SATA3, 1 Ultra M.2 (PCIe Gen3 x4), 1 M.2 (SATA3)
  • 2 USB 3.1 Gen2 (Rear Type-A+C)
  • 6 USB 3.1 Gen1 (2 Front, 4 Rear)
  • Realtek Gigabit LAN
  • Release Date: 2020

Devices

Component Name HardwareID Status Driver
Processor AMD Ryzen 3 3200G 2nd generation N/A Check.gif ACPI
HDD - SATA AMD 400 Series Chipset SATA Controller 1002:43C8 Check.gif OS2AHCI, DANIS506
HDD - SATA AMD FCH SATA Controller [AHCI mode] 1002:7901 Check.gif OS2AHCI, DANIS506
Audio AMD Raven/Raven2/Fenghuang HDMI/DP Audio Controller 1022:15DE Vraag.gif Not tested
Audio AMD Family 17h (Models 10h-1fh) HD Audio Controller 1002:15E3 Check.gif UNIAUD
Network Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 10EC:8168 Check.gif
Video (AGP) AMD Picasso 1002:15D8 Check.gif SNAP Graphics, Panorama
USB (xHCI) AMD/ATI 400 Series Chipset USB 3.1 XHCI Controller 1002:43D5 Check.gif
USB (xHCI) AMD Raven USB 3.1 1002:15E0 Check.gif
USB (xHCI) AMD Raven USB 3.1 1002:15E1 Check.gif

General Comments

Report by Ivan
ASRock B450M Pro 4 motherboard with an AMD Ryzen 3 3200G 2nd generation processor with Radeon graphics. Added to that is a Crucial 250GB SSD drive, 8 GB Memory with a 250GB WD Green SATA SSD M.2.
Install was a bit of a problem until I setup the partitions on the Crucial SSD with DFSee on my test computer. With those setup the install DVD saw them and everything went ahead as it should.
The fact that the motherboard doesn't have any real USB 2 ports (those it does have are a subset of the USB 3 CPU/chipset) did make things a little 'sensitive' to start with - the trackball kept on locking up if I tried to click on something while waiting for something else to happen.
There are a few other 'problems' which I think I can workaround with some thought, things like getting NoScript and AdBlock plus to install in firefox and needing to change the TZ in config.sys and add OSLEXAM.DLL to OS2\DLL to get the spell check in EPM to work - all things I have done in the past but forgotten about since all the installs with Ryzen processors prior to this have been from already setup images.

Hardware Report

Links