Intel Desktop Board DB85FL

From OS2World.Com Wiki
Jump to navigation Jump to search
Desktop-board-db85fl-3-1.png.rendition.cq5dam.thumbnail.310.155.png

General Specs

Socket
LGA1150
Chipset
Intel B85
Release Date
Q2'2013

Devices

Component Name HardwareID Driver Status
Processor Intel Core i7-4770 Working -- ACPI
Audio Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller 8086:0C0C UNIAUD32.SYS, UNIAUD16.SYS Not working
Audio Intel 8 Series/C220 Series Chipset High Definition Audio Controller 8086:8C20 UNIAUD32.SYS, UNIAUD16.SYS Not working
SATA Intel 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] 8086:8C02 OS2AHCI Wirking
Video Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller 8086:0412 -
USB 3.0 USB 8 Series/C220 Series Chipset Family USB xHCI 8086:8C31 -
USB 2.0 Intel 8 Series/C220 Series Chipset Family USB EHCI #2 8086:8C2D -
USB 2.0 Intel 8 Series/C220 Series Chipset Family USB EHCI #1 8086:8C26 -
Networks Intel Ethernet Connection I217-LM 8086:153A

General Comments 1

Tested with eComStation 2.2 beta 2.

BIOS Settings

This machine has a "Legacy Boot mode" to not only depend on UEFI BIOS.

IntelVisualBIOS.JPG

If the legacy mode is turned on in the BIOS, eComStation will boot. Otherwise it will show you an error.

A bootable device has not been detected.
Please refer to the Product Guide at http://support.intel.com/support/motherboar
ds/desktop/

ACPI - Boot

eComStation 2.2 beta will boot on this configuration (DB85FL with Intel Core i7-4770) as a standard boot.

The ACPI driver will recognize 8 cores, maybe because has Intel® Core™ i7-4770 Processor 8 threads according to its specification.

I7-4770-8coresboot.JPG

I7-4770-8cores.JPG

Audio

The mainboard has a "Intel Lynx Point PCH - High Definition Audio Controller [C1]/ Codec: RealTek ALC662". UniAud shipped with eCS 2.2 b2 was installed, the device get recognized on the boot but it produces no sound.

Video

The mainboard has a "Intel Haswell-DT GT2 - Integrated Graphics Controller [Intel] - Intel HD Graphics 4600" video chipset. On the installation Panorama was installed and a 1920x1080 resolution was selected for the next boot. It worked without any major issue.

USB 2.0

The USB 2.0 ports were recognized by the eCS 2.2 installer. Also an USB mouse and keyboard was used during all the install procedure without issues.

Network

The wired network adapter "Intel I217-V (ClarkvilleV) Network Adapter / Intel(R) Ethernet Connection I217-V" was not recognized by the installer. Some intel network drivers was tested (E1000e.OS2, E1000_c.OS2, E1000.OS2) without being able to make it work.

General Comments 2

Tested with ArcaOS 5.0.6 (beta) with UEFI and GPT support. It installed and booted the OS.

  • BIOS was enabled as UEFI
  • GPT partition where used on the Hard drive.
  • Video worked with Panorama
  • Audio was not possible to be further tested.

Hardware Report

Links