Author Topic: OS/2 Warp 4.52 and Broadcom NetXtreme 57xx  (Read 319 times)

Ab Pp

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
    • View Profile
OS/2 Warp 4.52 and Broadcom NetXtreme 57xx
« on: May 17, 2018, 10:49:44 pm »
I always wanted to try OS/2 Warp 4 since I first saw it in 1995 but I am not willing to pay over $100 USD for ECS or ArcaOS...yet. So, I am trying OS/2 Warp 4.52 in an old Dell laptop (no VM, wanted real hardware). The installation went well and despite no good graphics, no audio, and no USB yet, all I want for now is network/Internet. This is an old Dell Latitude D610 with a Broadcom NetXtreme 57xxx Gigabit. I found the B57.OS2 driver files online and installed them via the Multiprocols control panel but is NOT working. OS/2 is not detecting the NIC and get the error during bootup. Why??  :(

Pete

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 28
  • Posts: 635
    • View Profile
Re: OS/2 Warp 4.52 and Broadcom NetXtreme 57xx
« Reply #1 on: May 18, 2018, 12:24:49 am »
Hi

I must admit to not having had much luck with Broadcom nics in the past - in fact with my 2 old laptops I removed the Broadcom wireless nics and replaced with the Intel equivalents .

I did, however, get a wired Broadcom BCM5787M, pci ID 14e4:1693, working at 1 point. I seem to recall trying several B57 drivers before finding a working driver which is B57.OS2 dated 30/01/2007 size 46,394bytes

Due to hard drive failures a few years back I no longer have the zip package and do not know where it came from - I think it was downloaded directly from Broadcom.

I guess I could zip up the driver and email it to you but no guarantees that it will work with your hardware.


Regards

Pete


 

Ab Pp

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
    • View Profile
Re: OS/2 Warp 4.52 and Broadcom NetXtreme 57xx
« Reply #2 on: May 18, 2018, 01:51:17 am »
Thanks for the reply. Yes, my Broadcom is an internal Ethernet card. I went to Broadcom's site and all I saw were Windows drivers. I got the B57.OS2 driver from one of the OS/2 fan sites and I guess it should work, I do not know why is not. If you can, mail me yours and I will try it. Thanks. :-)

Pete

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 28
  • Posts: 635
    • View Profile
Re: OS/2 Warp 4.52 and Broadcom NetXtreme 57xx
« Reply #3 on: May 18, 2018, 02:39:25 am »
Hi Ab Pp

I have attached b57.zip to this post

All you probably need is the driver file, b57.os2, but I included the nif, ini and readme files for completeness.

Hope it works with your hardware.


Regards

Pete

Andi B.

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 14
  • Posts: 359
    • View Profile
Re: OS/2 Warp 4.52 and Broadcom NetXtreme 57xx
« Reply #4 on: May 18, 2018, 08:58:30 am »
IIRC correctly you need a driver version 9.xx. Later versions did not work for me. And I think the NIC needs an IRQ < 16. This maybe route able in BIOS or is default with older hardware anyway.


Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 39
  • Posts: 1023
    • View Profile
Re: OS/2 Warp 4.52 and Broadcom NetXtreme 57xx
« Reply #5 on: May 18, 2018, 07:27:05 pm »
There are a number of BROADCOM adapters packaged for GENMAC. See: ftp://genmac@ftp.os2voice.org/ (use the word "unsupported" no quotes, and lower case, if it asks for a password). If your's isn't listed, tell me exactly what it is, and I will see if we can make something work. You do need the base GENMAC support to use those packages.

Pete

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 28
  • Posts: 635
    • View Profile
Re: OS/2 Warp 4.52 and Broadcom NetXtreme 57xx
« Reply #6 on: May 18, 2018, 10:49:25 pm »
Hi Andi B.

My experience is exactly the opposite. All versions prior to 10.03 (version in B57.ZIP) failed to work the bcm5787m nic in my old Acer Travelmate 5320 laptop.


Regards

Pete