Author Topic: Razor-Qt and OS/2  (Read 2111 times)

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 280
  • -Receive: 54
  • Posts: 1847
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Razor-Qt and OS/2
« on: September 28, 2013, 03:43:55 am »
I was checking some time ago the Razor-Qt project. Which is a Qt desktop environment.

I was hoping that it can be ported to OS/2, but checking its dependencies seems we are missing some:

    Qt 4.6 or above (inluding QtDBus) - YES
    X11: - (very old?)
    libmagic (usually part of the "file" package) (No)
    zlib (Yes)

I'm not sure about the X11 stuff, I know we have some X11 ported but it is old.

It will be interesting to try to port this to OS/2-eCS but it don't seems feasible. Any comments from someone that has more development/porting experience?

Martin Iturbide
OS2World NewsMaster
... just share the dream.


  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 6
  • Posts: 51
    • View Profile
Re: Razor-Qt and OS/2
« Reply #1 on: September 28, 2013, 09:51:48 am »
Hi Martin,

I looked some time ago at it, but since it needed QtDbus i stop looking at it, cause we don't have QTdbus so useless to look...!

This is what the guy from the program  told me...
« Last Edit: September 28, 2013, 10:30:15 am by TeLLie »