Author Topic: LVM Error Codes - Documentation?  (Read 281 times)

Eric Erickson

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 39
    • View Profile
LVM Error Codes - Documentation?
« on: August 21, 2019, 11:57:47 pm »
Is there a list of what the various LVM Error codes indicate?

I'm trying to build a new Maintenance Partition (ArcaOS 5.03) on on an existing System. When I try the install, I get a popup about LVM Error 10 when I try and select the new partition for the new install.

Booting to the main system (ArcaOS 5.01) and executing LVM Reports invalid Partition Data on Disk 2, but running DFSEE V11 does not report any issues with it. So I'm wondering a couple of things.

1) What the 10 telling me (Invalid Partition Info)?
2) Is there documentation on LVM Engine Error Codes?
3) How to figure out whats wrong with the partition info, since DFSEE does not report any errors?

TIA.

Tom

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 23
    • View Profile
Re: LVM Error Codes - Documentation?
« Reply #1 on: August 22, 2019, 02:20:11 am »
You can find more information about LVM on Alex Taylor's website:

http://altsan.org/os2/toolkits/lvm/index.html

where you can download version 1.5 of the LVM Programmer's Toolkit for OS/2 (on Hobbes you can still find version 1.4).

The errorcodes are also listed on Alex's site:

http://altsan.org/os2/toolkits/lvm/lvmref/LVMREF_0096.html

where it says about errorcode 10:

LVM_ENGINE_BAD_PARTITION                      10

For more information about what is bad about that partition, you could try typing the following command in DFSee:

part -w:t -t-

Even better: ask Jan van Wijk for help (which assumes you have a registered copy of DFSee).


Is there a list of what the various LVM Error codes indicate?

I'm trying to build a new Maintenance Partition (ArcaOS 5.03) on on an existing System. When I try the install, I get a popup about LVM Error 10 when I try and select the new partition for the new install.

Booting to the main system (ArcaOS 5.01) and executing LVM Reports invalid Partition Data on Disk 2, but running DFSEE V11 does not report any issues with it. So I'm wondering a couple of things.

1) What the 10 telling me (Invalid Partition Info)?
2) Is there documentation on LVM Engine Error Codes?
3) How to figure out whats wrong with the partition info, since DFSEE does not report any errors?

TIA.

Eric Erickson

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 39
    • View Profile
Re: LVM Error Codes - Documentation?
« Reply #2 on: August 22, 2019, 06:49:32 pm »
Ok, I did the part -w:t -t- and it did not flag any errors. Got a bunch of warning messages about partitions after the 1023 cylinder boundary or crossing the 1023 boundary, but no errors shown.

I've got an older (V11) registered version of DFSEE. So I might go that route. But first I'm going to migrate all the partitions off the drive, wipe the drive and then try an install again.