Author Topic: GCC 9.2.0 upgrade - ligcc1 issue?  (Read 306 times)

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 16
  • Posts: 659
    • View Profile
GCC 9.2.0 upgrade - ligcc1 issue?
« on: February 11, 2020, 05:13:03 am »
Has anyone tried to the GCC 9.2.0 upgrade (through RPM package install)?

I have 4.9.2 at the moment but figured I'd go down the 9.2.0 path. Well, from within ANPM the upgrade ended pretty quickly:

Code: [Select]
Package libgcc1 is obsoleted by libgcc, but obsoleting package does not provide for requirements
Running Transaction Check
YumRPMCheckError(): [u'ERROR with transaction check vs depsolve:',
'libgcc1 is needed by (installed) libaio-0.0.1-5.oc00.pentium4',
'libgcc1 is needed by (installed) libvncserver-0.9.10-4.oc00.pentium4',
'libgcc1 is needed by (installed) libidl-0.8.14-6.oc00.pentium4',
u'Please report this error at http://yum.baseurl.org/report']

Error: ERROR with transaction check vs depsolve:
libgcc1 is needed by (installed) libaio-0.0.1-5.oc00.pentium4
libgcc1 is needed by (installed) libvncserver-0.9.10-4.oc00.pentium4
libgcc1 is needed by (installed) libidl-0.8.14-6.oc00.pentium4

So basically looks like something's missing from the 9.x release of libgcc, which obsoleted the 4.9's libgcc1.

I logged a ticket with bww here => https://github.com/bitwiseworks/gcc-os2/issues/18

In the meantime, I'm curious if this is a known issue?

Pete

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 36
  • Posts: 892
    • View Profile
Re: GCC 9.2.0 upgrade - ligcc1 issue?
« Reply #1 on: February 11, 2020, 06:44:46 am »
Hi Dariusz

I'll take a guess, based on previous similar surprises, and say there is probably some sort of dll forwarder package to cover earlier gcc needs...

Just had a quick look with ANPM and I see libgcc-fwd which looks from the package details that it may well be the bit you need.


Regards

Pete