Author Topic: Setting up a WiFi Connection  (Read 497 times)

DF94

  • Newbie
  • *
  • Thank You
  • -Given: 5
  • -Receive: 0
  • Posts: 4
    • View Profile
Setting up a WiFi Connection
« on: February 14, 2020, 09:16:51 pm »
Hello everyone!

Following my last thread, I've since managed to get ArcaOS up and running on my old Thinkpad. Using it has been an absolute blast so far, and I've just been putzing around getting a "feel" for it.

I'm struggling to set up a connection to my home WiFi, though. Networking over ethernet is no problem, but I specifically chose a ThinkPad T43 as my ArcaOS machine because I knew the WiFi chip would be supported. I can detect my home network and those of my neighbors, so something is definitely happening. I get the impression I need to create a profile before I can connect, but I've been playing around with no success for the last week or so.

My Google-fu seems to have failed me too, so once again I must request the assistance of our wonderful community.

If anyone could help me out, I'd be very grateful!

Have a good weekend out there,

Jack.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 189
  • Posts: 2603
    • View Profile
Re: Setting up a WiFi Connection
« Reply #1 on: February 14, 2020, 10:27:35 pm »
Yes, you need to create a profile, perhaps called Home. I'll assume your using the widget.
Right click on the Widget and choose add/edit profile then new.
Add your profile name and under connect to "Basic/Extended Service Set (BSS/ESS) and fill in your network name/SSID.
Under the Security Tab, fill in your pre-shared key and for encryption, WPA2-PSK. Under TCPIP tab, DHCP.
Then you should be able to right click on the widget, select your profile and turn on the radio. After a minute you should be connected.

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 59
  • Posts: 1362
    • View Profile
Re: Setting up a WiFi Connection
« Reply #2 on: February 15, 2020, 03:38:25 am »
Quote
Under the Security Tab, fill in your pre-shared key and for encryption, WPA2-PSK.

My T43 (not necessarily the same as yours) won't work with WPA2-PSK. I need to use WPA-PSK. I don't know if that is because of the driver (GENMAC 8086-4224), the device, the router, or something else. Fortunately, the router can be set to accept WAP2, or WPA, so it isn't  much of a problem.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 189
  • Posts: 2603
    • View Profile
Re: Setting up a WiFi Connection
« Reply #3 on: February 15, 2020, 04:12:29 am »
My T42 uses Genmac 8086-4220 and luckily works fine with WPA2-PSK as that is all my web hub supports, it's a piece of crap.