Author Topic: Google Photos - pics no longer showing?  (Read 543 times)

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 14
  • -Receive: 16
  • Posts: 709
    • View Profile
Google Photos - pics no longer showing?
« on: April 03, 2020, 06:20:50 am »
I was attempting to download some pics off of my mobile device and noticed that Google Photos (https://photos.google.com/) no longer actually shows the images. Instead of a photo I see a grey square/frame, but that's it.

Is anyone else seeing this?

I see no Google 'service outage' updates out there but having recently ran some RPM package updates I'm wondering if one of them messed things up. So before I go digging through them all I'd like to know if this is just my issue?

Thanks!

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 56
  • Posts: 507
    • View Profile
Re: Google Photos - pics no longer showing?
« Reply #1 on: April 03, 2020, 06:46:50 am »
I see the same thing here with Firefox 38 on ArcaOS. Works fine in latest Chrome/Firefox on Ubuntu...

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 14
  • Posts: 260
    • View Profile
Re: Google Photos - pics no longer showing?
« Reply #2 on: April 03, 2020, 02:10:55 pm »
Could it be webp ?  (I do not use google photo)
(new google and firefox too standard picture... and replaces jpg, png, gif etc...)   
Of course not supported by older browser nor under OS/2 ! 
https://www.fxsitecompat.dev/en-CA/docs/2018/webp-image-support-has-been-added/

libvebp libraies may be needed !
Or may be some online webp to jpg (gif...) could help !
Can you provide an example please ?

Regards
Rémy   
   
« Last Edit: April 03, 2020, 02:12:31 pm by Remy »

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 469
  • -Receive: 95
  • Posts: 2658
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Google Photos - pics no longer showing?
« Reply #3 on: April 03, 2020, 02:58:47 pm »
Hi
I tried Google Photos with Firefox 45.9 and it working very bad.
I can access the site, see the square shapes, but pictures does not display right.  I see the album cover, but once I access it I don't see the pictures. If I access one picture of the album I see it shortly and after that it change to the loading icon.

We need a new browser, let's keep supporting Bitwise.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Neil Waldhauer

  • Hero Member
  • *****
  • Thank You
  • -Given: 9
  • -Receive: 41
  • Posts: 546
    • View Profile
    • Blonde Guy
Re: Google Photos - pics no longer showing?
« Reply #4 on: April 03, 2020, 03:40:49 pm »
I'm sorry to read that Google Photos does not work. I rely on many Google services, although, I am also in the Apple ecosystem.

Apple Photos still works amazingly well. It's quite the same thing, but Microsoft One Drive is also very functional. I've been uploading 300 GB files to one drive all week using Firefox.

I'll send BitWise another small donation. I wish I could do more.
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 14
  • Posts: 260
    • View Profile
Re: Google Photos - pics no longer showing?
« Reply #5 on: April 03, 2020, 05:58:41 pm »
Hi
I tried Google Photos with Firefox 45.9 and it working very bad.
I can access the site, see the square shapes, but pictures does not display right.  I see the album cover, but once I access it I don't see the pictures. If I access one picture of the album I see it shortly and after that it change to the loading icon.

We need a new browser, let's keep supporting Bitwise.

Regards

Hum !
"I see shortly and after that it change to the loading icon"
It looks more like a network slowdown.... 
Can you try to recycle your dhcp (if dynamic) and retry !   

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 14
  • -Receive: 16
  • Posts: 709
    • View Profile
Re: Google Photos - pics no longer showing?
« Reply #6 on: April 03, 2020, 07:55:58 pm »
Remy and Martin,

Hi
I tried Google Photos with Firefox 45.9 and it working very bad.
I can access the site, see the square shapes, but pictures does not display right.  I see the album cover, but once I access it I don't see the pictures. If I access one picture of the album I see it shortly and after that it change to the loading icon...

Hum !
"I see shortly and after that it change to the loading icon"
It looks more like a network slowdown.... 
Can you try to recycle your dhcp (if dynamic) and retry !

I am seeing the same here, however, when looking at the individual image it does show shortly thereafter even though the loading icon continues to display...from there on I can advance to the next full-size image, so at least that's still working.

For what it's worth, I did a little bit of research re: the WebP image format. Indeed, this ia a Google tech push, it does appear to lower the amount of bandwidth it consumes, so I get why they are doing it. The arguments they made for equal quality to JPEG or PNG have been questioned and debunked by several key players in this domain. Perhaps part of the reason why it's taken nearly 10 yrs to actually get it to this point?