Author Topic: Updated Uniaud32 build  (Read 43444 times)

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 58
  • -Receive: 110
  • Posts: 810
  • Karma: +50/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #105 on: August 03, 2020, 05:41:30 am »
Guys,

For any traps, please state which version and build type the trap corresponds to. Ie 3.13.11 debug or 3.12.74 release.

Otherwise, the trap is very difficult to interpret.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 205
  • Posts: 2931
  • Karma: +31/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #106 on: August 03, 2020, 07:59:10 am »
Tested 3.8.13 on a Dell 790, perhaps 7 years old. Strange thing is my unaud.dll seems to have vanished, breaking the mixer. Once I restored it and turned up the PCM volume, seems to work fine. The headphone volume also works independently of the PCM volume unlike the ArcaOS version.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 558
  • -Receive: 114
  • Posts: 3078
  • Karma: +17/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Updated Uniaud32 build
« Reply #107 on: August 04, 2020, 01:19:18 am »
Hi Paul

Linux 3.12.74: http://smedley.id.au/tmp/uniaud32-linux-3.12.74.zip
FYI: I tried this version on real hardware (ThinkPad L420) and it traps on boot.

I will try to test your other releases.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 558
  • -Receive: 114
  • Posts: 3078
  • Karma: +17/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Updated Uniaud32 build
« Reply #108 on: August 04, 2020, 01:33:19 am »
Hi Paul

I also tried these drivers on the Thinkpad L420. I had only tested the "release" versions.

3.9.11 - http://smedley.id.au/tmp/uniaud32-linux-3.9.11.zip
Does not trap. Produces sounds. Volume control works, but it only sounds on the attached headset, not on the laptop speaker. Possible more unimix tweeaking is required from my side.

3.13.11 - http://smedley.id.au/tmp/uniaud32-linux-3.13.11.zip  <== includes hackaround with help from Steven Levine for the TRAP000E I was seeing

Traps.

3.14.79 - http://smedley.id.au/tmp/uniaud32-linux-3.14.79.zip <== doesn't trap, but fails to find an audio driver

Boot error:
Code: [Select]
ERROR: Query names failed.
open ret = -19
      OSS32_QueryNames() ret = -19
             Unable to attach 32-bit driver


Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 58
  • -Receive: 110
  • Posts: 810
  • Karma: +50/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #109 on: August 04, 2020, 01:34:55 am »
Hi Martin,

Linux 3.12.74: http://smedley.id.au/tmp/uniaud32-linux-3.12.74.zip
FYI: I tried this version on real hardware (ThinkPad L420) and it traps on boot.

Traps on my X250E as well - which I guess is a good thing :)

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 12
  • -Receive: 25
  • Posts: 332
  • Karma: +13/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #110 on: August 04, 2020, 02:21:47 am »
 Paul,

  Attached is the screen shot of the trap using the debug 3.13 drivers you requested....

Regards,

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 58
  • -Receive: 110
  • Posts: 810
  • Karma: +50/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #111 on: August 04, 2020, 11:46:21 am »
Hi All,

Can anyone experience a TRAP000E with 3.10 -> 3.13 please test with http://smedley.id.au/tmp/uniaud32-linux-3.10.108-20200804.zip

This has the hda drivers from 3.10.108 replaced with the code from 3.9.11. This fixes things on my X250. Assuming it works for others too, next steps will be to start trying to identify/fix the code change  between these two versions that broke things for us :)

Cheers,

Paul

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 12
  • -Receive: 25
  • Posts: 332
  • Karma: +13/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #112 on: August 04, 2020, 12:56:56 pm »
 Paul,

  When I download that link, I get a 0 byte file...

Regards,

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 58
  • -Receive: 110
  • Posts: 810
  • Karma: +50/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #113 on: August 04, 2020, 01:04:41 pm »
Paul,

  When I download that link, I get a 0 byte file...

Regards,

Sorry - try again now

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 12
  • -Receive: 25
  • Posts: 332
  • Karma: +13/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #114 on: August 05, 2020, 12:38:16 am »
 Hey Paul,

  This one behaves like the 3.9 version: it boots, but no sound, and unimix doesn't change anything (hardware manager shows it is loaded). I'll upload the alsahlp$ log running the debug drivers...

Regards,

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 58
  • -Receive: 110
  • Posts: 810
  • Karma: +50/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #115 on: August 05, 2020, 12:50:25 pm »
Quick update: I've narrowed down the cause of the trap to changes in hda_codec.c between the 3.9 code and the 3.10 code. Nothing in the diff immediately jumps out as a cause, but I'll try and work through it tomorrow night, and post an update here.

Dave: fwiw I get no sound with 3.9 either in the x250 with Realtek hardware, sound is fine with virtualised sigmatel hardware.

I prefer successful boot with no sound to a trap right now :)

Heikki Kekki

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #116 on: August 06, 2020, 10:42:52 am »
Hi David,

  It's working just fine here - system sounds, WPS MP3 objects and YouTube - all on ArcaOS 5.0.5 on bare metal 8086:A170. Thanks for continuing to progress with this! Any chance for multiple streams (so system sounds don't interrupt something else, they are just mixed in)?... or even surround...

Thanks for testing. In terms of multiple streams - I believe the SBLive driver supported this so it definitely should be possible to support.
Therefore, I use the SBLive driver, it works flawlessly. The downside of RAM is only 2 GB, exactly on this computer Memory Watcher shows 2180716 KB installed memory. If there is 16 GB more, the sound is distorted. Installed at 4 GB, the ramdisk uses almost half.

OS2LDR.CFG
Code: [Select]
RAMDISK = MIN=1836 HPFS Q:
HIDISK = RLOW=128 RHIGH=0
RAMDISKNAME = RAM disk

Browser cache, TMP, TEMP and swapper.dat are on ramdisk Q. Swapping (rarely happens) is pretty imperceptible.
This is Dell OptiPlex 960 and sound card is Creative Labs - SB Live! EMU10k1

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 18
  • -Receive: 13
  • Posts: 588
  • Karma: +1/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #117 on: August 06, 2020, 10:55:08 am »
Can anyone experience a TRAP000E with 3.10 -> 3.13 please test with http://smedley.id.au/tmp/uniaud32-linux-3.10.108-20200804.zip

This has the hda drivers from 3.10.108 replaced with the code from 3.9.11. This fixes things on my X250. Assuming it works for others too, next steps will be to start trying to identify/fix the code change  between these two versions that broke things for us :)
It doesn't give me any traps, it works perfect even at 64K and 16M panorama colors. The trap I sent earlier was Linux3.13.11 debug.
Saludos

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 58
  • -Receive: 110
  • Posts: 810
  • Karma: +50/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #118 on: August 06, 2020, 12:01:24 pm »
Hi Roberto,

Can anyone experience a TRAP000E with 3.10 -> 3.13 please test with http://smedley.id.au/tmp/uniaud32-linux-3.10.108-20200804.zip

This has the hda drivers from 3.10.108 replaced with the code from 3.9.11. This fixes things on my X250. Assuming it works for others too, next steps will be to start trying to identify/fix the code change  between these two versions that broke things for us :)
It doesn't give me any traps, it works perfect even at 64K and 16M panorama colors. The trap I sent earlier was Linux3.13.11 debug.
Saludos

Great to hear - what sound driver is detected?

Cheers,

Paul

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 18
  • -Receive: 13
  • Posts: 588
  • Karma: +1/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #119 on: August 06, 2020, 01:45:45 pm »
I attach the log , in debug.