Author Topic: Updated Uniaud32 build  (Read 23085 times)

Sigurd Fastenrath

  • Sr. Member
  • ****
  • Thank You
  • -Given: 16
  • -Receive: 76
  • Posts: 458
  • Karma: +5/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #240 on: October 22, 2020, 11:14:29 pm »
Hi Paul,

the hardware I am using is far to new for the driver, I guess. So I did not expect it to work.

Even though I attach my results, may be I can be of help in a future release.

The hardware is a lenovo Thinkpad T480 with Intel core i7-8550 CPU.

Your driver loads and boots but can not detect the mixer. I guess this is what you would expect with this hardware.

If I can be of any help, please let me know.

Thanks for your great work!!
« Last Edit: October 22, 2020, 11:19:05 pm by Sigurd Fastenrath »

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 27
  • -Receive: 94
  • Posts: 694
  • Karma: +25/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #241 on: October 22, 2020, 11:33:33 pm »
Hi Sigurd,

the hardware I am using is far to new for the driver, I guess. So I did not expect it to work.

Even though I attach my results, may be I can be of help in a future release.

The hardware is a lenovo Thinkpad T480 with Intel core i7-8550 CPU.

Your driver loads and boots but can not detect the mixer. I guess this is what you would expect with this hardware.

If I can be of any help, please let me know.

Thanks for your great work!!

From some googling, seems the T480 has the ALC285 chip. According to https://www.phoronix.com/scan.php?page=news_item&px=Realtek-ALC-215-285-289 support was added in the linux 4.13 kernel.

I'll try and fix Sigmatel support so I can test in Virtualbox, but otherwise, I'll probably push on to newer kernel versions over the weekend.

Cheers,

Paul.

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 27
  • -Receive: 94
  • Posts: 694
  • Karma: +25/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #242 on: October 23, 2020, 10:52:55 am »
I'll try and fix Sigmatel support so I can test in Virtualbox, but otherwise, I'll probably push on to newer kernel versions over the weekend.

I didn't look at Sigmatel, but pushed on. 4.4.238 patches applied pretty cleanly to 4.9.240 - we'll see how hard it is to make it compile/link...

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 14
  • -Receive: 20
  • Posts: 822
  • Karma: +4/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #243 on: October 24, 2020, 01:19:52 am »
Hi Paul,

...http://smedley.id.au/tmp/uniaud32-linux-4.4.238-20201022.zip

Trap should be fixed - but here at least - no mixer is detected. I still need to investigate this - but curious if it's a Sigmatel issue, or a broader issue.
...

Here unimix reports:

Code: [Select]
Command line mixer for UNIAUD32. Version 1.1
Detected UNIAUD version 2.02.05
Detected 1 audio adapter(s)
Error: invalid number of PCM instances for adapter 0
Card info for adapter 0:
  num: 0
  id: SB
  driver: HDA-Intel
  name: HDA ATI SB
  longname: HDA ATI SB at 0xfe8f4000 irq 16
  mixer:
  componenets: HDA:10ec0889,14627576,00100004

...but no sound is produced.

Invoking UniMix produces a pop-up error message with the following text:

Code: [Select]
uniaud_mixer_get_ctls_number: error $00000000. Close the program?

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 27
  • -Receive: 94
  • Posts: 694
  • Karma: +25/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #244 on: October 24, 2020, 05:10:17 am »
4.9.240: http://smedley.id.au/tmp/uniaud32-linux-4.9.240-20201024.zip

Here on Sigmatel hardware (virtualbox), and on a Thinkpad X250 (Realtek HW), I get no sound and output similar to:
Command line mixer for UNIAUD32. Version 1.1
Detected UNIAUD version 2.02.05
Detected 1 audio adapter(s)
Error: invalid number of PCM instances for adapter 0
Card info for adapter 0:
  num: 0
  id: Intel
  driver: HDA-Intel
  name: HDA Intel
  longname: HDA Intel at 0xf0804000 irq 11
  mixer:
  componenets: HDA:83847680,83847680,00103401

YMMV... It's  interesting that Dave get's his mixer identified... I might need more logging...

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 195
  • Posts: 2723
  • Karma: +16/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #245 on: October 24, 2020, 07:13:37 am »
Tried this one, no sound and PMUniMix gives a ctls error number of $0000000. I posted my Intel HDA info earlier in the thread.
Thanks for the work.

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 27
  • -Receive: 94
  • Posts: 694
  • Karma: +25/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #246 on: October 24, 2020, 07:42:30 am »
Tried this one, no sound and PMUniMix gives a ctls error number of $0000000. I posted my Intel HDA info earlier in the thread.
Thanks for the work.
Thanks Dave - this will be the mixer not being detected.... weird how it works for Dave Mckenna... the positive is that 4.9.x behaves the same as 4.4.x for me at least, so the fix will likely be similar. Patches also applied pretty cleanly to 4.14.x, so will try get that compiling then work on fixes...
« Last Edit: October 24, 2020, 11:16:49 am by Paul Smedley »

Ian Manners

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 44
  • -Receive: 28
  • Posts: 356
  • Karma: +1/-0
  • I am the computer, it is me.
    • View Profile
    • ComKal Networks Australia
Re: Updated Uniaud32 build
« Reply #247 on: October 24, 2020, 10:03:55 am »
Hi Paul,

No problems here but thought I would still let you know that all of your latest builds still work well with:

Card info for adapter 0:
  num: 0
  id: Live
  driver: EMU10K1
  name: SB Live! 5.1
  longname: SB Live! 5.1 (rev.7, serial:0x80641102) at 0xd880, irq 22
  mixer: eMicro EM28028
  componenets: AC97a:454d4328

including uniaud32-linux-4.9.240-20201024.zip

Thanks :)
Cheers
Ian B Manners

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 27
  • -Receive: 94
  • Posts: 694
  • Karma: +25/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #248 on: October 24, 2020, 10:21:45 am »
Hi All,

Tried this one, no sound and PMUniMix gives a ctls error number of $0000000. I posted my Intel HDA info earlier in the thread.
Thanks for the work.
Thanks Dave - this will be the mixer not being detected.... weird how it works for Dave... the positive is that 4.9.x behaves the same as 4.4.x for me at least, so the fix will likely be similar. Patches also applied pretty cleanly to 4.14.x, so will try get that compiling then work on fixes...

http://smedley.id.au/tmp/uniaud32-linux-4.14.202-20201024.zip is based on the linux 4.14.x kernel - again - no hda mixer detection here in Virtualbox.

Cheers,

Paul

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 27
  • -Receive: 94
  • Posts: 694
  • Karma: +25/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #249 on: October 24, 2020, 10:22:26 am »
Hi Ian,

No problems here but thought I would still let you know that all of your latest builds still work well with:

Card info for adapter 0:
  num: 0
  id: Live
  driver: EMU10K1
  name: SB Live! 5.1
  longname: SB Live! 5.1 (rev.7, serial:0x80641102) at 0xd880, irq 22
  mixer: eMicro EM28028
  componenets: AC97a:454d4328

including uniaud32-linux-4.9.240-20201024.zip

Thanks :)

Thanks for confirming things work on non-HDA hardware :)

Cheers,

Paul

Sigurd Fastenrath

  • Sr. Member
  • ****
  • Thank You
  • -Given: 16
  • -Receive: 76
  • Posts: 458
  • Karma: +5/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #250 on: October 24, 2020, 02:37:34 pm »
Hi All,

http://smedley.id.au/tmp/uniaud32-linux-4.14.202-20201024.zip is based on the linux 4.14.x kernel - again - no hda mixer detection here in Virtualbox.

Cheers,

Paul

Hi Paul,

tested this 4.14.202, seems to show the same results as with the older one.

Boots OK, does not detect the mixer.

Great to see 4.14 boot at all!

What can I provide to assist?

Thanks!

Eugene Tucker

  • Full Member
  • ***
  • Thank You
  • -Given: 45
  • -Receive: 6
  • Posts: 121
  • Karma: +1/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #251 on: October 25, 2020, 05:37:42 pm »
New version no trap, no sound and no PMmixer connect.

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 27
  • -Receive: 94
  • Posts: 694
  • Karma: +25/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #252 on: October 25, 2020, 09:11:21 pm »
New version no trap, no sound and no PMmixer connect.

Thanks guys - I need to think about how best to proceed. At this stage, I think it's best to resurrect the logging that was broken around kernel 4.0 timeframe - I'm hoping that will elicit some clues as to why the mixer isn't being detected.

I'll post here when I have some news.

Sigurd Fastenrath

  • Sr. Member
  • ****
  • Thank You
  • -Given: 16
  • -Receive: 76
  • Posts: 458
  • Karma: +5/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #253 on: October 25, 2020, 09:30:21 pm »

Thanks guys - I need to think about how best to proceed. At this stage, I think it's best to resurrect the logging that was broken around kernel 4.0 timeframe - I'm hoping that will elicit some clues as to why the mixer isn't being detected.

I'll post here when I have some news.

Hi Paul,

may be you can team up with "abwillis1", he helped me out with getting Uniaud to run on a Thinkpad X250.

Please see: https://mantis.arcanoae.com/view.php?id=2637

(ArcaOS Bugtracker Bug 2637)

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 27
  • -Receive: 94
  • Posts: 694
  • Karma: +25/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #254 on: October 25, 2020, 10:08:26 pm »
OK, so I fixed some logging code....

Firstly, there was a pretty major code re-structuring in relation to the sound code between 4.0 and 4.1. Some of the added api calls I simply stubbed as I didn't think they were important, some I implemented.

What I believe is happening is that whilst the HDA chipset is being recognised, I don't think the code to support the mixers is being loaded at all. I see no logging from (for example) patch_sigmatel.c

What I need to do is step through the code and determine where the hda_intel/hda_codec code is supposed to call the code for the mixer, then work out why it isn't being loaded. I suspect this will come back to some code I stubbed that needs to be at least partially implemented - I just don't want to waste time implementing the wrong code...

No timeframes on updates, I have a busy week coming up...