Author Topic: Java for os2  (Read 65434 times)

miturbide

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1154
    • View Profile
    • OS2World
Re: Java for os2
« Reply #180 on: 2012.03.06, 05:38:03 »
Any luck with Nevernote (Nixnote) ?

"This is an open source clone of Evernote.  This program has been run on Linux, Windows, and OS-X, but the primary goal is to proved a Linux client.  While this is designed to work with Evernote, it is in no way connected with or supported by Evernote."

http://nevernote.sourceforge.net/index.htm
Martín Itúrbide
OS2World.com NewsMaster
Open Source Advocate

Skype - martiniturbide
Google Talk - martiniturbide@gmail.com

Pete

  • Hero Member
  • *****
  • Posts: 865
    • View Profile
Re: Java for os2
« Reply #181 on: 2012.03.08, 03:19:17 »
Hi Martin

Which package did you download?

I picked on nixnote-1.2_i386.tar.gz from the "Current" download option and it looks like the usual *nix mess; not sure if I can figure out how to get a working app from this package...

I suspect that it will need a cmd file version of nixnote.sh as trying to run the nixnote.jar results in a Java Virtual Machine Launcher error:-

Failed to load Main-Class manifest attribute from J:\Java\nixnote\usr\share\nixnote\nixnote.jar


Regards

Pete




ivan

  • Hero Member
  • *****
  • Posts: 593
    • View Profile
Re: Java for os2
« Reply #182 on: 2012.03.08, 13:04:11 »
Hi Pete

I tried it with just the jar file (at the top of the file list) and get the same error that you do so it could be a problem with the package.

ivan

miturbide

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1154
    • View Profile
    • OS2World
Re: Java for os2
« Reply #183 on: 2012.03.08, 14:44:12 »
Yes, I'm using the same one "nixnote-1.2_i386.tar.gz" with the same error, no manifest file.

I'm trying to look around. Possible it is not platform independent.
Martín Itúrbide
OS2World.com NewsMaster
Open Source Advocate

Skype - martiniturbide
Google Talk - martiniturbide@gmail.com

miturbide

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1154
    • View Profile
    • OS2World
Re: Java for os2
« Reply #184 on: 2012.03.09, 22:30:24 »
Hi

I also had been trying Rachota 2.4 (2011-01-07), it seems to work fine.

"Rachota is a portable application for timetracking different projects. It runs on Windows, Linux, Solaris and Mac. It displays time data in diagram form, creates customized reports or invoices and provides suggestions to increase your effeciency."

URL: sourceforge.net/projects/rachota/
Martín Itúrbide
OS2World.com NewsMaster
Open Source Advocate

Skype - martiniturbide
Google Talk - martiniturbide@gmail.com

miturbide

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1154
    • View Profile
    • OS2World
Re: Java for os2
« Reply #185 on: 2012.05.22, 23:46:08 »
I remember I run SmartSVN and SmartVS for testing, but I'm having problems running SmartGit.

I'm trying[

  java -Xmx512m -Dsun.awt.noerasebackground=true -Dsmartgit.checkIncompatibleJava=false -jar ..\LIB\smartgit.jar

But I get the famous "Failed to load Main-Class manifest attribute from ..\LIB\smartgit.jar"

Any tip to make SmartGit run? Thanks.
Martín Itúrbide
OS2World.com NewsMaster
Open Source Advocate

Skype - martiniturbide
Google Talk - martiniturbide@gmail.com

Andi

  • Sr. Member
  • ****
  • Posts: 264
    • View Profile
Re: Java for os2
« Reply #186 on: 2012.05.23, 20:43:15 »
I run SmartGit2.1.6 with the following script -
Code: [Select]
@echo off
rem OS/2 script for SmartGIT, requires JAVA 1.6 installed

rem #########################################################################
rem call external script which set up java6 enviroment
rem #########################################################################
call envjava6.cmd

set JAVA_EXE=java
SET JAVA_OPT="-Dsmartgit.checkIncompatibleJava=false"
set SMARTGIT_HOME=.
set SMARTGIT_LIB=%SMARTGIT_HOME%\lib
set SMARTGIT_MAIN_JAR=%SMARTGIT_LIB%\smartGIT.jar

%JAVA_EXE% %JAVA_OPT% -mx256m -jar %SMARTGIT_MAIN_JAR% %1

My envjava6.cmd is like -
Code: [Select]
set JAVA_HOME=P:\Java6
set path=%JAVA_HOME%\bin;%PATH%

set libpathstrict=T
set BEGINLIBPATH=%JAVA_HOME%\bin;

miturbide

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1154
    • View Profile
    • OS2World
Re: Java for os2
« Reply #187 on: 2012.05.23, 22:45:13 »
Thanks Andi.

I'm trying smartgit-generic-3_0_4.tar.gz, with your script it shows the same

"Failed to load Main-Class manifest attribute from
.\lib\smartGIT.jar"

...uhm.. maybe the 3.0.4 is not working.
Martín Itúrbide
OS2World.com NewsMaster
Open Source Advocate

Skype - martiniturbide
Google Talk - martiniturbide@gmail.com

miturbide

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1154
    • View Profile
    • OS2World
Re: Java for os2
« Reply #188 on: 2012.05.23, 22:51:15 »

I tried SmartGit 2.1.8 and it worked.
(http://www.syntevo.com/smartgit/download-archive.html)

My guess is that SmartGit 3 does not run cause it is using SWT, which is not ported to OS/2-eCS, but that's only a guess checking v3 changelog.
Martín Itúrbide
OS2World.com NewsMaster
Open Source Advocate

Skype - martiniturbide
Google Talk - martiniturbide@gmail.com

miturbide

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1154
    • View Profile
    • OS2World
Re: Java for os2
« Reply #189 on: 2012.06.27, 00:03:21 »
I'm not able to run MegaMek with OpenJDK 1.6.
http://megamek.info/downloads

I'm getting this error:

Quote
[D:\JAVATEST\MEGAMEK-V0.34.10]java -jar megamek.jar
Redirecting output to megameklog.txt
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x1cb9012a, pid=107, tid=701236
6
#
# JRE version: 6.0-b24
# Java VM: OpenJDK Client VM (20.0-b12 mixed mode os2-x86 )
# Problematic frame:
# V  [JVM+0xc012a]
#
# An error report file with more information is saved as:
# D:\JAVATEST\MEGAMEK-V0.34.10\hs_err_pid107.log
SYS1808:
The process has stopped.  The software diagnostic
code (exception code) is  0000.


The log says:
Quote
Starting MegaMek v0.34.10 ...
Compiled on Wed Jan 25 18:23:28 EST 2012
Today is Tue Jun 26 16:59:11 EDT 2012
Java vendor Sun Microsystems Inc.
Java version 1.6.0-ga2
Platform OS/2 20.45 (x86)
Total memory available to MegaMek: 253,440 kB

Starting GUI AWT. args: []
Martín Itúrbide
OS2World.com NewsMaster
Open Source Advocate

Skype - martiniturbide
Google Talk - martiniturbide@gmail.com

Joop

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
    • My homepage about OS/2-eCS - Wacom Bamboo driver and some other solutions.
Re: Java for os2
« Reply #190 on: 2012.06.27, 22:55:41 »
I'm not able to run MegaMek with OpenJDK 1.6.
http://megamek.info/downloads

I'm getting this error:

Download the game, unzipped it in a new directory, used one of my cmd files, changed it a little so it understands the directory and filename. Did start it, did run into errors because hadn't setup properly. This is with most programs a first time problem. Tried it again and the game just start. Didn't read anything, but its a huge game, it is a net game, so you need to play it with others over the net. Can be risky.

I used this commandfile;

@echo off
set BEGINLIBPATH=[drive:]\JAVA\JAVA160\bin
set path=[drive:]:\JAVA\JAVA160\bin
set CLASSPATH=
[drive:]
cd [drive:]\Spelletjes\MegaMek
java.exe -Duser.home=[drive:]\Spelletjes\MegaMek -jar megamek.jar 2>megamek-bugs.txt

Change [drive:] into a proper drive letter.

Have fun
Joop

miturbide

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1154
    • View Profile
    • OS2World
Re: Java for os2
« Reply #191 on: 2012.07.01, 19:19:07 »
Nop.... I can not make megamek run.. I got the same error.

I had been trying also Vassal engine, which is a Java board engine.
http://www.vassalengine.org/

It had several modules.
http://www.vassalengine.org/wiki/Category:Modules

Some of them seems to run fine. I'm still trying it out.
Martín Itúrbide
OS2World.com NewsMaster
Open Source Advocate

Skype - martiniturbide
Google Talk - martiniturbide@gmail.com

jep

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 421
    • View Profile
Re: Java for os2
« Reply #192 on: 2012.07.02, 08:18:31 »
Nop.... I can not make megamek run.. I got the same error.

Me neither, it just barf at me with the same problem as described by martini.

______
(Firefox 10.0.5 and JDownloader doesn't seem to get along either on that computer, AMD Quad Core, as it cause a reboot after a sys3170 in popup.log). The same setup work (FF 10.0.5 and JDownloader) fine on a single core machine.  (MegaMek not tested there though)

//Jan-Erik

Joop

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
    • My homepage about OS/2-eCS - Wacom Bamboo driver and some other solutions.
Re: Java for os2
« Reply #193 on: 2012.07.05, 03:06:14 »
# JRE version: 6.0-b24
# Java VM: OpenJDK Client VM (20.0-b12 mixed mode os2-x86 )


I use 6.0-b22 version, single core.
I have removed the game from system due to the problem that you can find "confidential" information in the file "MegaMek\logs\megameklog.txt".

Andi

  • Sr. Member
  • ****
  • Posts: 264
    • View Profile
Re: Java for os2
« Reply #194 on: 2012.07.06, 19:17:23 »
Anyone tried/success with regain? http://regain.sourceforge.net/download.php

ok, got it started, seems to prepare index now. Let's see if it's usable then....
« Last Edit: 2012.07.06, 19:28:11 by Andi »