MSI B450M PRO-VDH MAX

From OS2World.Com Wiki
Jump to navigation Jump to search

General Specs

  • Release Date: September 2019
  • Socket: AM4
  • Chipset: AMD® B450 Chipset
  • Form Factor: m-ATX

Extras

  • Storage: 1Tb NVMe SSD
  • Memory: Crucial 16MB RAM [1]
  • Processor: AMD Ryzen 5 5600G 6 core CPU [2]
  • CDROM: Optiarc DVD RW AD-5280S optical drive [3]

Devices

Component Name HardwareID Status Driver
Processor AMD Ryzen 5 5600G 6 core cpu -- ACPI
HDD - SATA AMD 400 Series Chipset SATA Controller 1022:43C8 OS2AHCI, DANIS506
HDD - SATA AMD FCH SATA Controller [AHCI mode] 1022:7901 OS2AHCI, DANIS506
HDD - NVMe Micron/Crucial Technology P2 NVMe PCIe SSD C0A9:540A NVME.ADD
Audio AMD Family 17h/19h HD Audio Controller 1022:15E3 UNIAUD
Network Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 10EC:8168 Multimac MMRE.OS2
Video AMD Cezanne [Radeon Vega Series / Radeon Vega Mobile Series] 1002:1638 Panorama
USB (xHCI) AMD 400 Series Chipset USB 3.1 xHCI Compliant Host Controller 1022:43D5 AN USB Drivers.

General Comments

Report by Pete
He reported that he installed ArcaOS 5.1 on a dual boot configuration with Windows 11. CSM needs to be enabled to boot from CD/DVD on this system.
Installed 5.1.0 in UEFI Boot mode to GPT disk layout
Note About Hyper Threading
The AMD's version of Hyper Threading is called Simultaneous Multithreading (SMT) which can be Disabled in:
BIOS -> Settings -> Advanced -> AMD Overclocking -> Manual CPU Overclocking -> CPU Core Count Control -> SMT Control [Auto] or [Disable]
Pete have been using this mainboard with SMT set to Auto, resulting in ArcaOS reporting "Processors Intialized: 12" for his 6 core Ryzen 5 5600G CPU during boot for over 3 months and the system has been very stable. He did "Disable SMT" in the BIOS but did not see a lot of difference in system speed in general although Seamonkey and OpenOffice apps seemed to start just a little quicker when SMT is set to Auto so he reset SMT to Auto.
The NVMe drive makes for a very fast boot and applications start more quickly.
Onboard AMD/ATI graphics working fine with Panorama driver.
Onboard Realtek RTL8111/8168/8411 NIC working with MMRE.OS2.
The above worked with the drivers included in 5.1.0.
Onboard sound: Choice of 2 devices.
I could not get any sound from speakers when booting with
       DEVICE=H:\MMOS2\UNIAUD32.SYS /V
or
       DEVICE=H:\MMOS2\UNIAUD32.SYS /V /A:0
/A:0 selected the AMD mixer device.
Changing that to
       DEVICE=H:\MMOS2\UNIAUD32.SYS /V /A:1
/A:1 selected the Realtek ALC892 mixer device.
Sound works using the Release build in this package [4]

Hardware Report

Links