Author Topic: Updated Uniaud32 build  (Read 33015 times)

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 541
  • -Receive: 109
  • Posts: 2967
  • Karma: +10/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Updated Uniaud32 build
« Reply #285 on: November 20, 2020, 09:11:48 pm »
Hi Paul.

It may be trivial, but I hope it can be possible to do this on the UNIAUD driver:
- http://trac.netlabs.org/uniaud/ticket/246

I know it is a controversial issue, since people think different on how to show the /V (verbose) information on boot, but I have the dream that maybe someday all drivers may look similar when you boot your OS/2 box.

Regards
« Last Edit: November 20, 2020, 09:23:16 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 51
  • -Receive: 107
  • Posts: 780
  • Karma: +45/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #286 on: November 20, 2020, 09:47:38 pm »
Hi Roberto,

Another TRAP with this card:

Thanks - we think we know what's causing this - just need to work out why it's happening. The positive is that once it's fixed, it's likely to fix the sound as well.

It may be trivial, but I hope it can be possible to do this on the UNIAUD driver:
- http://trac.netlabs.org/uniaud/ticket/246

I know it is a controversial issue, since people think different on how to show the /V (verbose) information on boot, but I have the dream that maybe someday all drivers may look similar when you boot your OS/2 box.

It might happen - but it currently has zero priority until we're at as higher code level as we can get....

Cheers,

Paul

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 51
  • -Receive: 107
  • Posts: 780
  • Karma: +45/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #287 on: November 21, 2020, 09:52:20 am »
OK, http://smedley.id.au/tmp/uniaud32-linux-4.14.202-20201121.zip doesn't trap (or produce sound) on my X250, T60 or virtualbox systems.

Interested to get feedback from other systems. Pretty sure the lack of audio are due to broken regmap/regcache

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 11
  • -Receive: 22
  • Posts: 313
  • Karma: +10/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #288 on: November 21, 2020, 02:58:55 pm »
 Hi Paul,

  Sorry to report that I get a TrapE with this one too... I'll attach the serial port log, and I have a trapdump if you want it...

Regards,

Eugene Tucker

  • Full Member
  • ***
  • Thank You
  • -Given: 48
  • -Receive: 9
  • Posts: 134
  • Karma: +4/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #289 on: November 21, 2020, 04:49:20 pm »
No trap E.But no sound. Just like you said.

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 17
  • -Receive: 13
  • Posts: 579
  • Karma: +1/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #290 on: November 22, 2020, 10:12:24 am »
The TRAP persist
Saludos

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 51
  • -Receive: 107
  • Posts: 780
  • Karma: +45/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #291 on: November 22, 2020, 11:08:09 am »
The TRAP persist
Saludos

Very interesting - anyway - it's confirmed that regmap/regcache are still a problem. I'll keep digging as time permits.

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 14
  • -Receive: 22
  • Posts: 877
  • Karma: +8/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #292 on: November 23, 2020, 03:20:54 am »
Hi Paul,

OK, http://smedley.id.au/tmp/uniaud32-linux-4.14.202-20201121.zip doesn't trap (or produce sound) on my X250, T60 or virtualbox systems...

Small change in hardware here, I went from my MSI 880G-E45 motherboard to a MSI 890FXA-HD70. The advertised specs showed a RealTek chipset:

1) 880G-E45 => RealtekĀ® ALC888S/ACL889

2) 890FXA-GD70 => RealtekĀ® ALC889
Code: [Select]
Command line mixer for UNIAUD32. Version 1.1
Detected UNIAUD version 2.02.05
Detected 1 audio adapter(s)
Error: invalid number of PCM instances for adapter 0
Card info for adapter 0:
  num: 0
  id: SB
  driver: HDA-Intel
  name: HDA ATI SB
  longname: HDA ATI SB at 0xfe4f8000 irq 16
  mixer: Realtek ALC889
  componenets: HDA:10ec0889,14627640,00100004

...but your last known good release which was working on the 880G-E45:

Code: [Select]
8-12-20  5:07a       586,198     54 a---  uniaud32.sys

Build Level Display Facility Version 6.12.675 Sep 25 2001
(C) Copyright IBM Corporation 1993-2001
Signature:       @#Netlabs:2.02.05#@##1## 12 Aug 2020 18:37:33     ARCAOS-D0C:3.
16.85:::05::SVN@@Universal Audio Driver for OS/2 (c)  Netlabs
Vendor:          Netlabs
Revision:        2.02.05
Date/Time:       12 Aug 2020 18:37:33
Build Machine:   ARCAOS-D0C
ASD Feature ID:  3.16.85
FixPak Version:  SVN
File Version:    2.2.5
Description:     Universal Audio Driver for OS/2 (c)  Netlabs

...was now trapping on the newer 890FXA-GD70 board.

Anyways, the good news is that this latest drop does NOT trap, but as others have noted, it does not produce output either.

For me it's a positive direction given no TRAP! Thank you!

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 51
  • -Receive: 107
  • Posts: 780
  • Karma: +45/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #293 on: November 30, 2020, 09:05:16 am »
Hi All,

Just a quick update to say that there's no real progress - broadly it's understood why the builds don't produce sound, and where the problem lies (the port of the regmap/regcache APIs), but there isn't a clear root cause/solution to this yet. I'm actually taking a break from looking at Uniaud for a short time - with any luck a fresh look after a break may help shed some light on the problem.

Cheers,

Paul

Mentore

  • Jr. Member
  • **
  • Thank You
  • -Given: 15
  • -Receive: 2
  • Posts: 68
  • Karma: +0/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #294 on: December 07, 2020, 08:10:42 am »
Hi All,

Just a quick update to say that there's no real progress - broadly it's understood why the builds don't produce sound, and where the problem lies (the port of the regmap/regcache APIs), but there isn't a clear root cause/solution to this yet. I'm actually taking a break from looking at Uniaud for a short time - with any luck a fresh look after a break may help shed some light on the problem.

Cheers,

Paul

Best of luck Pete. I'm following this and hope to try the new builds soon (have to build one or two machines almost from scratch with some old hardware).

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 51
  • -Receive: 107
  • Posts: 780
  • Karma: +45/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #295 on: December 07, 2020, 08:47:28 am »
Hi Mentore,

Just a quick update to say that there's no real progress - broadly it's understood why the builds don't produce sound, and where the problem lies (the port of the regmap/regcache APIs), but there isn't a clear root cause/solution to this yet. I'm actually taking a break from looking at Uniaud for a short time - with any luck a fresh look after a break may help shed some light on the problem.

Best of luck Pete. I'm following this and hope to try the new builds soon (have to build one or two machines almost from scratch with some old hardware).

Hopefully there will be good news sometime soon. It's extremely frustrating being so close to it working  and it not quite working!

Cheers,

Paul

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 51
  • -Receive: 107
  • Posts: 780
  • Karma: +45/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #296 on: December 23, 2020, 02:59:33 am »
Quick update:

I built a driver based on the latest 4.19.x kernel - unfortunately I'm getting a TRAP 000E during boot that I need to debug.

I updated the code to 5.4.x - the code is compiling but I have around 10 missing symbols of functions that need to be added to the linux 'kernel'.

Hopefully I can resolve those over the next couple of days and see where we land. I keep hoping that in bumping the code levels things will start working :)

I'll have increased free time over the next couple of weeks over the Christmas/New Year break so will hopefully make some progress.

Cheers,

Paul

Sigurd Fastenrath

  • Sr. Member
  • ****
  • Thank You
  • -Given: 16
  • -Receive: 80
  • Posts: 467
  • Karma: +10/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #297 on: December 23, 2020, 09:12:52 am »
Quick update:

I built a driver based on the latest 4.19.x kernel - unfortunately I'm getting a TRAP 000E during boot that I need to debug.

I updated the code to 5.4.x - the code is compiling but I have around 10 missing symbols of functions that need to be added to the linux 'kernel'.

Hopefully I can resolve those over the next couple of days and see where we land. I keep hoping that in bumping the code levels things will start working :)

I'll have increased free time over the next couple of weeks over the Christmas/New Year break so will hopefully make some progress.

Cheers,

Paul

Hi Paul,

good news!! I will try to get the T480 to run with OS/2 - ArcaOS  over the Christmas/New Year break as well, so I hopefully will be able to test and support. It depends on only one LCD cable that I expect to be delivered since the beginning of December from China. So it may happen, if not, I will come back with that hardware as soon as possible.

All the best!

Sigurd

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 51
  • -Receive: 107
  • Posts: 780
  • Karma: +45/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #298 on: December 26, 2020, 09:38:58 pm »
OK.... it took a while - but I finally produced sound with HDA hardware (albeit virtualised) with 4.14.202...

Testing appreciated: https://smedley.id.au/tmp/uniaud32-linux-4.14.202-20201227.zip

Not sure I fully understand why the change I made to OSS32_WaveClose() fixed things, but I'll worry about that later!!
« Last Edit: December 26, 2020, 09:41:13 pm by Paul Smedley »

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 11
  • -Receive: 22
  • Posts: 313
  • Karma: +10/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #299 on: December 26, 2020, 09:49:37 pm »
 Just happened to be browsing OS2World when your post appeared, so installed the release 4.14.202 version and it works! Congratulations! I'll keep running with it and let you know if any issues arise, but so far system sounds, PMUniMix and MP3's work.... thanks again!