Author Topic: Blev helt tokigt med UTF-8 och Latin1  (Read 7149 times)

kimhav

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
    • View Profile
    • My Blog!
Blev helt tokigt med UTF-8 och Latin1
« on: 2007.05.13, 19:57:52 »
Kan inte mer än be om ursäkt att det blev helt snurr med de postningar som innehöll svenska tecken och som Joomla i sin tur drog igenom till index sidan. Svenska tecken blev fel på grund av att SMF körde UTF-8 och Joomla har inte stöd för detta.

Så på grund av ovan blev jag tvungen att rensa ut gamla UTF-8 postningar.

[Just a little note for the non-Swedish users; this thread is about issues regarding UTF-8 viewing and if you have still issues with strange characters, please contact either me or Tommy]
« Last Edit: 2007.05.17, 09:50:41 by Björn Söderström »

bjorso

  • Global Moderator
  • Newbie
  • *****
  • Posts: 37
    • View Profile
Re: Blev helt tokigt med UTF-8 och Latin1
« Reply #1 on: 2007.05.13, 20:04:25 »
Hej,

Uppenbarligen är detta inte helt enkelt? :( Det är synd att alla inte kan enas runt UTF-8, då kunde man lägga dylika onödiga problem åt sidan.

//Björn
« Last Edit: 2007.05.17, 09:49:06 by Björn Söderström »

bjorso

  • Global Moderator
  • Newbie
  • *****
  • Posts: 37
    • View Profile
Re: Blev helt tokigt med UTF-8 och Latin1
« Reply #2 on: 2007.05.13, 20:07:52 »
Det är fortfarande problem med namn i profilerna. Ser rätt ut när man hanterar profilen och på hemsidan men i forumets presentation av namnet blir höga ascii fel? :(

//Björn
« Last Edit: 2007.05.17, 09:48:32 by Björn Söderström »

kimhav

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
    • View Profile
    • My Blog!
Re: Blev helt tokigt med UTF-8 och Latin1
« Reply #3 on: 2007.05.13, 21:05:54 »
Det kan vara så att någon enstaka plugin hämtar eventuellt information någonstans som har lagrats med UTF-8 men skall ordna detta Björn.
« Last Edit: 2007.05.17, 09:49:37 by Björn Söderström »

tjansson

  • Global Moderator
  • Full Member
  • *****
  • Posts: 100
    • View Profile
Re: Blev helt tokigt med UTF-8 och Latin1
« Reply #4 on: 2007.05.13, 21:22:55 »
Ska kolla sedan om jag kan se till så att firefox får rätt kodning som default. Man kan ändra det manuellt men då får man ändra det varje gång man tittar på sidan ska se vad jag kan göra åt detta. För det har med profilen har inte så mycket med databasens teckenupsättning utan bara hur webläsaren ska tolka det som sysns på skärmen

// tommy
« Last Edit: 2007.05.17, 01:17:38 by Tommy Jansson »

kimhav

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
    • View Profile
    • My Blog!
Re: Blev helt tokigt med UTF-8 och Latin1
« Reply #5 on: 2007.05.14, 09:24:52 »
Inte att glömma att jag installerade SMF forum med UTF-8 stöd och Joomla har inte stöd för UTF-8 - och en del av de Community Builder plugins som används just för användarprofilen har hämtat data från SMF datafält. Jag har varit inne och rensat ut och ändrat i ett flertal användardatafält.

Har fått även lite epost från tyska användare som har noterat problem med sina tyska tecken; men frågan om deras problem finns kvar efter att jag plockade bort UTF-8 parametern i SMF forum konfig fil.
« Last Edit: 2007.05.17, 09:52:18 by Björn Söderström »

bjorso

  • Global Moderator
  • Newbie
  • *****
  • Posts: 37
    • View Profile
Re: Blev helt tokigt med UTF-8 och Latin1
« Reply #6 on: 2007.05.14, 13:22:42 »
Det är synd att inte alla moderna program och verktyg är byggda runt UTF-8, då skulle vi skandinaver och tyskar slippa problem med våra namn och ord som innehåller höga ascii-tecken. Kommer ihåg att för flera år sedan var det samma elände med e-post mellan olika datorsystem, nu märker man aldrig sånt tack och lov. 8)

Datorindustrin har aldrig varit bra på standarder. >:(

//Björn
« Last Edit: 2007.05.17, 09:47:43 by Björn Söderström »

kimhav

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
    • View Profile
    • My Blog!
Re: Blev helt tokigt med UTF-8 och Latin1
« Reply #7 on: 2007.05.14, 16:28:39 »
Sant, vet faktiskt inte varför flertal stora skript inte har implementerat stöd för det; men har troligen med att göra att är hela databasen väl uppsatt med t ex latin1 så måste den göras om till utf-8.
« Last Edit: 2007.05.17, 09:53:08 by Björn Söderström »

bjorso

  • Global Moderator
  • Newbie
  • *****
  • Posts: 37
    • View Profile
Re: Blev helt tokigt med UTF-8 och Latin1
« Reply #8 on: 2007.05.17, 11:43:17 »

Nu verkar det äntligen ha fallit på plats med höga ascii!  ;D

Jag redigerade de befintliga inläggen med svenska tecken för att få ordning på läsningen. Det här trasslet tycker jag visar på ett tydligt sätt hur dåligt olika program och tillverkare fungerar tillsammans, det är långt kvar tills datorer är bekymmersfria hjälpmedel enligt min erfarenhet.

//Björn

kimhav

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
    • View Profile
    • My Blog!
Re: Blev helt tokigt med UTF-8 och Latin1
« Reply #9 on: 2007.05.17, 12:07:10 »
Jo men den primära orsaken var just att jag gick från utf-8 till 8859-1 men att man i SMF forum inte kunde slå av det innne i själva admin panel. Att det sedan visade sig att de hårdkodat utf-8 inställningen dels i en settings.php fil samt även i databasen gör det ju inte mycket enklare och tyvärr var dokumentationen inte helt klart kring detta. Det var i changelogen för SMF jag noterade att det stod en enda rad kring utf-8 och vart dessa parameters fanns någonstans.

bjorso

  • Global Moderator
  • Newbie
  • *****
  • Posts: 37
    • View Profile
Re: Blev helt tokigt med UTF-8 och Latin1
« Reply #10 on: 2007.05.17, 12:29:48 »
I vart fall är det bra att du hittade orsaken.

Själv har svårt att förstå varför man inte kan lösa teckenproblemen en gång för alla genom att acceptera UTF-8 i program och system. Någon kanske minns att man använde CP-850 i DOS. När svensk Windows dök upp fick den CP-1252 trots att tidiga versioner av Windows endast var grafiska tillägg ovanpå DOS. I OS/2 och eCS använder man fortfarande CP-850 och det fungerar bra, varför kunde i svenska versioner av Windows ha fortsatt med CP-850? Den troliga orsaken verkar vara att stänga vägen för andra program typ Word Perfect för DOS och framtvinga nya program och då företrädesvis från MS, naturligtvis. Det finns dock en del ljuspunkter, t.ex. nya filformat som de XML-baserade i OpenOffice. Då kan man enkelt samarbeta med vem som helst utan att ens veta eller bry sig om datasystem. Ett annat bra exempel är Mozillaprogrammen, de använder UTF-8 internt vilket innebär att ett svensk språkpaket passar på eCS-versioner av programmen trots att de endast är byggda på engelska.

//Björn
« Last Edit: 2007.06.13, 18:16:47 by bjorso »